The company I work for is using ISDN PRI for our phone lines.
We have 5 channels for the ISDN coming in right now. One of these is the D channel though of course.
Cisco 2801 router.
What happens is that I can receive faxes, but when I try to fax out I get the busy reorder signal on the line. Now when I take out my international dialing plan I am able to fax out but when it is in the I get the busy reorder signal.
I did follow this when I originally set this up. After that I had configured the International Dial Plan as shown in the configuration.
Can anyone point me in the right direction? The debug voip ccapi inout shows that when I am trying to dial out it is using the International Dial Plan for some reason.
The current configuration:
controller T1 0/1/0
framing esf
linecode b8zs
pri-group timeslots 20-24
description t1
!
!
!
!
interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$
ip address 172.22.1.52 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
isdn bchan-number-order ascending
no cdp enable
!
ip route 0.0.0.0 0.0.0.0 172.22.1.1
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 5 life 86400 requests 10000
!
!
!
!
control-plane
!
disable-eadi
!
!
voice-port 0/0/0
caller-id enable
!
voice-port 0/0/1
trunk-group 1 2
input gain 6
connection plar 2000
caller-id enable
!
voice-port 0/1/0:23
!
!
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
!
!
!
dial-peer voice 9 pots
destination-pattern 9[2-9]......
incoming called-number .
direct-inward-dial
port 0/1/0:23
!
dial-peer voice 91 pots
destination-pattern 91[2-9]..[2-9]......
incoming called-number .
direct-inward-dial
port 0/1/0:23
prefix 1
!
dial-peer voice 911 pots
destination-pattern 911
incoming called-number .
direct-inward-dial
port 0/1/0:23
forward-digits all
!
dial-peer voice 9911 pots
destination-pattern 9[4,9]11
incoming called-number .
direct-inward-dial
port 0/1/0:23
forward-digits 3
!
dial-peer voice 2000 voip
destination-pattern 2...
progress_ind setup enable 3
session target ipv4:172.22.1.50
incoming called-number 9
dtmf-relay h245-alphanumeric
fax rate disable
no vad
!
dial-peer voice 3000 voip
destination-pattern 3...
progress_ind setup enable 3
session target ipv4:172.22.1.50
incoming called-number 9
dtmf-relay h245-alphanumeric
fax rate disable
no vad
!
dial-peer voice 1581 voip
destination-pattern 1581
progress_ind setup enable 3
session target ipv4:172.22.1.50
incoming called-number 9
dtmf-relay h245-alphanumeric
fax rate disable
no vad
!
dial-peer voice 8577 voip
destination-pattern 8577
progress_ind setup enable 3
session target ipv4:172.22.1.50
incoming called-number 9
dtmf-relay h245-alphanumeric
fax rate disable
no vad
!
dial-peer voice 880 voip
destination-pattern 0880
progress_ind setup enable 3
session target ipv4:172.22.1.50
incoming called-number 9
dtmf-relay h245-alphanumeric
fax rate disable
no vad
!
dial-peer voice 8578 voip
destination-pattern 8578
progress_ind setup enable 3
session target ipv4:172.22.1.50
incoming called-number 9
dtmf-relay h245-alphanumeric
fax rate disable
no vad
!
dial-peer voice 1795 voip
preference 5
destination-pattern 1795
session target ipv4:172.22.1.50
incoming called-number .
dtmf-relay h245-alphanumeric
codec g711ulaw
fax-relay ecm disable
no vad
!
dial-peer voice 5555 pots
destination-pattern 5555
port 0/0/0
!
dial-peer voice 9011 pots
description International Calling
destination-pattern 9
incoming called-number .
direct-inward-dial
port 0/1/0:23
!
We have 5 channels for the ISDN coming in right now. One of these is the D channel though of course.
Cisco 2801 router.
What happens is that I can receive faxes, but when I try to fax out I get the busy reorder signal on the line. Now when I take out my international dialing plan I am able to fax out but when it is in the I get the busy reorder signal.
I did follow this when I originally set this up. After that I had configured the International Dial Plan as shown in the configuration.
Can anyone point me in the right direction? The debug voip ccapi inout shows that when I am trying to dial out it is using the International Dial Plan for some reason.
The current configuration:
controller T1 0/1/0
framing esf
linecode b8zs
pri-group timeslots 20-24
description t1
!
!
!
!
interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$
ip address 172.22.1.52 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
isdn bchan-number-order ascending
no cdp enable
!
ip route 0.0.0.0 0.0.0.0 172.22.1.1
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 5 life 86400 requests 10000
!
!
!
!
control-plane
!
disable-eadi
!
!
voice-port 0/0/0
caller-id enable
!
voice-port 0/0/1
trunk-group 1 2
input gain 6
connection plar 2000
caller-id enable
!
voice-port 0/1/0:23
!
!
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
!
!
!
dial-peer voice 9 pots
destination-pattern 9[2-9]......
incoming called-number .
direct-inward-dial
port 0/1/0:23
!
dial-peer voice 91 pots
destination-pattern 91[2-9]..[2-9]......
incoming called-number .
direct-inward-dial
port 0/1/0:23
prefix 1
!
dial-peer voice 911 pots
destination-pattern 911
incoming called-number .
direct-inward-dial
port 0/1/0:23
forward-digits all
!
dial-peer voice 9911 pots
destination-pattern 9[4,9]11
incoming called-number .
direct-inward-dial
port 0/1/0:23
forward-digits 3
!
dial-peer voice 2000 voip
destination-pattern 2...
progress_ind setup enable 3
session target ipv4:172.22.1.50
incoming called-number 9
dtmf-relay h245-alphanumeric
fax rate disable
no vad
!
dial-peer voice 3000 voip
destination-pattern 3...
progress_ind setup enable 3
session target ipv4:172.22.1.50
incoming called-number 9
dtmf-relay h245-alphanumeric
fax rate disable
no vad
!
dial-peer voice 1581 voip
destination-pattern 1581
progress_ind setup enable 3
session target ipv4:172.22.1.50
incoming called-number 9
dtmf-relay h245-alphanumeric
fax rate disable
no vad
!
dial-peer voice 8577 voip
destination-pattern 8577
progress_ind setup enable 3
session target ipv4:172.22.1.50
incoming called-number 9
dtmf-relay h245-alphanumeric
fax rate disable
no vad
!
dial-peer voice 880 voip
destination-pattern 0880
progress_ind setup enable 3
session target ipv4:172.22.1.50
incoming called-number 9
dtmf-relay h245-alphanumeric
fax rate disable
no vad
!
dial-peer voice 8578 voip
destination-pattern 8578
progress_ind setup enable 3
session target ipv4:172.22.1.50
incoming called-number 9
dtmf-relay h245-alphanumeric
fax rate disable
no vad
!
dial-peer voice 1795 voip
preference 5
destination-pattern 1795
session target ipv4:172.22.1.50
incoming called-number .
dtmf-relay h245-alphanumeric
codec g711ulaw
fax-relay ecm disable
no vad
!
dial-peer voice 5555 pots
destination-pattern 5555
port 0/0/0
!
dial-peer voice 9011 pots
description International Calling
destination-pattern 9
incoming called-number .
direct-inward-dial
port 0/1/0:23
!