Hello,
I have a Cisco 2500 with IOS 21.2 running. I have it connected to my broadband cablemodem and it works like a charm. I would like to lock down the track that passes through it and also host a ftp and webserver. The problem I'm having is when I try to access my server from outside my network, I am unable to get the requested port 80 and 21 request to my internal addresses (192.168.1.*). I pretty sure I can do this with an extended access-list but I am unsure of how do it. I have the following configuration below. Any help is greatly appreciated.
Current configuration : 2206 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname "Cisco-2514"
!
no logging console
enable password ##############
!
ip subnet-zero
!
!
!
!
interface Ethernet0
description Connection to WAN
ip address dhcp
ip nat outside
!
interface Ethernet1
description Connection to LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
interface Serial0
no ip address
shutdown
no fair-queue
!
interface Serial1
no ip address
shutdown
!
ip nat log translations syslog
ip nat inside source list 1 interface Ethernet0 overload
ip classless
ip http server
!
logging 192.168.1.2
access-list 1 permit 192.168.1.0 0.0.0.255
no cdp run
tftp-server flash
tftp-server flash 1
snmp-server community ######## RW
snmp-server community ######## RO
!
line con 0
line aux 0
line vty 0 4
password #################
login
!
end
I have a Cisco 2500 with IOS 21.2 running. I have it connected to my broadband cablemodem and it works like a charm. I would like to lock down the track that passes through it and also host a ftp and webserver. The problem I'm having is when I try to access my server from outside my network, I am unable to get the requested port 80 and 21 request to my internal addresses (192.168.1.*). I pretty sure I can do this with an extended access-list but I am unsure of how do it. I have the following configuration below. Any help is greatly appreciated.
Current configuration : 2206 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname "Cisco-2514"
!
no logging console
enable password ##############
!
ip subnet-zero
!
!
!
!
interface Ethernet0
description Connection to WAN
ip address dhcp
ip nat outside
!
interface Ethernet1
description Connection to LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
interface Serial0
no ip address
shutdown
no fair-queue
!
interface Serial1
no ip address
shutdown
!
ip nat log translations syslog
ip nat inside source list 1 interface Ethernet0 overload
ip classless
ip http server
!
logging 192.168.1.2
access-list 1 permit 192.168.1.0 0.0.0.255
no cdp run
tftp-server flash
tftp-server flash 1
snmp-server community ######## RW
snmp-server community ######## RO
!
line con 0
line aux 0
line vty 0 4
password #################
login
!
end