Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations Westi on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

EtherChannel and 802.1Q Trunking Between Router and Switch 1

Status
Not open for further replies.

yemaya

Technical User
Sep 13, 2006
140
CA
Hi.

This is the first time i do this and before apply this configuration to the route/switch, i need some advice, this is the configuration in both:


Router 2621
Code:
!
!
!
interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 192.168.2.100 255.255.255.0
!         
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 192.168.3.100 255.255.255.0
!
interface FastEthernet0/0.30
 encapsulation dot1Q 30
 ip address 192.168.4.100 255.255.255.0
!
interface FastEthernet0/0.40
 encapsulation dot1Q 40
 ip address 192.168.5.100 255.255.255.0
!
interface FastEthernet0/0.50
 encapsulation dot1Q 50
 ip address 192.168.6.100 255.255.255.0
!
interface FastEthernet0/0.180
 encapsulation dot1Q 180
 ip address 192.168.150.100 255.255.255.0
!
ip http server
ip classless
!         
!
!

Switch 2950
Code:
!
!
interface Port-channel1
 switchport mode trunk
 flowcontrol send off
!
interface FastEthernet0/1
 description "ROUTER-TRUNK"
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet0/2
 switchport access vlan 10
!
interface FastEthernet0/3
 switchport access vlan 10
!
interface FastEthernet0/4
 switchport access vlan 10
!
interface FastEthernet0/5
 switchport access vlan 10
!
interface FastEthernet0/6
 switchport access vlan 20
!
interface FastEthernet0/7
 switchport access vlan 20
!
interface FastEthernet0/8
 switchport access vlan 20
!
interface FastEthernet0/9
 switchport access vlan 20
!
interface FastEthernet0/10
 switchport access vlan 30
!         
interface FastEthernet0/11
 switchport access vlan 30
!
interface FastEthernet0/12
 switchport access vlan 30
!
interface FastEthernet0/13
 switchport access vlan 30
!
interface FastEthernet0/14
 switchport access vlan 40
!
interface FastEthernet0/15
 switchport access vlan 40
!
interface FastEthernet0/16
 switchport access vlan 40
!
interface FastEthernet0/17
 switchport access vlan 40
!
interface FastEthernet0/18
 switchport access vlan 50
!
interface FastEthernet0/19
 switchport access vlan 50
!
interface FastEthernet0/20
 switchport access vlan 50
!
interface FastEthernet0/21
 switchport access vlan 50
!
interface FastEthernet0/22
 switchport access vlan 180
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
 ip address 192.168.1.200 255.255.255.0
 no ip route-cache
 shutdown
!
interface Vlan10
 ip address 192.168.2.100 255.255.255.0
 no ip route-cache
 shutdown
!
interface Vlan20
 ip address 192.168.3.100 255.255.255.0
 no ip route-cache
 shutdown
!
interface Vlan30
 ip address 192.168.4.100 255.255.255.0
 no ip route-cache
 shutdown
!
interface Vlan40
 ip address 192.168.5.100 255.255.255.0
 no ip route-cache
 shutdown
!
interface Vlan50
 ip address 192.168.6.100 255.255.255.0
 no ip route-cache
 shutdown
!
interface Vlan180
 ip address 192.168.150.100 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.1.1
no ip http server
no cdp run
!

The router is connected to internet with the interface 0/0 and i have running DHCP and NAT on the same router, i created 6 VLANs for differents PCs, 2 servers, 5 Workstations and VLAN 180 goes to one linksys wireless router to provide internet to two laptops.

Thanks in advanced
 
Hi guys;

Any input in this?, i'm having problem with DHCP, after few minutes it stops leasing ip address to the PC's behind the vlans and no internet for those PC's.

Sorry but i need this done and i'll appreciate any help.
 
A cisco router can do DHCP but I've heard it's kind of a kludge. Rather than use the router, why not put up a real DCHP server? It won't cost you anything, just an old machine and a copy of linux. And, you'll have to setup an ip helper address.

If linux scares you or something, then we'll need some more information. Your best bet would be, during a period of low usage, to issue a:
debug ip dhcp server events
debug ip dhcp server packets
(Note - be ready to type in and "un all" if there is too much output)

Cisco pings the address twice to see if it's in use. If it doesn't get a reply for some reason, it will give the address to somebody else.
 
Hi.

You are right, i have a real IBM server and i'm going to setup the DHCP server there with MS server 2003, i'll do that and i'll let you know guys, but, if anybody knows how to fix my problem with my DHCP router i'll appreciate it.

Thanks guys.
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top