Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations Westi on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

EIGRP Summarization

Status
Not open for further replies.

wiredtek

Technical User
Feb 4, 2010
3
US
I am having trouble configuring EIGRP summarization. Attached is the network diagram. I am using the CCNA virtual lab to configure this.

Router configs:

R1

--snip--
interface Serial0/0/0
ip address 192.168.1.34 255.255.255.252
no ip directed-broadcast
!
interface Serial0/0/1
ip address 192.168.1.37 255.255.255.252
no ip directed-broadcast
clockrate 2000000
!
--snip--

R1#sh ip eigrp top
IP-EIGRP Topology Table for AS(1)/ID(192.168.1.34)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 10.10.10.8/29, 1 successors, FD is 2172416
via 192.168.1.38 (2172416/28160), Serial0/0/0
P 192.168.1.32/30, 1 successors, FD is 2172416
via Connected, Serial0/0/0
P 192.168.1.36/30, 1 successors, FD is 2172416
via Connected, Serial0/0/1
P 192.168.1.40/30, 1 successors, FD is 2172416
via 192.168.1.38 (2172416/28160), Serial0/0/0
P 10.10.10.0/29, 1 successors, FD is 2172416
via 192.168.1.33 (2172416/28160), Serial0/0/0
R1#


interface Serial0/0/0
ip address 192.168.1.38 255.255.255.252
no ip directed-broadcast
!
interface Serial0/0/1
ip address 192.168.1.41 255.255.255.252
no ip directed-broadcast
clockrate 2000000
!
router eigrp 1
network 192.168.1.0

R3>en
R3#sh ip eigrp top
IP-EIGRP Topology Table for AS(1)/ID(192.168.1.38)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 192.168.1.32/30, 1 successors, FD is 2172416
via 192.168.1.37 (2172416/28160), Serial0/0/1
P 10.10.10.8/29, 1 successors, FD is 2172416
via 192.168.1.42 (2172416/28160), Serial0/0/1
P 192.168.1.36/30, 1 successors, FD is 2172416
via Connected, Serial0/0/0
P 192.168.1.40/30, 1 successors, FD is 2172416
via Connected, Serial0/0/1
P 10.10.10.0/29, 1 successors, FD is 2172416
via 192.168.1.37 (2172416/28160), Serial0/0/1
R3#

Here is one core router configuration that should be summarizing that block:




R2 Con0 is now available



Press RETURN to get started!



R2>en
R2#sh run

Building configuration...

Current configuration : 874 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
!
!
no aaa new-model
!
!
ip cef
!
!
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.248
no ip directed-broadcast
ip summary-address eigrp 1 192.168.1.32 255.255.255.240
!
interface FastEthernet0/1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/0/0
ip address 192.168.1.33 255.255.255.252
no ip directed-broadcast
clockrate 2000000
!
interface Serial0/0/1
no ip address
no ip directed-broadcast
shutdown
clockrate 2000000
!
interface Serial0/1/0
no ip address
no ip directed-broadcast
shutdown
clockrate 2000000
!
interface Serial0/1/1
no ip address
no ip directed-broadcast
shutdown
clockrate 2000000
!
router eigrp 1
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
ip classless
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
line vty 5 1180
login
!
scheduler allocate 20000 1000
!
end

R2#

R2>en
R2#sh ip eigrp top
IP-EIGRP Topology Table for AS(1)/ID(192.168.1.33)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 10.10.10.8/29, 1 successors, FD is 2172416
via null (2172416/28160), FastEthernet0/8
P 192.168.1.32/30, 1 successors, FD is 2172416
via Connected, Serial0/0/0
P 192.168.1.36/30, 1 successors, FD is 2172416
via 192.168.1.34 (2172416/28160), Serial0/0/0
P 192.168.1.40/30, 1 successors, FD is 2172416
via 192.168.1.34 (2172416/28160), Serial0/0/0
P 10.10.10.0/29, 1 successors, FD is 2172416
via Connected, FastEthernet0/0
R2#

R2>en
R2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR, P - periodic downloaded static route
T - traffic engineered route

Gateway of last resort is not set

10.0.0.0/29 is subnetted, 2 subnets
D 10.10.10.8 [90/2172416] via 10.10.10.9, 01:31:30, FastEthernet0/0
C 10.10.10.0 is directly connected, FastEthernet0/0
192.168.1.0/30 is subnetted, 3 subnets
C 192.168.1.32 is directly connected, Serial0/0/0
D 192.168.1.36 [90/2172416] via 192.168.1.34, 01:31:30, Serial0/0/0
D 192.168.1.40 [90/2172416] via 192.168.1.34, 01:31:30, Serial0/0/0
R2#
 
I started used a 16 block for the /30 addresses between each serial link. The starting IP is 192.168.1.33, with the network ID being 192.168.1.32.

There is complete connectivity between all devices, but it will not summarize all of the /30's into a single 16 block of .240.

I added in the "auto-summary" command on R1 and R3, and "no auto-summary" on R2 and R4 anyway but it didn't change anything. I'm not sure what I'm missing.
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top