I have a 1605 R that I need to get hooked up to my new DSL line. It currently is connected to a Dial_up account through a WAN card. What I would like to do is connect eth0 to my DSL modem, and leave eth1 connected to my Local LAN. I am serioulsy confused as to what to change. I have 2 static IP address from the DSL ISP that I need to map to 2 devices inside my LAN. Here is a copy of my running-config any ideas about what to change would be great. The two IP address on ETH0 are the DSL provided ones.
I will provide any more info as needed.
Thanks in Advance.
Current configuration:
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ********
!
logging buffered 4096 debugging
no logging console
enable secret 5 **************
enable password ********
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
ip domain-name mtiwi.com
ip name-server 206.40.xxx.xxx
ip name-server 206.40.xxx.xxx
!
ip inspect name firewall tcp timeout 3600
ip inspect name firewall udp timeout 3600
ip inspect name firewall tftp timeout 30
ip inspect name firewall h323 timeout 3600
ip inspect name firewall realaudio timeout 3600
ip inspect name firewall rcmd timeout 3600
ip inspect name firewall cuseeme timeout 3600
ip inspect name firewall ftp timeout 3600
ip inspect name firewall rtsp timeout 3600
ip inspect name firewall netshow timeout 3600
chat-script dial "" AT OK "\patdt\T" TIMEOUT 60 CONNECT \C
!
!
!
interface Ethernet0
ip address xxx.xxx.xxx.100 255.255.255.0 secondary
ip address xxx.xxx.xxx.99 255.255.255.0
ip access-group DSL_inbound in
!
interface Ethernet1
ip address 10.xxx.xxx.254 255.255.255.0
ip nat inside
ip inspect firewall in
!
interface Serial0
physical-layer async
no ip address
ip nat outside
encapsulation ppp
dialer in-band
dialer pool-member 1
async mode dedicated
!
interface Dialer1
ip address negotiated
ip access-group inbound in
ip nat outside
encapsulation ppp
dialer remote-name isp
dialer pool 1
dialer idle-timeout 200000
dialer string 6179019
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname **********
ppp chap password **********
ppp pap sent-username ******** password ***********
!
router rip
timers basic 120 480 600 720
network 206.xxx.xxx.0
!
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source static tcp 10.xxx.xxx.xxx 3011 206.xxx.xxx.xxx 3011 extendable
ip nat inside source static tcp 10.xxx.xxx.xxx 80 206.xxx.xxx.xxx 400 extendable
ip nat inside source static tcp 10.xxx.xxx.xxx 80 206.xxx.xxx.xxx 80 extendable
ip nat inside source static tcp 10.xxx.xxx.xxx 25 206.xxx.xxx.xxx 25 extendable
ip nat inside source static tcp 10.xxx.xxx.xxx 23 206.xxx.xxx.xxx 23 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
!
dialer-list 1 protocol ip permit
route-map jace permit 10
!
line con 0
exec-timeout 0 0
password **********
login
transport input none
stopbits 1
line 1
autoselect ppp
script dialer dial
modem InOut
transport input all
speed 115200
flowcontrol hardware
line vty 0 4
exec-timeout 20 0
password *************
login
!
end
I will provide any more info as needed.
Thanks in Advance.
Current configuration:
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ********
!
logging buffered 4096 debugging
no logging console
enable secret 5 **************
enable password ********
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
ip domain-name mtiwi.com
ip name-server 206.40.xxx.xxx
ip name-server 206.40.xxx.xxx
!
ip inspect name firewall tcp timeout 3600
ip inspect name firewall udp timeout 3600
ip inspect name firewall tftp timeout 30
ip inspect name firewall h323 timeout 3600
ip inspect name firewall realaudio timeout 3600
ip inspect name firewall rcmd timeout 3600
ip inspect name firewall cuseeme timeout 3600
ip inspect name firewall ftp timeout 3600
ip inspect name firewall rtsp timeout 3600
ip inspect name firewall netshow timeout 3600
chat-script dial "" AT OK "\patdt\T" TIMEOUT 60 CONNECT \C
!
!
!
interface Ethernet0
ip address xxx.xxx.xxx.100 255.255.255.0 secondary
ip address xxx.xxx.xxx.99 255.255.255.0
ip access-group DSL_inbound in
!
interface Ethernet1
ip address 10.xxx.xxx.254 255.255.255.0
ip nat inside
ip inspect firewall in
!
interface Serial0
physical-layer async
no ip address
ip nat outside
encapsulation ppp
dialer in-band
dialer pool-member 1
async mode dedicated
!
interface Dialer1
ip address negotiated
ip access-group inbound in
ip nat outside
encapsulation ppp
dialer remote-name isp
dialer pool 1
dialer idle-timeout 200000
dialer string 6179019
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname **********
ppp chap password **********
ppp pap sent-username ******** password ***********
!
router rip
timers basic 120 480 600 720
network 206.xxx.xxx.0
!
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source static tcp 10.xxx.xxx.xxx 3011 206.xxx.xxx.xxx 3011 extendable
ip nat inside source static tcp 10.xxx.xxx.xxx 80 206.xxx.xxx.xxx 400 extendable
ip nat inside source static tcp 10.xxx.xxx.xxx 80 206.xxx.xxx.xxx 80 extendable
ip nat inside source static tcp 10.xxx.xxx.xxx 25 206.xxx.xxx.xxx 25 extendable
ip nat inside source static tcp 10.xxx.xxx.xxx 23 206.xxx.xxx.xxx 23 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
!
dialer-list 1 protocol ip permit
route-map jace permit 10
!
line con 0
exec-timeout 0 0
password **********
login
transport input none
stopbits 1
line 1
autoselect ppp
script dialer dial
modem InOut
transport input all
speed 115200
flowcontrol hardware
line vty 0 4
exec-timeout 20 0
password *************
login
!
end