I am installing a Cisco 837 at a small remote office, I want to get an outside IP address and DNS from the ISP and also run a DHCP service for clients connecting to the router. Apart from the DNS the config works well. Has anyone got an suggestions? Also can you connect a VPN tunnel fro a 837 to a PIX 515?
Config as follows:
version 12.3
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname CT-RR-837
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip dhcp excluded-address 10.10.10.1
!
!
ip dhcp pool RR
import all
network 172.18.28.0 255.255.255.0
default-router 172.18.28.250
dns-server 172.18.28.250
lease 7 23
!
!
ip audit notify log
ip audit po max-events 100
ip ssh break-string
no ftp-server write-enable
no scripting tcl init
no scripting tcl encdir
!
!
!
no crypto isakmp enable
!
!
!
!
interface Ethernet0
ip address 172.18.28.250 255.255.255.0
ip nat inside
no cdp enable
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname ctukitteam3@plusdsl.net
ppp chap password 7 xxxxxxx
ppp pap sent-username ct@plusdsl.net password 7 xxxxxx
ppp ipcp dns request
ppp ipcp wins request
!
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
no ip http secure-server
!
!
access-list 1 remark DIALLER
access-list 1 permit 172.18.28.0 0.0.0.255
!
control-plane
!
!
line con 0
exec-timeout 120 0
no modem enable
transport preferred all
transport output all
stopbits 1
line aux 0
transport preferred all
transport output all
line vty 0 4
exec-timeout 120 0
login local
length 0
transport preferred all
transport input all
transport output all
!
scheduler max-task-time 5000
!
end
Config as follows:
version 12.3
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname CT-RR-837
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip dhcp excluded-address 10.10.10.1
!
!
ip dhcp pool RR
import all
network 172.18.28.0 255.255.255.0
default-router 172.18.28.250
dns-server 172.18.28.250
lease 7 23
!
!
ip audit notify log
ip audit po max-events 100
ip ssh break-string
no ftp-server write-enable
no scripting tcl init
no scripting tcl encdir
!
!
!
no crypto isakmp enable
!
!
!
!
interface Ethernet0
ip address 172.18.28.250 255.255.255.0
ip nat inside
no cdp enable
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname ctukitteam3@plusdsl.net
ppp chap password 7 xxxxxxx
ppp pap sent-username ct@plusdsl.net password 7 xxxxxx
ppp ipcp dns request
ppp ipcp wins request
!
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
no ip http secure-server
!
!
access-list 1 remark DIALLER
access-list 1 permit 172.18.28.0 0.0.0.255
!
control-plane
!
!
line con 0
exec-timeout 120 0
no modem enable
transport preferred all
transport output all
stopbits 1
line aux 0
transport preferred all
transport output all
line vty 0 4
exec-timeout 120 0
login local
length 0
transport preferred all
transport input all
transport output all
!
scheduler max-task-time 5000
!
end