Hi Guys,
I will be starting a CCNA course next month and have bought myself a 2514 to use on my broadband. I am going to use it to replace the linux router I have been running.
I have come across a problem that I hope someone on here can help me with.
I am setting the router up in stages and have been configuring ethernet 0 to obtain its IP address etc from my ISP via DHCP. If I connect it to my existing router it gets an IP address and will ping various web servers etc.
However, if I connect it directly to my DSL modem it obtains the correct IP address but fails to resolve addresses and it cant ping the DNS server, dhcp server etc that I know are there because its got an IP address from them.
Heres what I have in my config:
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
enable secret
enable password
!
ip subnet-zero
!
!
!
!
interface Ethernet0
description WAN
ip address dhcp
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
ip classless
no ip http server
ip pim bidir-enable
!
!
line con 0
line aux 0
line vty 0 4
exec-timeout 30 0
password
login
!
end
I will be adding NAT and firewalling when I get this sorted.
Any help will be appreciated.
Thanks
Jon
I will be starting a CCNA course next month and have bought myself a 2514 to use on my broadband. I am going to use it to replace the linux router I have been running.
I have come across a problem that I hope someone on here can help me with.
I am setting the router up in stages and have been configuring ethernet 0 to obtain its IP address etc from my ISP via DHCP. If I connect it to my existing router it gets an IP address and will ping various web servers etc.
However, if I connect it directly to my DSL modem it obtains the correct IP address but fails to resolve addresses and it cant ping the DNS server, dhcp server etc that I know are there because its got an IP address from them.
Heres what I have in my config:
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
enable secret
enable password
!
ip subnet-zero
!
!
!
!
interface Ethernet0
description WAN
ip address dhcp
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
ip classless
no ip http server
ip pim bidir-enable
!
!
line con 0
line aux 0
line vty 0 4
exec-timeout 30 0
password
login
!
end
I will be adding NAT and firewalling when I get this sorted.
Any help will be appreciated.
Thanks
Jon