Hi I'm trying to set up a cicso 1841 router on DHCP but cant get the IP address to the interface
Primary-Router#
Primary-Router#sh ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES DHCP up up
FastEthernet0/1 192.168.1.254 YES manual up up
FastEthernet0/0/0 unassigned YES unset up down
FastEthernet0/0/1 unassigned YES unset up down
FastEthernet0/0/2 unassigned YES unset up down
FastEthernet0/0/3 unassigned YES unset up down
Vlan1 unassigned YES unset up down
NVI0 unassigned NO unset up up
Building configuration...
Current configuration : 1359 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Primary-Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$LGru$5elYlxvWx6nJELHjZcyJe.
enable password o*******
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.250 192.168.1.255
!
ip dhcp pool LAN_NETWORK
network 192.168.1.0 255.255.255.0
default-router 192.168.1.254
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description LAN_Connection
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed 100
!
interface FastEthernet0/0/0
!
interface FastEthernet0/0/1
!
interface FastEthernet0/0/2
!
interface FastEthernet0/0/3
!
interface Vlan1
no ip address
!
ip forward-protocol nd
!
!
Primary-Router#
Im not sure what I did diffrent on this router, I have a 2651xm that has the same config and that one is getting the DHCP address.
2651xm
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 75.112.23.26 YES DHCP up up
Serial0/0 unassigned YES unset administratively down down
FastEthernet0/1 192.168.1.254 YES manual up up
Serial0/1 unassigned YES unset administratively down down
Serial0/2 unassigned YES unset administratively down down
Serial0/3 unassigned YES unset administratively down down
NVI0 unassigned NO unset up up
The above sh ip int brief output from 2651xm shows ip address on fa0/0
Any suggestions?
Thanks
Primary-Router#
Primary-Router#sh ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES DHCP up up
FastEthernet0/1 192.168.1.254 YES manual up up
FastEthernet0/0/0 unassigned YES unset up down
FastEthernet0/0/1 unassigned YES unset up down
FastEthernet0/0/2 unassigned YES unset up down
FastEthernet0/0/3 unassigned YES unset up down
Vlan1 unassigned YES unset up down
NVI0 unassigned NO unset up up
Building configuration...
Current configuration : 1359 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Primary-Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$LGru$5elYlxvWx6nJELHjZcyJe.
enable password o*******
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.250 192.168.1.255
!
ip dhcp pool LAN_NETWORK
network 192.168.1.0 255.255.255.0
default-router 192.168.1.254
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description LAN_Connection
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed 100
!
interface FastEthernet0/0/0
!
interface FastEthernet0/0/1
!
interface FastEthernet0/0/2
!
interface FastEthernet0/0/3
!
interface Vlan1
no ip address
!
ip forward-protocol nd
!
!
Primary-Router#
Im not sure what I did diffrent on this router, I have a 2651xm that has the same config and that one is getting the DHCP address.
2651xm
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 75.112.23.26 YES DHCP up up
Serial0/0 unassigned YES unset administratively down down
FastEthernet0/1 192.168.1.254 YES manual up up
Serial0/1 unassigned YES unset administratively down down
Serial0/2 unassigned YES unset administratively down down
Serial0/3 unassigned YES unset administratively down down
NVI0 unassigned NO unset up up
The above sh ip int brief output from 2651xm shows ip address on fa0/0
Any suggestions?
Thanks