Hi,
I'm trying to set up a 2503 as a DHCP client for Rogers (Canada). But for some reasons it does not work. This is the config:
ids_2500_router_2#sho conf
Using 1309 out of 32762 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service udp-small-servers
!
hostname ids_2500_router_2
!
enable secret bla, bla, bla
enable password 7 bla, bla, bla
!
username XXX password 7 YYYYY
!
!
!
!
ip subnet-zero
!
isdn switch-type ntt
!
!
!
!
!
interface Ethernet0
ip address dhcp
ip nat outside
no ip route-cache
no ip mroute-cache
no cdp enable
!
interface Serial0
ip address 10.2.3.2 255.255.255.252
ip nat inside
no ip route-cache
no ip mroute-cache
down-when-looped
clockrate 2000000
!
interface Serial1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
!
interface BRI0
no ip address
encapsulation ppp
no ip route-cache
no ip mroute-cache
shutdown
dialer idle-timeout 60
dialer string 08912184575
dialer-group 1
isdn switch-type ntt
!
router eigrp 1
network 10.0.0.0
!
ip nat inside source list 100 interface Ethernet0 overload
no ip classless
no ip http server
!
access-list 99 permit 192.168.2.70
access-list 100 permit ip any any log
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 10 10
transport input none
line aux 0
line vty 0 4
password 7 15060E000A2F3F643B362627
login local
!
end
This is the output of debug:
3d09h: DHCP: DHCP client process started: 10
3d09h: DHCP: allocate request
3d09h: DHCP: new entry. add to queue
3d09h: DHCP: SDiscover attempt # 1 for entry:
3d09h: Temp IP addr: 0.0.0.0 for peer on Interface: Ethernet0
3d09h: Temp sub net mask: 0.0.0.0
3d09h: DHCP Lease server: 0.0.0.0, state: 1 Selecting
3d09h: DHCP transaction id: 549
3d09h: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
3d09h: Next timer fires after: 00:00:02
3d09h: Retry count: 1 Client-ID: cisco-0000.0c3e.72c6-Et0
3d09h: DHCP: SDiscover: sending 297 byte length DHCP packet
3d09h: DHCP: SDiscover 297 bytes
3d09h: B'cast on Ethernet0 interface from 0.0.0.0
3d09h: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
3d09h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to up
3d09h: DHCP: SDiscover attempt # 2 for entry:
3d09h: Temp IP addr: 0.0.0.0 for peer on Interface: Ethernet0
3d09h: Temp sub net mask: 0.0.0.0
3d09h: DHCP Lease server: 0.0.0.0, state: 1 Selecting
3d09h: DHCP transaction id: 549
3d09h: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
3d09h: Next timer fires after: 00:00:02
3d09h: Retry count: 2 Client-ID: cisco-0000.0c3e.72c6-Et0
3d09h: DHCP: SDiscover: sending 297 byte length DHCP packet
3d09h: DHCP: SDiscover 297 bytes
3d09h: B'cast on Ethernet0 interface from 0.0.0.0
3d09h: DHCP: SDiscover attempt # 3 for entry:
3d09h: Temp IP addr: 0.0.0.0 for peer on Interface: Ethernet0
3d09h: Temp sub net mask: 0.0.0.0
3d09h: DHCP Lease server: 0.0.0.0, state: 1 Selecting
3d09h: DHCP transaction id: 549
3d09h: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
3d09h: Next timer fires after: 00:00:02
3d09h: Retry count: 3 Client-ID: cisco-0000.0c3e.72c6-Et0
3d09h: DHCP: SDiscover: sending 297 byte length DHCP packet
3d09h: DHCP: SDiscover 297 bytes
3d09h: B'cast on Ethernet0 interface from 0.0.0.0
3d09h: DHCP: QScan: Timed out Selecting state%Unknown DHCP problem.. No allocation possible
3d09h: DHCP: allocate request
3d09h: DHCP: zapping entry in DHC_PURGING state for Et0
3d09h: DHCP: new entry. add to queue
3d09h: DHCP: SDiscover attempt # 1 for entry:
3d09h: Temp IP addr: 0.0.0.0 for peer on Interface: Ethernet0
3d09h: Temp sub net mask: 0.0.0.0
3d09h: DHCP Lease server: 0.0.0.0, state: 1 Selecting
3d09h: DHCP transaction id: 54A
3d09h: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
3d09h: Next timer fires after: 00:00:02
3d09h: Retry count: 1 Client-ID: cisco-0000.0c3e.72c6-Et0
3d09h: DHCP: SDiscover: sending 297 byte length DHCP packet
3d09h: DHCP: SDiscover 297 bytes
3d09h: B'cast on Ethernet0 interface from 0.0.0.0
3d09h: DHCP: SDiscover attempt # 2 for entry:
3d09h: Temp IP addr: 0.0.0.0 for peer on Interface: Ethernet0
3d09h: Temp sub net mask: 0.0.0.0
3d09h: DHCP Lease server: 0.0.0.0, state: 1 Selecting
3d09h: DHCP transaction id: 54A
3d09h: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
3d09h: Next timer fires after: 00:00:02
3d09h: Retry count: 2 Client-ID: cisco-0000.0c3e.72c6-Et0
3d09h: DHCP: SDiscover: sending 297 byte length DHCP packet
3d09h: DHCP: SDiscover 297 bytes
3d09h: B'cast on Ethernet0 interface from 0.0.0.0
3d09h: DHCP: SDiscover attempt # 3 for entry:
3d09h: Temp IP addr: 0.0.0.0 for peer on Interface: Ethernet0
3d09h: Temp sub net mask: 0.0.0.0
3d09h: DHCP Lease server: 0.0.0.0, state: 1 Selecting
3d09h: DHCP transaction id: 54A
3d09h: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
3d09h: Next timer fires after: 00:00:02
3d09h: Retry count: 3 Client-ID: cisco-0000.0c3e.72c6-Et0
3d09h: DHCP: SDiscover: sending 297 byte length DHCP packet
3d09h: DHCP: SDiscover 297 bytes
3d09h: B'cast on Ethernet0 interface from 0.0.0.0
3d09h: DHCP: QScan: Timed out Selecting state%Unknown DHCP problem.. No allocation possible
3d09h: %SEC-6-IPACCESSLOGP: list 100 permitted udp 0.0.0.0(0) -> 255.255.255.255(0), 6 pa
a.s.o
Any ideeas?
Thanks,
SS
I'm trying to set up a 2503 as a DHCP client for Rogers (Canada). But for some reasons it does not work. This is the config:
ids_2500_router_2#sho conf
Using 1309 out of 32762 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service udp-small-servers
!
hostname ids_2500_router_2
!
enable secret bla, bla, bla
enable password 7 bla, bla, bla
!
username XXX password 7 YYYYY
!
!
!
!
ip subnet-zero
!
isdn switch-type ntt
!
!
!
!
!
interface Ethernet0
ip address dhcp
ip nat outside
no ip route-cache
no ip mroute-cache
no cdp enable
!
interface Serial0
ip address 10.2.3.2 255.255.255.252
ip nat inside
no ip route-cache
no ip mroute-cache
down-when-looped
clockrate 2000000
!
interface Serial1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
!
interface BRI0
no ip address
encapsulation ppp
no ip route-cache
no ip mroute-cache
shutdown
dialer idle-timeout 60
dialer string 08912184575
dialer-group 1
isdn switch-type ntt
!
router eigrp 1
network 10.0.0.0
!
ip nat inside source list 100 interface Ethernet0 overload
no ip classless
no ip http server
!
access-list 99 permit 192.168.2.70
access-list 100 permit ip any any log
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 10 10
transport input none
line aux 0
line vty 0 4
password 7 15060E000A2F3F643B362627
login local
!
end
This is the output of debug:
3d09h: DHCP: DHCP client process started: 10
3d09h: DHCP: allocate request
3d09h: DHCP: new entry. add to queue
3d09h: DHCP: SDiscover attempt # 1 for entry:
3d09h: Temp IP addr: 0.0.0.0 for peer on Interface: Ethernet0
3d09h: Temp sub net mask: 0.0.0.0
3d09h: DHCP Lease server: 0.0.0.0, state: 1 Selecting
3d09h: DHCP transaction id: 549
3d09h: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
3d09h: Next timer fires after: 00:00:02
3d09h: Retry count: 1 Client-ID: cisco-0000.0c3e.72c6-Et0
3d09h: DHCP: SDiscover: sending 297 byte length DHCP packet
3d09h: DHCP: SDiscover 297 bytes
3d09h: B'cast on Ethernet0 interface from 0.0.0.0
3d09h: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
3d09h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to up
3d09h: DHCP: SDiscover attempt # 2 for entry:
3d09h: Temp IP addr: 0.0.0.0 for peer on Interface: Ethernet0
3d09h: Temp sub net mask: 0.0.0.0
3d09h: DHCP Lease server: 0.0.0.0, state: 1 Selecting
3d09h: DHCP transaction id: 549
3d09h: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
3d09h: Next timer fires after: 00:00:02
3d09h: Retry count: 2 Client-ID: cisco-0000.0c3e.72c6-Et0
3d09h: DHCP: SDiscover: sending 297 byte length DHCP packet
3d09h: DHCP: SDiscover 297 bytes
3d09h: B'cast on Ethernet0 interface from 0.0.0.0
3d09h: DHCP: SDiscover attempt # 3 for entry:
3d09h: Temp IP addr: 0.0.0.0 for peer on Interface: Ethernet0
3d09h: Temp sub net mask: 0.0.0.0
3d09h: DHCP Lease server: 0.0.0.0, state: 1 Selecting
3d09h: DHCP transaction id: 549
3d09h: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
3d09h: Next timer fires after: 00:00:02
3d09h: Retry count: 3 Client-ID: cisco-0000.0c3e.72c6-Et0
3d09h: DHCP: SDiscover: sending 297 byte length DHCP packet
3d09h: DHCP: SDiscover 297 bytes
3d09h: B'cast on Ethernet0 interface from 0.0.0.0
3d09h: DHCP: QScan: Timed out Selecting state%Unknown DHCP problem.. No allocation possible
3d09h: DHCP: allocate request
3d09h: DHCP: zapping entry in DHC_PURGING state for Et0
3d09h: DHCP: new entry. add to queue
3d09h: DHCP: SDiscover attempt # 1 for entry:
3d09h: Temp IP addr: 0.0.0.0 for peer on Interface: Ethernet0
3d09h: Temp sub net mask: 0.0.0.0
3d09h: DHCP Lease server: 0.0.0.0, state: 1 Selecting
3d09h: DHCP transaction id: 54A
3d09h: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
3d09h: Next timer fires after: 00:00:02
3d09h: Retry count: 1 Client-ID: cisco-0000.0c3e.72c6-Et0
3d09h: DHCP: SDiscover: sending 297 byte length DHCP packet
3d09h: DHCP: SDiscover 297 bytes
3d09h: B'cast on Ethernet0 interface from 0.0.0.0
3d09h: DHCP: SDiscover attempt # 2 for entry:
3d09h: Temp IP addr: 0.0.0.0 for peer on Interface: Ethernet0
3d09h: Temp sub net mask: 0.0.0.0
3d09h: DHCP Lease server: 0.0.0.0, state: 1 Selecting
3d09h: DHCP transaction id: 54A
3d09h: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
3d09h: Next timer fires after: 00:00:02
3d09h: Retry count: 2 Client-ID: cisco-0000.0c3e.72c6-Et0
3d09h: DHCP: SDiscover: sending 297 byte length DHCP packet
3d09h: DHCP: SDiscover 297 bytes
3d09h: B'cast on Ethernet0 interface from 0.0.0.0
3d09h: DHCP: SDiscover attempt # 3 for entry:
3d09h: Temp IP addr: 0.0.0.0 for peer on Interface: Ethernet0
3d09h: Temp sub net mask: 0.0.0.0
3d09h: DHCP Lease server: 0.0.0.0, state: 1 Selecting
3d09h: DHCP transaction id: 54A
3d09h: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
3d09h: Next timer fires after: 00:00:02
3d09h: Retry count: 3 Client-ID: cisco-0000.0c3e.72c6-Et0
3d09h: DHCP: SDiscover: sending 297 byte length DHCP packet
3d09h: DHCP: SDiscover 297 bytes
3d09h: B'cast on Ethernet0 interface from 0.0.0.0
3d09h: DHCP: QScan: Timed out Selecting state%Unknown DHCP problem.. No allocation possible
3d09h: %SEC-6-IPACCESSLOGP: list 100 permitted udp 0.0.0.0(0) -> 255.255.255.255(0), 6 pa
a.s.o
Any ideeas?
Thanks,
SS