Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations IamaSherpa on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

configuring ppp connection

Status
Not open for further replies.

alfwro

IS-IT--Management
Sep 4, 2007
7
here it is:
two routers connected via serial cable,

router 1 config:
Building configuration...

Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname r1
!
!
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
ip address 10.1.1.1 255.255.255.0
encapsulation ppp
!
interface Serial1
no ip address
shutdown
!
no ip classless
!
!
line con 0
line aux 0
line vty 0 4
login
!
end


router 2 config:
Building configuration...

Current configuration : 451 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2
!
!
ip subnet-zero
!
!
!
!
!
!
!
interface BRI0
no ip address
shutdown
!
--More--
interface FastEthernet0
no ip address
shutdown
speed auto
!
interface Serial0
ip address 10.1.1.2 255.255.255.0
encapsulation ppp
!
ip classless
no ip http server
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end


in theory that should work,
and here is the result of "debug ppp negotiation" command:
......
Se0 LCP: TIMEout: Time 0x19E5C8 State REQsent
Se0 LCP: O CONFREQ [REQsent] id 5 len 10
Se0 LCP: MagicNumber 0x508D1B6B (0x0506508D1B6B)
Se0 LCP: TIMEout: Time 0x19ED98 State REQsent
Se0 LCP: O CONFREQ [REQsent] id 6 len 10
Se0 LCP: MagicNumber 0x508D1B6B (0x0506508D1B6B)
Se0 LCP: TIMEout: Time 0x19F56C State REQsent
Se0 LCP: O CONFREQ [REQsent] id 7 len 10
Se0 LCP: MagicNumber 0x508D1B6B (0x0506508D1B6B)
Se0 LCP: TIMEout: Time 0x19FD40 State REQsent
Se0 LCP: O CONFREQ [REQsent] id 8 len 10
Se0 LCP: MagicNumber 0x508D1B6B (0x0506508D1B6B)
Se0 LCP: TIMEout: Time 0x1A0514 State REQsent
Se0 LCP: State is Listen
Se0 LCP: TIMEout: Time 0x1A7A5C State Listen
Se0 LCP: O CONFREQ [Listen] id 9 len 10
Se0 LCP: MagicNumber 0x508DE6F0 (0x0506508DE6F0)
Se0 LCP: TIMEout: Time 0x1A825C State REQsent
Se0 LCP: O CONFREQ [REQsent] id 10 len 10
Se0 LCP: MagicNumber 0x508DE6F0 (0x0506508DE6F0)
Se0 LCP: TIMEout: Time 0x1A8A30 State REQsent
Se0 LCP: O CONFREQ [REQsent] id 11 len 10
Se0 LCP: MagicNumber 0x508DE6F0 (0x0506508DE6F0)
Se0 LCP: TIMEout: Time 0x1A9204 State REQsent
Se0 LCP: O CONFREQ [REQsent] id 12 len 10
Se0 LCP: MagicNumber 0x508DE6F0 (0x0506508DE6F0)
Se0 LCP: TIMEout: Time 0x1A99D8 State REQsent
Se0 LCP: O CONFREQ [REQsent] id 13 len 10
Se0 LCP: MagicNumber 0x508DE6F0 (0x0506508DE6F0)
Se0 LCP: TIMEout: Time 0x1AA1AC State REQsent
Se0 LCP: O CONFREQ [REQsent] id 14 len 10
Se0 LCP: MagicNumber 0x508DE6F0 (0x0506508DE6F0)
Se0 LCP: TIMEout: Time 0x1AA994 State REQsent
Se0 LCP: O CONFREQ [REQsent] id 15 len 10
Se0 LCP: MagicNumber 0x508DE6F0 (0x0506508DE6F0)
Se0 LCP: TIMEout: Time 0x1AB168 State REQsent
Se0 LCP: O CONFREQ [REQsent] id 16 len 10
Se0 LCP: MagicNumber 0x508DE6F0 (0x0506508DE6F0)
Se0 LCP: TIMEout: Time 0x1AB93C State REQsent
Se0 LCP: O CONFREQ [REQsent] id 17 len 10
Se0 LCP: MagicNumber 0x508DE6F0 (0x0506508DE6F0)
Se0 LCP: TIMEout: Time 0x1AC110 State REQsent
..... and so on...

where is the problem and how can I fix it.

Thanks
Andre

 
On Router 1

interface Serial0
ip address 10.1.1.1 255.255.255.0
encapsulation ppp
clock rate 64000
 
generally you want the dce end of the cable to provide clock..
but it should work either way.
 
I tried with (clock rate 56000) and without clock and the result was exactly the same: no connection
 
It has been a long time, but I thought you needed PAP or CHAP configured on the line for negotiation to take place...can you ping???

Burt
 
you shouldnt need any authentication..
it supports it but it is not required.
 
Alfrwo

You said "connected by serial cable". I assume this is a DCE to DTE crossover?

Do 'show controller serial0' on both routers to check which is DCE & which DTE. Apply clock to the DCE unit.

You could also do 'no encapsulation PPP' on both to use the default HDLC instead. That would confirm the hardware works OK

EB
 
What I said about negotiations was in response to this...
"and here is the result of "debug ppp negotiation" command:"

Can you ping??????????????????????????

Burt
 
no I cannot ping, the cable and ports are OK, it works fine with:
router1:
interface serial 0
ip address 10.1.1.1 255.255.255.0
clock rate 56000
no shut

router 2:
interface serial 1
ip address 10.1.1.2 255.255.255.0
no shut

the above works fine, I am able to ping
it just does not want to work with the ppp encapsulation
 
YES, I finally got it running.

Thanks for your help
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top