Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations SkipVought on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Configuring DHCP Server in AP 1231

Status
Not open for further replies.

yemaya

Technical User
Sep 13, 2006
140
0
0
CA
Hi Guys,

Attempting to setup a Cisco 1200 to give out private DHCP addresses to its clients. I have added the following statements, however the AP isn't giving out any addresses.

Code:
!
service dhcp
!
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.50.1 192.168.50.5
!
ip dhcp pool AP
   import all
   network 192.168.50.0 255.255.255.0
   default-router 192.168.50.1
   dns-server 206.53.48.23 206.53.60.10 4.2.2.2
   lease 8
   update arp
!
AP#

I'm missing something here?, the AP has a static ip assigned from my internal DHCP (statically assingned).

Thanks in advance.
 
Can do a full show run? Will help with diagnosing the problem.
 
Hi,

Ok, here is my configuration on the AP:

Code:
! 
version 12.3 
no service pad 
service tcp-keepalives-in 
service tcp-keepalives-out 
service timestamps debug datetime msec localtime show-timezone 
service timestamps log datetime msec localtime show-timezone 
service password-encryption 
service sequence-numbers 
! 
hostname AP 
! 
logging buffered 51200 warnings 
no logging console 
no logging monitor 
enable secret XXXXXXXXXX 
! 
clock timezone EST -5 
clock summer-time EDT recurring 
ip subnet-zero 
no ip source-route 
no ip gratuitous-arps 
no ip domain lookup 
ip domain name Gateway.com 
ip name-server 206.53.xx.xx 
ip name-server 206.53.xx.xx 
ip name-server 4.2.2.2 
no ip dhcp conflict logging 
ip dhcp excluded-address 192.168.50.1 192.168.50.5 
! 
ip dhcp pool AP 
   import all 
   network 192.168.50.0 255.255.255.0 
   default-router 192.168.50.1 
   dns-server 206.53.xx.xx 206.53.xx.xx 4.2.2.2 
   lease 8 
   update arp 
! 
ip dhcp pool MyLaptop 
   host 192.168.50.4 255.255.255.0 
   client-identifier 0100.18de.9836.ed 
   lease infinite 
! 
! 
ip ssh authentication-retries 2 
ip ssh port 2212 rotary 1 
ip ssh version 2 
no aaa new-model 
! 
dot11 ssid ITCS 
   authentication open 
   authentication key-management wpa 
   guest-mode 
   wpa-psk ascii XXXXXXXXXX 
! 
! 
crypto pki trustpoint TP-self-signed-3901523961 
enrollment selfsigned 
subject-name cn=IOS-Self-Signed-Certificate-3901523961 
revocation-check none 
rsakeypair TP-self-signed-3901523961 
! 
! 
crypto ca certificate chain TP-self-signed-3901523961 
certificate self-signed 01 
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 33393031 35323339 3631301E 170D3032 30333031 30303232 
  33395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649 
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 39303135 
  32333936 3130819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 
  8100F850 C6716C31 F8C77108 1A869785 0726FA04 E14BE218 2CEE4C4E D76EC8A2 
  8368C16E 31648402 EDFC1C6F 03F78235 AA7FDB35 38DC53F8 655CD6EE 0CD70EF0 
  3D2B52D1 E98974CA ABFE52AB 0621537C 7150915A CCA7040B 8DB19EBF 20B94741 
  21C92290 2EFF0E6F 478948D0 72142357 8CC2A49F 27DD8015 01CC931D 14E95C17 
  A3FB0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603 
  551D2304 18301680 1478501C 0BAF1979 10A0CB52 42E299FF 1B1EA613 AF301D06 
  03551D0E 04160414 78501C0B AF197910 A0CB5242 E299FF1B 1EA613AF 300D0609 
  2A864886 F70D0101 04050003 818100CC DA4E05A0 35E21A96 FBA89E8C 993CA52A 
  905720AE 9386E601 33BBF9D3 D6169D06 F52BB51B 6FFE44DA E633EE5C 8F900462 
  33A36FE1 E7BF8BFF B177C989 E81E179D 8156A24A D75D1520 67B72D59 2058241E 
  6B00E7F6 FF55E628 7FDAB68E 0418E5EC F3463137 91EAB6B6 472D5F16 2938C43C 
  E42DFD23 B398AF07 D09E8C54 BC58AC 
  quit 
username admin privilege 15 secret XXXXXXXXXX 
archive 
log config 
  hidekeys 
path tftp://192.168.2.4/cfg-$h 
write-memory 
time-period 1440 
! 
bridge irb 
! 
! 
interface Dot11Radio0 
ip address 192.168.50.1 255.255.255.0 
no ip route-cache 
! 
encryption mode ciphers tkip 
! 
ssid ITCS 
! 
speed basic-6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0 
channel 2412 
station-role root 
antenna gain 128 
world-mode dot11d country CA both 
no cdp enable 
bridge-group 1 
bridge-group 1 subscriber-loop-control 
bridge-group 1 block-unknown-source 
no bridge-group 1 source-learning 
no bridge-group 1 unicast-flooding 
bridge-group 1 spanning-disabled 
! 
interface FastEthernet0 
no ip address 
no ip route-cache 
duplex auto 
speed auto 
no cdp enable 
bridge-group 1 
no bridge-group 1 source-learning 
bridge-group 1 spanning-disabled 
! 
interface BVI1 
ip address 192.168.5.4 255.255.255.0 
no ip route-cache 
! 
no ip http server 
ip http secure-server 
ip http help-path [URL unfurl="true"]http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag[/URL] 
! 
no cdp run 
bridge 1 route ip 
! 
! 
! 
line con 0 
exec-timeout 0 0 
password XXXXXXXXXX 
logging synchronous 
login 
line vty 0 4 
logging synchronous 
login local 
rotary 1 
transport input ssh 
! 
end

Thanks in advance.
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top