I am trying to setup a PIX at home so I can use remote desktop over VPN to access my machine from work.
I am a newbie to the PIX but have managed to get a internet connection working, and the vpn connects.
After the vpn connects I cannot ping the pix or my xp pc and cannot get the remote desktop to work. XP firewall is switched off.
Im kind of thinking its something to do with the access-list.
I also would like to be able to access the pix over the vpn to mod the config, at the moment I can only do one test per day as I have to change the settings at home
Do I have to enter the computer name or ip (192.168.8.32) in the xp remote desktop connection on remote pc.
Can any of you gurus have a quick look at my script and point me in the right direction as i'm lost now.
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ************ encrypted
passwd *********** encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 102 permit ip 192.168.8.0 255.255.255.0 10.10.8.0 255.255.255.0
access-list 100 permit tcp 10.10.8.0 255.255.255.0 192.168.8.0 255.255.255.0 eq
3389
pager lines 24
icmp deny any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside 192.168.8.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool1 10.10.8.1-10.10.8.2
pdm location 10.10.8.0 255.255.255.0 outside
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 102
nat (inside) 1 192.168.8.0 255.255.255.0 0 0
access-group 100 in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa authentication http console LOCAL
aaa authentication telnet console LOCAL
http server enable
http 192.168.8.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto dynamic-map map2 10 set transform-set ESP-AES-256-SHA
crypto map map1 10 ipsec-isakmp dynamic map2
crypto map map1 interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption aes-256
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup testvpn address-pool vpnpool1
vpngroup testpn default-domain xxxx.com
vpngroup testvpn split-tunnel 102
vpngroup testvpn idle-time 1800
vpngroup testvpn password ********
telnet 192.168.8.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.8.32-192.168.8.63 inside
dhcpd dns 194.168.x.x 194.168.x.x
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd enable inside
username ******* password ************ encrypted privilege 15
terminal width 80
I am a newbie to the PIX but have managed to get a internet connection working, and the vpn connects.
After the vpn connects I cannot ping the pix or my xp pc and cannot get the remote desktop to work. XP firewall is switched off.
Im kind of thinking its something to do with the access-list.
I also would like to be able to access the pix over the vpn to mod the config, at the moment I can only do one test per day as I have to change the settings at home
Do I have to enter the computer name or ip (192.168.8.32) in the xp remote desktop connection on remote pc.
Can any of you gurus have a quick look at my script and point me in the right direction as i'm lost now.
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ************ encrypted
passwd *********** encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 102 permit ip 192.168.8.0 255.255.255.0 10.10.8.0 255.255.255.0
access-list 100 permit tcp 10.10.8.0 255.255.255.0 192.168.8.0 255.255.255.0 eq
3389
pager lines 24
icmp deny any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside 192.168.8.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool1 10.10.8.1-10.10.8.2
pdm location 10.10.8.0 255.255.255.0 outside
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 102
nat (inside) 1 192.168.8.0 255.255.255.0 0 0
access-group 100 in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa authentication http console LOCAL
aaa authentication telnet console LOCAL
http server enable
http 192.168.8.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto dynamic-map map2 10 set transform-set ESP-AES-256-SHA
crypto map map1 10 ipsec-isakmp dynamic map2
crypto map map1 interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption aes-256
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup testvpn address-pool vpnpool1
vpngroup testpn default-domain xxxx.com
vpngroup testvpn split-tunnel 102
vpngroup testvpn idle-time 1800
vpngroup testvpn password ********
telnet 192.168.8.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.8.32-192.168.8.63 inside
dhcpd dns 194.168.x.x 194.168.x.x
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd enable inside
username ******* password ************ encrypted privilege 15
terminal width 80