Hello
I am trying to configure VPN from a cisco pix 515E and all vpn clients connecting from outside interface cannot access any resources. The only thing they can do is ping the cisco pix itself.
I think I am forgetting something very simple as I have looked at a few dozen manuals and I cannot seem to figure this out. If anyone could help this would be great.
Here is the config I am using:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto shutdown
interface ethernet3 auto shutdown
interface ethernet4 auto shutdown
interface ethernet5 auto shutdown
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 intf2 security4
nameif ethernet3 intf3 security6
nameif ethernet4 intf4 security8
nameif ethernet5 intf5 security10
enable password *************** encrypted
passwd ********************** encrypted
hostname pix
domain-name asd.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
object-group icmp-type icmp_types
icmp-object echo-reply
icmp-object unreachable
icmp-object time-exceeded
access-list outbound permit tcp any any
access-list outbound permit ip any any
access-list outbound permit icmp any any
access-list outbound permit icmp any any echo-reply
pager lines 24
logging on
icmp permit any echo outside
icmp permit any echo-reply inside
mtu outside 1500
mtu inside 1500
mtu intf2 1500
mtu intf3 1500
mtu intf4 1500
mtu intf5 1500
ip address outside 46.22.209.2 255.255.255.248
ip address inside 10.198.253.2 255.255.255.0
no ip address intf2
no ip address intf3
no ip address intf4
no ip address intf5
ip audit info action alarm
ip audit attack action alarm
ip local pool mypool 10.198.253.3-10.198.253.254
no failover
failover timeout 0:00:00
failover poll 15
no failover ip address outside
no failover ip address inside
no failover ip address intf2
no failover ip address intf3
no failover ip address intf4
no failover ip address intf5
pdm history enable
arp timeout 14400
global (outside) 1 46.22.209.3-46.22.209.6 netmask 255.255.255.248
global (outside) 1 interface
nat (outside) 0 access-list outbound
nat (outside) 2 10.198.253.0 255.255.255.0 outside 0 0
nat (inside) 0 access-list outbound
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
conduit permit icmp any any
routing interface outside
route outside 0.0.0.0 0.0.0.0 46.22.209.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-l2tp
crypto ipsec transform-set cisco-l2tp esp-3des esp-sha-hmac
crypto ipsec transform-set cisco-l2tp mode transport
crypto dynamic-map l2tp 30 set transform-set cisco-l2tp
crypto map transam 1 ipsec-isakmp
! Incomplete
crypto map newmap 30 ipsec-isakmp dynamic l2tp
crypto map newmap interface outside
crypto map dmu 30 ipsec-isakmp dynamic l2tp
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp identity address
isakmp nat-traversal 20
isakmp policy 1 authentication rsa-sig
isakmp policy 1 encryption des
isakmp policy 1 hash sha
isakmp policy 1 group 1
isakmp policy 1 lifetime 86400
isakmp policy 5 authentication pre-share
isakmp policy 5 encryption 3des
isakmp policy 5 hash sha
isakmp policy 5 group 2
isakmp policy 5 lifetime 28800
vpngroup vpn3000 idle-time 1800
telnet timeout 5
ssh timeout 60
console timeout 0
vpdn group 2 accept dialin l2tp
vpdn group 2 ppp authentication pap
vpdn group 2 client configuration address local mypool
vpdn group 2 client configuration dns 80.79.112.2 80.79.112.20
vpdn group 2 client authentication local
vpdn group 2 l2tp tunnel hello 60
vpdn username kusok password *********
vpdn enable outside
terminal width 80
Cryptochecksum:7c511d49447f143ef4ee0cabe8ed454f
: end
I am trying to configure VPN from a cisco pix 515E and all vpn clients connecting from outside interface cannot access any resources. The only thing they can do is ping the cisco pix itself.
I think I am forgetting something very simple as I have looked at a few dozen manuals and I cannot seem to figure this out. If anyone could help this would be great.
Here is the config I am using:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto shutdown
interface ethernet3 auto shutdown
interface ethernet4 auto shutdown
interface ethernet5 auto shutdown
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 intf2 security4
nameif ethernet3 intf3 security6
nameif ethernet4 intf4 security8
nameif ethernet5 intf5 security10
enable password *************** encrypted
passwd ********************** encrypted
hostname pix
domain-name asd.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
object-group icmp-type icmp_types
icmp-object echo-reply
icmp-object unreachable
icmp-object time-exceeded
access-list outbound permit tcp any any
access-list outbound permit ip any any
access-list outbound permit icmp any any
access-list outbound permit icmp any any echo-reply
pager lines 24
logging on
icmp permit any echo outside
icmp permit any echo-reply inside
mtu outside 1500
mtu inside 1500
mtu intf2 1500
mtu intf3 1500
mtu intf4 1500
mtu intf5 1500
ip address outside 46.22.209.2 255.255.255.248
ip address inside 10.198.253.2 255.255.255.0
no ip address intf2
no ip address intf3
no ip address intf4
no ip address intf5
ip audit info action alarm
ip audit attack action alarm
ip local pool mypool 10.198.253.3-10.198.253.254
no failover
failover timeout 0:00:00
failover poll 15
no failover ip address outside
no failover ip address inside
no failover ip address intf2
no failover ip address intf3
no failover ip address intf4
no failover ip address intf5
pdm history enable
arp timeout 14400
global (outside) 1 46.22.209.3-46.22.209.6 netmask 255.255.255.248
global (outside) 1 interface
nat (outside) 0 access-list outbound
nat (outside) 2 10.198.253.0 255.255.255.0 outside 0 0
nat (inside) 0 access-list outbound
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
conduit permit icmp any any
routing interface outside
route outside 0.0.0.0 0.0.0.0 46.22.209.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-l2tp
crypto ipsec transform-set cisco-l2tp esp-3des esp-sha-hmac
crypto ipsec transform-set cisco-l2tp mode transport
crypto dynamic-map l2tp 30 set transform-set cisco-l2tp
crypto map transam 1 ipsec-isakmp
! Incomplete
crypto map newmap 30 ipsec-isakmp dynamic l2tp
crypto map newmap interface outside
crypto map dmu 30 ipsec-isakmp dynamic l2tp
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp identity address
isakmp nat-traversal 20
isakmp policy 1 authentication rsa-sig
isakmp policy 1 encryption des
isakmp policy 1 hash sha
isakmp policy 1 group 1
isakmp policy 1 lifetime 86400
isakmp policy 5 authentication pre-share
isakmp policy 5 encryption 3des
isakmp policy 5 hash sha
isakmp policy 5 group 2
isakmp policy 5 lifetime 28800
vpngroup vpn3000 idle-time 1800
telnet timeout 5
ssh timeout 60
console timeout 0
vpdn group 2 accept dialin l2tp
vpdn group 2 ppp authentication pap
vpdn group 2 client configuration address local mypool
vpdn group 2 client configuration dns 80.79.112.2 80.79.112.20
vpdn group 2 client authentication local
vpdn group 2 l2tp tunnel hello 60
vpdn username kusok password *********
vpdn enable outside
terminal width 80
Cryptochecksum:7c511d49447f143ef4ee0cabe8ed454f
: end