Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations strongm on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Cisco DHCP problems over vlan.

Status
Not open for further replies.

Nesle

Technical User
Jun 5, 2008
4
NO
In my network I'm using the router as a router on a stick, my problem is when setting it up as a DHCP server it gives some vlans ip's (vlan 15) and others (vlan 16)
gets an error message when trying to obtain it. (unable to contact your DHCP server. request timed out)

If I change the port with vlan 16 to vlan 15 it get's a 10.5.0.* address straight away, change it back to vlan 16 and the client cant reach the dhcp server.

There seems to be a problem with my vlans, but i can't see it in the config, any help appreciated.




Router(cisco 2600):

interface FastEthernet0/0
no ip address
duplex auto
speed auto
no clns route-cache


ip dhcp excluded-address 10.5.0.1
ip dhcp excluded-address 10.6.0.1

interface FastEthernet0/0.5
encapsulation dot1Q 15
ip address 10.5.0.1 255.255.0.0

interface FastEthernet0/0.6
encapsulation dot1Q 16
ip address 10.6.0.1 255.255.0.0

interface FastEthernet0/1
ip address 10.0.0.1 255.255.0.0
duplex auto
speed auto
no clns route-cache

router eigrp 10
network 10.0.0.0
auto-summary

ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.2


ip dhcp pool vlan15
import all
network 10.5.0.0 255.255.0.0
dns-server 10.4.0.2
default-router 10.5.0.1
netbios-name-server 10.4.0.2
domain-name vlan.15
lease 8
update arp

!
ip dhcp pool vlan16
import all
network 10.6.0.0 255.255.0.0
dns-server 10.4.0.2
default-router 10.6.0.1
netbios-name-server 10.4.0.2
domain-name vlan.16
lease 8
update arp




interface FastEthernet0/0.5
encapsulation dot1Q 15
ip address 10.5.0.1 255.255.0.0

interface FastEthernet0/0.6
encapsulation dot1Q 16
ip address 10.6.0.1 255.255.0.0


First switch (cisco 2900):

interface FastEthernet0/1 (goes to/comes from router)
switchport trunk encapsulation dot1q
switchport mode trunk

interface FastEthernet0/9 (goes to/comes from switch two)
switchport trunk encapsulation dot1q
switchport mode trunk



Second switch (cisco 3550):

interface FastEthernet0/1 (goes to/comes from switch one)
switchport trunk encapsulation dot1q
switchport mode trunk

interface FastEthernet0/5
switchport access vlan 12
switchport mode dynamic desirable

interface FastEthernet0/7
switchport access vlan 16
switchport mode dynamic desirable

 
What is vlan 12? Post a complete sh run from the switch with access ports for vlan 15 and 16.

Burt
 
Sorry about that , here is the complete sh run for the second switch


Switch#show run
Building configuration...

Current configuration : 2273 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
enable secret 5 $1$KxTM$jI.VVttj2bCv8pES34JiW.
!
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 11
switchport mode dynamic desirable
!
interface FastEthernet0/3
switchport access vlan 11
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 12
switchport mode dynamic desirable
!
interface FastEthernet0/5
switchport access vlan 12
switchport mode dynamic desirable
!
interface FastEthernet0/6
switchport access vlan 15
switchport mode dynamic desirable
!
interface FastEthernet0/7
switchport access vlan 16
switchport mode dynamic desirable
!
interface FastEthernet0/8
switchport mode dynamic desirable
!
interface FastEthernet0/9
switchport mode dynamic desirable
!
interface FastEthernet0/10
switchport mode dynamic desirable
!
interface FastEthernet0/11
switchport mode dynamic desirable
!
interface FastEthernet0/12
switchport mode dynamic desirable
!
interface FastEthernet0/13
switchport mode dynamic desirable
!
interface FastEthernet0/14
switchport mode dynamic desirable
!
interface FastEthernet0/15
switchport mode dynamic desirable
!
interface FastEthernet0/16
switchport mode dynamic desirable
!
interface FastEthernet0/17
switchport mode dynamic desirable
!
interface FastEthernet0/18
switchport mode dynamic desirable
!
interface FastEthernet0/19
switchport mode dynamic desirable
!
interface FastEthernet0/20
switchport mode dynamic desirable
!
interface FastEthernet0/21
switchport mode dynamic desirable
!
interface FastEthernet0/22
switchport mode dynamic desirable
!
interface FastEthernet0/23
switchport mode dynamic desirable
!
interface FastEthernet0/24
switchport mode dynamic desirable
!
interface GigabitEthernet0/1
switchport mode dynamic desirable
!
interface GigabitEthernet0/2
switchport mode dynamic desirable
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip http server
!
!
line con 0
line vty 5 15
!
!
end
 
Try taking out the dynamic desirable command from the switchports. I will think more later...gotta get the kid off to school...lol

Burt
 
I tested a new switch to day (Cisco catalyst 2900) with simmular results.
to add some inf :
I currentl have 7 vlans in my network vlan 11-17, vlan 11-15 works fine (obtaining the ip for it's vlan ) vlan 16 and 17 on the other hand can't reach the dhcp server. (dhcp server running on the router)

This is running config on the other 2900 switch

Switch#show run
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
enable secret 5 $1$2VxE$QOqXv1z8kTzJhXjOZCD6g/
!
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 13
!
interface FastEthernet0/3
switchport access vlan 13
!
interface FastEthernet0/4
switchport access vlan 15
!
interface FastEthernet0/5
switchport access vlan 15
!
interface FastEthernet0/6
switchport access vlan 16
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
switchport access vlan 18
!
interface FastEthernet0/18
switchport access vlan 18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface VLAN1
no ip directed-broadcast
no ip route-cache
!
!
line con 0
transport input none
stopbits 1
line vty 0 4
login
line vty 5 15
login
!
end

Switch#


Vlan 13 and 15 workes fine on it and again 16 can't reach the dhcp server.

Nesle
 
Is vlan 16 and 17 in the vlan database on the 2900? Also on all switchports with actual user pc's on it add "spanning tree portfast" .
 
I just did a google for dhcp poolI and it landed me in your thread. I

It is so helpfull to see your config. Even though you have a problem, it's great to see how other people are doing it.

I have a similar problem as you (no dhcp working yet) but it's a work in progress.

The difference is that I can't use sub-ints because my hwic-4esw.

I'm looking around for some on the net and will paste it in here if it's relevent - if that's ok.
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top