Currently running Cisco CME 4.1(0) with IOS C2600-IPVOICEK9-M-12.4(11)XJ4. Trying to setup a sip gateway and can’t seem to get the router to register with the gateway. Can you look over my IOS and let me know if you see anything that stands out. I have wireshark running and I never see anything leave the router towards the sip gateway.
Thanks
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
ip domain name tdb.local
ip name-server 192.168.16.50
multilink bundle-name authenticated
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service h450.2
no supplementary-service h450.3
supplementary-service h450.12
fax protocol pass-through g711ulaw
h323
call start slow
sip
bind control source-interface FastEthernet0/0
bind media source-interface FastEthernet0/0
header-passing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username admin password
!
vlan internal allocation policy ascending
!
!
!
!
interface FastEthernet0/0
ip address 192.168.16.75 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
ip http server
ip http authentication local
no ip http secure-server
!
!
!
control-plane
!
!
!
!
!
!
!
dial-peer voice 1 voip
translation-profile outgoing SIP
destination-pattern 1..........
session protocol sipv2
session target ipv4:207.191.12.60
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
no vad
!
!
sip-ua
authentication username theuser password thepass
no remote-party-id
retry invite 4
retry response 3
retry bye 2
retry cancel 2
retry register 5
retry options 0
timers register 250
registrar ipv4:207.191.12.60 expires 3600
sip-server ipv4:207.191.12.60
host-registrar
!
!
telephony-service
load 7960-7940 P00308000500
max-ephones 12
max-dn 24
ip source-address 192.168.16.75 port 2000
calling-number local
system message JNL Test System
url services voicemail 5000
mwi relay
max-conferences 4 gain -6
call-forward pattern 4...
web admin system name admin password thepass
transfer-system full-consult
transfer-pattern 52540..
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn 1
number 1000
label 337-905-7233
description EX-1000
name EX-1000
call-forward busy 5000
call-forward noan 5000 timeout 12
!
!
ephone-dn 2
number 1001
label 337-905-7234
description EX-1001
name EX-1001
!
!
ephone-dn 3
number 5000
name Voice Messaging Port 2
no huntstop
!
!
ephone-dn 4
number 5000
name Voice Messaging Port 1
no huntstop
!
!
ephone-dn 5
number A01
name MWI Only
mwi on-off
!
!
ephone-dn 6
number 9998 secondary 9999
name 3379057801
no huntstop
mwi on-off
!
!
ephone-dn 7
number 3379057801 no-reg primary
label 337-905-7801
description 3379057801
name 3379057801
no huntstop
!
!
ephone 1
username "xxx" password
mac-address 0015.6278.86A7
paging-dn 1 unicast
type 7960
button 1:1 2:7
!
!
!
ephone 2
username "xxx" password xxx
mac-address 0009.7CBE.C70A
fastdial 1 5551212
paging-dn 2 unicast
type 7940
button 1:2 2:1
!
!
!
ephone 3
vm-device-id cvm2
button 1:3
!
!
!
ephone 4
vm-device-id cvm1
button 1:4
!
!
!
ephone 5
vm-device-id cvm3
!
!
!
line con 0
line aux 0
line vty 0 4
login local
!
!
end
Thanks
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
ip domain name tdb.local
ip name-server 192.168.16.50
multilink bundle-name authenticated
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service h450.2
no supplementary-service h450.3
supplementary-service h450.12
fax protocol pass-through g711ulaw
h323
call start slow
sip
bind control source-interface FastEthernet0/0
bind media source-interface FastEthernet0/0
header-passing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username admin password
!
vlan internal allocation policy ascending
!
!
!
!
interface FastEthernet0/0
ip address 192.168.16.75 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
ip http server
ip http authentication local
no ip http secure-server
!
!
!
control-plane
!
!
!
!
!
!
!
dial-peer voice 1 voip
translation-profile outgoing SIP
destination-pattern 1..........
session protocol sipv2
session target ipv4:207.191.12.60
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
no vad
!
!
sip-ua
authentication username theuser password thepass
no remote-party-id
retry invite 4
retry response 3
retry bye 2
retry cancel 2
retry register 5
retry options 0
timers register 250
registrar ipv4:207.191.12.60 expires 3600
sip-server ipv4:207.191.12.60
host-registrar
!
!
telephony-service
load 7960-7940 P00308000500
max-ephones 12
max-dn 24
ip source-address 192.168.16.75 port 2000
calling-number local
system message JNL Test System
url services voicemail 5000
mwi relay
max-conferences 4 gain -6
call-forward pattern 4...
web admin system name admin password thepass
transfer-system full-consult
transfer-pattern 52540..
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn 1
number 1000
label 337-905-7233
description EX-1000
name EX-1000
call-forward busy 5000
call-forward noan 5000 timeout 12
!
!
ephone-dn 2
number 1001
label 337-905-7234
description EX-1001
name EX-1001
!
!
ephone-dn 3
number 5000
name Voice Messaging Port 2
no huntstop
!
!
ephone-dn 4
number 5000
name Voice Messaging Port 1
no huntstop
!
!
ephone-dn 5
number A01
name MWI Only
mwi on-off
!
!
ephone-dn 6
number 9998 secondary 9999
name 3379057801
no huntstop
mwi on-off
!
!
ephone-dn 7
number 3379057801 no-reg primary
label 337-905-7801
description 3379057801
name 3379057801
no huntstop
!
!
ephone 1
username "xxx" password
mac-address 0015.6278.86A7
paging-dn 1 unicast
type 7960
button 1:1 2:7
!
!
!
ephone 2
username "xxx" password xxx
mac-address 0009.7CBE.C70A
fastdial 1 5551212
paging-dn 2 unicast
type 7940
button 1:2 2:1
!
!
!
ephone 3
vm-device-id cvm2
button 1:3
!
!
!
ephone 4
vm-device-id cvm1
button 1:4
!
!
!
ephone 5
vm-device-id cvm3
!
!
!
line con 0
line aux 0
line vty 0 4
login local
!
!
end