Can you tell us what "issues" your having in trying to do so? Post a config?
Assign ip address is:
interface fastethernet 0/0 < or whatever your interface is >
ip address 1.1.1.1 255.255.255.0 < or whatever your ip / mask is >
no shut
Erase the config:
erase startup-config
<confirm with enter>
reload
<confirm with enter>
HomeRouter#config t
Enter configuration commands, one per line. End with CNTL/Z.
HomeRouter(config)#interface fastethernet 0/0
^
% Invalid input detected at '^' marker.
HomeRouter(config)#interface fastethernet 0
HomeRouter(config-if)#ip address 192.168.1.2 255.255.255.0
% IP addresses may not be configured on L2 links FastEthernet0.
Cisco 800 series routers are not best documented items on Cisco web site, so it took me couple of hours to find out that even though the router contains 4 port switch, you MUST assign IP address tot he default VLAN 1 and then assign desired port(s) to the default VLAN. What is then point of having other 3 ports? Apparently, no one knows.
Anyway to configure IP address for the VLAN 1 do the following:
router>en
router# conf t
router#(config)interface vlan 1
router#(config-if) ip address 10.10.10.254 255.0.0.0
router#(config-if) no shutdown
Remember that you can assign IP address directly only to a Ethernet WAN port. Connect your network cable to the first port on the switch (FE0) and continue configuring your router using CLI or SDM.
I also found people trying this command: no switchport
on the interface to put it into a layer 3 mode.
Configure IP on this interface? [no]: 192.168.1.1 255.255.255.0
% Please answer 'yes' or 'no'.
Configure IP on this interface? [no]: yes
IP address for this interface: 192.168.1.1 255.255.255.0
% Bad Internet address.
% Enter an Internet address of the form 'X.X.X.X', where each
% letter corresponds to a decimal number between 0 and 255.
IP address for this interface: 192.168.1.1
Subnet mask for this interface [255.255.255.0] : 255.255.255.0
Class C network is 192.168.1.0, 24 subnet bits; mask is /24
The following configuration command script was created:
hostname HomeRouter
enable secret 5 $1$4S/.$f7W1h9ivr9cVkwWK/DYY3.
enable password km24410666
line vty 0 4
password pm24410666
snmp-server community public
!
no ip routing
!
interface ATM0
shutdown
no ip address
!
interface FastEthernet0
no shutdown
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet1
shutdown
no ip address
!
interface FastEthernet2
shutdown
no ip address
!
interface FastEthernet3
shutdown
no ip address
!
interface Vlan1
shutdown
no ip address
!
end
[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.
Enter your selection [2]: 2
% IP addresses may not be configured on L2 links FastEthernet0.
Building configuration...
Use the enabled mode 'configure' command to modify this configuration.
Press RETURN to get started!
Jan 2 12:00:01.731: %IOS_LICENSE_IMAGE_APPLICATION-6-LICENSE_LEVEL: Module name = c880-data Next reboot level = advsecurity and License = advsecurity
Apr 8 12:55:37.143: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0 State changed to: Initialized
Apr 8 12:55:37.147: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0 State changed to: Enabled
Apr 8 12:55:55.059: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to down
Apr 8 12:55:55.063: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0, changed state to down
Apr 8 12:55:55.063: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state to down
Apr 8 12:55:55.063: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:2, changed state to down
Apr 8 12:55:55.899: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
Apr 8 13:00:57.919: %LINK-3-UPDOWN: Interface ATM0, changed state to down
Apr 8 13:01:49.047: %SYS-5-CONFIG_I: Configured from console by console
Apr 8 13:01:50.939: %LINK-5-CHANGED: Interface ATM0, changed state to administratively down
Apr 8 13:01:51.031: %LINK-5-CHANGED: Interface FastEthernet1, changed state to administratively down
Apr 8 13:01:51.031: %LINK-5-CHANGED: Interface FastEthernet2, changed state to administratively down
Apr 8 13:01:51.035: %LINK-5-CHANGED: Interface FastEthernet3, changed state to administratively down
Apr 8 13:01:51.039: %LINK-5-CHANGED: Interface Vlan1, changed state to administratively down
Apr 8 13:01:52.031: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1, changed state to down
Apr 8 13:01:52.031: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2, changed state to down
Apr 8 13:01:52.035: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet3, changed state to down
Apr 8 13:01:52.995: %LINK-5-CHANGED: Interface BRI0, changed state to administratively down
Apr 8 13:01:53.951: %SYS-5-RESTART: System restarted --
Cisco IOS Software, C880 Software (C880DATA-UNIVERSALK9-M), Version 15.0(1)M7, RELEASE SOFTWARE (fc2)
Technical Support:
Copyright (c) 1986-2011 by Cisco Systems, Inc.
Compiled Fri 05-Aug-11 02:01 by prod_rel_team
Apr 8 13:01:53.955: %SNMP-5-COLDSTART: SNMP agent on host HomeRouter is undergoing a cold start
Apr 8 13:01:53.963: %SYS-6-BOOTTIME: Time taken to reboot after reload = 412 seconds
Apr 8 13:01:55.415: %LINK-3-UPDOWN: Interface FastEthernet0, changed state to up
Apr 8 13:01:56.415: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0, changed state to up
HomeRouter>en
Password:
HomeRouter#show config
Using 1324 out of 262136 bytes
!
! No configuration change since last restart
! NVRAM config last updated at 13:01:49 UTC Sun Apr 8 2012
!
version 15.0
service config
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HomeRouter
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$4S/.$f7W1h9ivr9cVkwWK/DYY3.
enable password km24410666
!
no aaa new-model
memory-size iomem 10
!
!
ip source-route
no ip routing
!
!
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO887-K9 sn FCZ1539C2T3
!
!
!
!
!
!
!
!
!
!
!
interface BRI0
encapsulation hdlc
no ip route-cache
isdn termination multidrop
no cdp enable
!
interface ATM0
no ip address
no ip route-cache
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
no cdp enable
!
interface FastEthernet1
shutdown
no cdp enable
!
interface FastEthernet2
shutdown
no cdp enable
!
interface FastEthernet3
shutdown
no cdp enable
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
snmp-server community public RO
!
control-plane
!
!
line con 0
exec-timeout 0 0
no modem enable
line aux 0
line vty 0 4
password pm24410666
login
!
scheduler max-task-time 5000
no process cpu extended
no process cpu autoprofile hog
end
If the no switchport command/argument doesn't work on the physical interface then I think you will have to assign the ip to vlan1 and then assign the interfaces to that vlan. See the post above with the link.
This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
By continuing to use this site, you are consenting to our use of cookies.