Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations Mike Lewis on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Cisco 831 and Cox Cable

Status
Not open for further replies.

jdannan

IS-IT--Management
Nov 17, 2003
58
0
0
US
I have a Cisco 831 router, and I am trying to use it with my cox cable business account and a static IP. I'm pretty new to cisco IOS, and not sure if I have everything setup correctly. Here is my running config. Can anyone give me some ideas if I am doing this right? Thanks...


Current configuration : 1226 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname lanrouter
!
enable secret 5 $1$OBXF$OjbPlOeV7H8kUL7xc7qQa.
!
username CRWS_Prem privilege 15 password 0 $1$W1fA$o1oSEpa1038159184
username CRWS_Shashi privilege 15 password 0 $1$W1fA$o1oSEpa161697005
username CRWS_Kannan privilege 15 password 0 $1$W1fA$o1oSEpa1040563783
username CRWS_Jaidil privilege 15 password 0 $1$W1fA$o1oSEpa904997320
ip subnet-zero
no ip routing
!
ip audit notify log
ip audit po max-events 100
!
!
!
!
interface Ethernet0
description Internal LAN
ip address 192.168.0.1 255.255.255.0
ip nat inside
no ip route-cache
no ip mroute-cache
hold-queue 100 out
!
interface Ethernet1
description External WAN
ip address static.ip.here 255.255.255.224
ip nat outside
no ip route-cache
no ip mroute-cache
!
ip classless
ip http server
!
!
snmp-server community litigation RO
snmp-server enable traps tty
!
line con 0
no modem enable
stopbits 1
line aux 0
stopbits 1
line vty 0 4
exec-timeout 120 0
login local
length 0
!
scheduler max-task-time 5000
end
 
Your missing your NAT information. Try adding this:

config t
ip route 0.0.0.0 0.0.0.0 interface ethernet 1 (IP address is better here)
access-list 1 permit 192.168.0.0 0.0.0.255
ip nat inside source list 1 overload
end


That should do it.

"I can picture a world without war. A world without hate. A world without fear. And I can picture us attacking that world, because they'd never expect it."
- Jack Handey, Deep Thoughts
 
Ok, I added those lines. Some of the commands weren't exactly the same as you stated. Did I add them correctly with the correct interfaces? Thanks for the help.

Here's my running config:

Current configuration : 1301 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname lanrouter
!
enable secret 5 $1$OBXF$OjbPlOeV7H8kUL7xc7qQa.
enable password .....
!
username CRWS_Prem privilege 15 password 0 $1$W1fA$o1oSEpa1038159184
username CRWS_Shashi privilege 15 password 0 $1$W1fA$o1oSEpa161697005
username CRWS_Kannan privilege 15 password 0 $1$W1fA$o1oSEpa1040563783
username CRWS_Jaidil privilege 15 password 0 $1$W1fA$o1oSEpa904997320
ip subnet-zero
!
ip audit notify log
ip audit po max-events 100
!
!
!
!
interface Ethernet0
description Internal LAN
ip address 192.168.0.1 255.255.255.0
ip nat inside
no ip mroute-cache
hold-queue 100 out
!
interface Ethernet1
description External WAN
ip address 24.x.x.x 255.255.255.224
ip nat outside
no ip mroute-cache
!
ip default-gateway 24.x.x.x
ip nat inside source list 1 interface Ethernet0 overload
no ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet1
no ip http server
!
!
!
!
access-list 1 permit 192.168.0.0 0.0.0.255
snmp-server community litigation RO
snmp-server enable traps tty
!
line con 0
no modem enable
stopbits 1
line aux 0
stopbits 1
line vty 0 4
exec-timeout 120 0
password ....
login local
length 0
!
scheduler max-task-time 5000
end
 
Looks good. Does it work for you now?

"I can picture a world without war. A world without hate. A world without fear. And I can picture us attacking that world, because they'd never expect it."
- Jack Handey, Deep Thoughts
 
ip nat inside source list 1 interface Ethernet0 overload"
I think the interface should be Ethernet1.
 
No it doesn't work, let me change the interface to eth1

Thanks for the help.

I'll let you know what happens shortly...
 
I'm trying to remove the interface ethernet1 from the 'ip nat inside source list 1 interface Ethernet1 overload'

With a no before the command, is this correct? I'm getting Domain mapping in use, cannot remove.
 
Yes, you'll get that. You need to "clear ip nat translation" first, then remove the statement.

"I can picture a world without war. A world without hate. A world without fear. And I can picture us attacking that world, because they'd never expect it."
- Jack Handey, Deep Thoughts
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top