I dont know if anyone can help. I have a cisco adsl router and have had it working before. I have reset and re-configured it but now its not working. I know ive left something stupid out. I have taken out all the firewall rules so its as basic as it can be. It assigns an outside IP ok and i can ping "yahoo.com" from it, so I know DNS is ok.
If I connect a PC to it with a fixed IP and using the ISP's DNS address's I cannot connect to the internet.
Here is my config, can anyone help?
Steve
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname MyRouter
!
no logging buffered
enable secret 5 $1$M2vN$8gyGl70Wul****.JXZN9o1
enable password *******
!
username ******** privilege 15 password 0 ******
no aaa new-model
ip subnet-zero
ip domain name local
!
!
ip audit notify log
ip audit po max-events 100
no ftp-server write-enable
!
!
!
!
partition flash 2 10 2
!
!
!
!
interface Ethernet0
description $FW_INSIDE$
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
pvc 0/38
oam-pvc manage
pppoe-client dial-pool-number 1
!
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer0
description $FW_OUTSIDE$
ip address negotiated
ip mtu 1452
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname ******@xtreme5.pipex.net
ppp chap password 0 ********
ppp pap sent-username ******@xtreme5.pipex.net password 0 *******
ppp ipcp dns request
!
ip classless
ip route 0.0.0.0 0.0.0.0
ip http server
ip http secure-server
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
privilege level 15
password ******
login local
transport input telnet
!
scheduler max-task-time 5000
!
end
If I connect a PC to it with a fixed IP and using the ISP's DNS address's I cannot connect to the internet.
Here is my config, can anyone help?
Steve
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname MyRouter
!
no logging buffered
enable secret 5 $1$M2vN$8gyGl70Wul****.JXZN9o1
enable password *******
!
username ******** privilege 15 password 0 ******
no aaa new-model
ip subnet-zero
ip domain name local
!
!
ip audit notify log
ip audit po max-events 100
no ftp-server write-enable
!
!
!
!
partition flash 2 10 2
!
!
!
!
interface Ethernet0
description $FW_INSIDE$
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
pvc 0/38
oam-pvc manage
pppoe-client dial-pool-number 1
!
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer0
description $FW_OUTSIDE$
ip address negotiated
ip mtu 1452
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname ******@xtreme5.pipex.net
ppp chap password 0 ********
ppp pap sent-username ******@xtreme5.pipex.net password 0 *******
ppp ipcp dns request
!
ip classless
ip route 0.0.0.0 0.0.0.0
ip http server
ip http secure-server
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
privilege level 15
password ******
login local
transport input telnet
!
scheduler max-task-time 5000
!
end