I have a Cisco 4506 with a sup2+ engine that I am trying to setup some vlans on and I am having some issues. I will post my config below. What I am trying to do is intervlan routing.
Vlan 1 = 192.168.0.0 255.255.252.0
vlan 20 = 172.20.0.0 255.255.0.0
I want to have my servers on vlan 1 and my users on vlan 20. I will be adding more vlans but just starting simple right now. I setup some static routes that you will see in my config but vlan 20 and vlan 1 will not talk. I have also tried RIP without any success. I know I am just missing a simple command somewhere so any help would be much appreciated.
Below is my config minus a ton of interfaces....
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service compress-config
!
no aaa new-model
vtp domain ''
vtp mode transparent
ip subnet-zero
no ip domain-lookup
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
power redundancy-mode redundant
!
!
!
vlan internal allocation policy ascending
!
vlan 20
!
interface GigabitEthernet3/27
switchport access vlan 20
switchport mode access
!
interface Vlan1
ip address 192.168.3.33 255.255.252.0
!
interface Vlan20
description user
ip address 172.20.0.5 255.255.0.0
ip helper-address 192.168.0.3
!
ip route 172.20.0.0 255.255.0.0 Vlan1
ip route 192.168.0.0 255.255.252.0 Vlan20
ip http server
As you can see I set g3/27 to vlan 20 and with static routes I pointed the two vlans at each other. I still cannot ping each other. Vlan 1 can talk to all vlan 1 devices and vlan 20 talks to all vlan 20 devices but not cross vlan communication.
Here is a show ip route...
C 172.20.0.0/16 is directly connected, Vlan20
C 192.168.0.0/22 is directly connected, Vlan1
Any ideas? It would be much appreciated.
Vlan 1 = 192.168.0.0 255.255.252.0
vlan 20 = 172.20.0.0 255.255.0.0
I want to have my servers on vlan 1 and my users on vlan 20. I will be adding more vlans but just starting simple right now. I setup some static routes that you will see in my config but vlan 20 and vlan 1 will not talk. I have also tried RIP without any success. I know I am just missing a simple command somewhere so any help would be much appreciated.
Below is my config minus a ton of interfaces....
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service compress-config
!
no aaa new-model
vtp domain ''
vtp mode transparent
ip subnet-zero
no ip domain-lookup
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
power redundancy-mode redundant
!
!
!
vlan internal allocation policy ascending
!
vlan 20
!
interface GigabitEthernet3/27
switchport access vlan 20
switchport mode access
!
interface Vlan1
ip address 192.168.3.33 255.255.252.0
!
interface Vlan20
description user
ip address 172.20.0.5 255.255.0.0
ip helper-address 192.168.0.3
!
ip route 172.20.0.0 255.255.0.0 Vlan1
ip route 192.168.0.0 255.255.252.0 Vlan20
ip http server
As you can see I set g3/27 to vlan 20 and with static routes I pointed the two vlans at each other. I still cannot ping each other. Vlan 1 can talk to all vlan 1 devices and vlan 20 talks to all vlan 20 devices but not cross vlan communication.
Here is a show ip route...
C 172.20.0.0/16 is directly connected, Vlan20
C 192.168.0.0/22 is directly connected, Vlan1
Any ideas? It would be much appreciated.