heatstreak20
MIS
I am currently an intern finishing my senior year of college, my current project is to configure a cisco 3640 series router to replace the current linksys router. There are about 100 people on the network.
The router works fine with the current configuration for about a day or 2 then it stops working. I turn it off and back on and the same thing happens.
here is the current configuration,
Current configuration : 1405 bytes
!
! Last configuration change at 13:44:27 UTC Mon Oct 19 2009
! NVRAM config last updated at 13:44:31 UTC Mon Oct 19 2009
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Shaftdrillers
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$WoI/$chsvq1pDwKPpgiKm827Xx.
!
no aaa new-model
!
resource policy
!
!
ip cef
no ip domain lookup
ip name-server 63.66.160.10
ip name-server 63.66.160.11
!
!
username admin privilege 15 password 0 admin
!
!
interface Ethernet0/0
description WAN
ip address 63.86.188.203 255.255.255.0
ip nat outside
ip virtual-reassembly
half-duplex
!
interface Ethernet0/1
description LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
full-duplex
!
ip http server
ip http authentication local
!
ip route 0.0.0.0 0.0.0.0 63.86.188.201
ip route 63.86.188.0 255.255.255.0 0.0.0.0
ip route 192.168.1.0 255.255.255.0 0.0.0.0
ip route 192.168.3.0 255.255.255.0 192.168.1.254
!
ip nat pool ovrld 63.86.188.203 63.86.188.203 prefix-length 24
ip nat inside source list 7 pool ovrld overload
!
!
ip access-list extended NAT_ADDRESSES
permit ip 192.168.1.0 0.0.0.255 any
access-list 7 permit 192.168.1.0 0.0.0.255
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
Also, if i type sh ip int brief it shows both ethernet interfaces and a 3rd interface called NVI0 which i am guessing is the virtual interface for the NAT, this NVI0 interface does not have an assigned IP address, isn't OK, the method is unset, but the status and protocol are both up. Do I have to configure this virtual interface? or is the buffer for the NAT overloading after a day or 2?
Thank you for all your help
The router works fine with the current configuration for about a day or 2 then it stops working. I turn it off and back on and the same thing happens.
here is the current configuration,
Current configuration : 1405 bytes
!
! Last configuration change at 13:44:27 UTC Mon Oct 19 2009
! NVRAM config last updated at 13:44:31 UTC Mon Oct 19 2009
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Shaftdrillers
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$WoI/$chsvq1pDwKPpgiKm827Xx.
!
no aaa new-model
!
resource policy
!
!
ip cef
no ip domain lookup
ip name-server 63.66.160.10
ip name-server 63.66.160.11
!
!
username admin privilege 15 password 0 admin
!
!
interface Ethernet0/0
description WAN
ip address 63.86.188.203 255.255.255.0
ip nat outside
ip virtual-reassembly
half-duplex
!
interface Ethernet0/1
description LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
full-duplex
!
ip http server
ip http authentication local
!
ip route 0.0.0.0 0.0.0.0 63.86.188.201
ip route 63.86.188.0 255.255.255.0 0.0.0.0
ip route 192.168.1.0 255.255.255.0 0.0.0.0
ip route 192.168.3.0 255.255.255.0 192.168.1.254
!
ip nat pool ovrld 63.86.188.203 63.86.188.203 prefix-length 24
ip nat inside source list 7 pool ovrld overload
!
!
ip access-list extended NAT_ADDRESSES
permit ip 192.168.1.0 0.0.0.255 any
access-list 7 permit 192.168.1.0 0.0.0.255
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
Also, if i type sh ip int brief it shows both ethernet interfaces and a 3rd interface called NVI0 which i am guessing is the virtual interface for the NAT, this NVI0 interface does not have an assigned IP address, isn't OK, the method is unset, but the status and protocol are both up. Do I have to configure this virtual interface? or is the buffer for the NAT overloading after a day or 2?
Thank you for all your help