Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations SkipVought on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Cisco 2940/2950

Status
Not open for further replies.

sjasbury

IS-IT--Management
Jan 23, 2008
13
0
0
DE
I have a network with 1 2940 and 4 2950's. I will be implementing a VoIP pbx and using the switch port on the back of the phone. Am I to understand if I set the data ports to multi vlan 1 and 20 pc's on 1 and phones on 20 and both with different subnets or would I need further programming?
 
You will need to look into putting QoS on the switches, if not you might run into a few problems with jitter and packet loss...

------------------------------------
Dallas, Texas
Telecommunications Tech
CCVP, CCNA, Net+

CCNP in the works
 
Hi sjasbury,

Just done this today actually...

Data VLAN= 10
Voice VLAN= 20

(config-if)#switchport access vlan 10
(config-if)#switchport voice vlan 20
(config-if)#switchport mode trunk

works fine for me... the IP phone is doing VLAN tagging on the switchports on the back of it...

:)
 
This is what I did on my test lab 2924xl
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
enable password cisco
!
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/2
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/3
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/4
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/5
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/6
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/7
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/8
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/9
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/10
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/11
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/12
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/13
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/14
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/15
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/16
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/17
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/18
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/19
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/20
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/21
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/22
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/23
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface FastEthernet0/24
switchport voice vlan 20
switchport priority extend trust
spanning-tree portfast
!
interface VLAN1
ip address 192.168.10.76 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
interface VLAN20
no ip directed-broadcast
no ip route-cache
shutdown

I think I'm on the right path :)
 
Little more specifics. I left the data on the default VLAN another company takes care of them. The VoIP system is Mitel and will be implemented later next month, I'm just trying to get a jump on the game to make a smooth cutover.
 
You can try to do it with out any QoS, but if you start to get complaints about choppy or dropped phone calls, you will need to implement QoS.

------------------------------------
Dallas, Texas
Telecommunications Tech
CCVP, CCNA, Net+

CCNP in the works
 
Another one to watch on bad speech is duplex settings. Had a large call centre with horrendous speech issues a few years ago. Turns out they had forced the switchport the IP PBX connected to full duplex and 100Mbps operation. The IP PBX does not support forced operation and auto-negotiated resulting in lots of collisions. Removed forced settings from the switchport in question - never had a problem since!

:eek:)
 
The Cisco QoS SRND v3.3 has examples in the appendix for the 2950.

SRND Site:

QoS SRND v3.3

Although there is only one software feature set for the 2950 (two if you count Crypto/Non-Crypto) there are two hardware types - one that only enables the SI features and one that enables the EI features. With the SI the QoS is limited to Layer-2 QoS with limited ability to classify packets and queueing. The EI adds Layer-3 QoS capabilities but these are limited.

Andy
 
Thanks for all the help. I noticed that there was no layer 3 routing in this switch so I did not worry about that. And since the data and voice would already be on separate subnets to begin with, I would use the vlan to setup QoS to help it along.
 
I noticed that there was no layer 3 routing in this switch so I did not worry about that. And since the data and voice would already be on separate subnets to begin with, I would use the vlan to setup QoS to help it along.

I didn't mean the EI 2950 supports Layer-3 functions, just that it can 'see' this layer with regards to QoS - i.e. it understands and can set DSCP, it can also classify traffic using ingress service-policies that look at layer-3 and layer-4 information (there are limitations though).

How you would use the VLAN to setup QoS I don't know?

Andy
 
I can see one confusion about the switchport settings.

There are two ways of configuring it:
either (alwaysalways use this one with Cisco phones, or any other phones that support CDP)

interface FastEthernet0/1
switchport mode access
swithcport access vlan 10
switchport voice vlan 20
spanning-tree portfast

or (I always use this for non-Cisco phones that don't support CDP)
interface FastEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport trunk allowed vlan 10,20
spanning-tree portfast trunk

Also, you will need your phone config to tell the phones that the Voice VLAN is tagged 20.

Then, you will need an access port in VLAN 20 to patch your PABX into.

And probably, you will need an IP helper address on your router to forward VLAN20 DHCP requests to your VLAN 1 DHCP server.

As for QoS, it isn't the first thing you need to get working, but once you have your system all up and working, you should simply add autoqos on the switch ports and tell them to trust DSCP, unless your phones support CDP or LLDP in which case QoS can be made a bit smarter.
 
Thanks for all the input. Right up to the last minute I was pulled of to work another project on a hotel whos PBX crashed and burned and have to install a new one from the hip. I have made a copy of the text from Vince for the next time I have to do this?

Thanks all.
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top