I'm having some issues with my 1700 series router. The router that I'm working with is being tied into an existing college campus network. Before I get too much further into my problem lemme copy my router config:
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
boot-start-marker
boot-end-marker
no aaa new-model
resource policy
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
no ip dhcp use vrf connected
interface Ethernet0
ip address 192.168.13.110 255.255.255.0
ip nat outside
no shutdown
half-duplex
!
interface FastEthernet0
no ip address
ip nat inside
speed auto
!
interface FastEthernet0.1
encapsulation dot1Q 1 native
ip address 10.10.5.1 255.255.255.0
ip nat inside
no snmp trap link-status
!
interface Serial0
ip address 10.10.10.1 255.255.255.0
clockrate 56000
!
interface Serial1
no ip address
shutdown
!
router eigrp 1
network 10.10.5.0 0.0.0.255
network 10.10.10.0 0.0.0.255
no auto-summary
eigrp router-id 10.10.10.1
neighbor 10.10.10.2 Serial0
!
ip classless
!
no ip http server
ip nat inside source list 1 interface Ethernet0 overload
!
access-list 1 permit 10.10.5.0 0.0.0.255
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
!
end
Now as you can see, PAT is running off of e0 which has a 192.168.13.110 address and 192.168.13.254 would be the gateway for the portion of the campus network I'm jacking in to. my problem is that my dns isn't working properly and for some reason. the clients that are behind the NAT wall have the proper DNS servers configured, but does the router need to have the proper DNS server configured too? and if so, how do I configure it? In addition, do I need a default/static route point out of the e0 interface?
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
boot-start-marker
boot-end-marker
no aaa new-model
resource policy
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
no ip dhcp use vrf connected
interface Ethernet0
ip address 192.168.13.110 255.255.255.0
ip nat outside
no shutdown
half-duplex
!
interface FastEthernet0
no ip address
ip nat inside
speed auto
!
interface FastEthernet0.1
encapsulation dot1Q 1 native
ip address 10.10.5.1 255.255.255.0
ip nat inside
no snmp trap link-status
!
interface Serial0
ip address 10.10.10.1 255.255.255.0
clockrate 56000
!
interface Serial1
no ip address
shutdown
!
router eigrp 1
network 10.10.5.0 0.0.0.255
network 10.10.10.0 0.0.0.255
no auto-summary
eigrp router-id 10.10.10.1
neighbor 10.10.10.2 Serial0
!
ip classless
!
no ip http server
ip nat inside source list 1 interface Ethernet0 overload
!
access-list 1 permit 10.10.5.0 0.0.0.255
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
!
end
Now as you can see, PAT is running off of e0 which has a 192.168.13.110 address and 192.168.13.254 would be the gateway for the portion of the campus network I'm jacking in to. my problem is that my dns isn't working properly and for some reason. the clients that are behind the NAT wall have the proper DNS servers configured, but does the router need to have the proper DNS server configured too? and if so, how do I configure it? In addition, do I need a default/static route point out of the e0 interface?