terminaljunkie
Technical User
I am trying to get RIP working across a small routing network at home consisting of (courtesy of ebay):
2 * Cisco 2503 Routers
1 * Cisco 2501 Router
1 * Cisco 1924 switch
1 * Intel Express 520T Switch
1 * 3Com OfficeConnect Switch
Routers are named 2500a, 2500b, 2500c (imaginative eh?).
It is here I am having the problem so I will descrivbe it thus:
The following setup is using a text from the Sybex CCNA study book 2nd Edition bt Todd Lammle:
- I have the Routers connected using back to back DTE <---> DCE Cables
- 2500a Serial port 0 192.168.160.1 (DTE) to 2500b serial port 0 192.168.160.2 (DCE)
- 2500b Serial port 1 192.168.180.2 (DCE) to 2500c serial port 0 192.168.180.1 (DTE)
With this setup I can create the static routes and ping the network through the switches end to end - no problem.
Then I tried default routes - again this works.....but I am flummoxed with the RIP implementation.
According to the text in the book, I simply remove the static routes and add:
router rip
network 192.168.0.0
So my configs look like this:
2500a
=====
Building configuration...
Current configuration:
!
version 11.0
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname 2500a
!
enable secret 5 $1$brOM$umU38gCPHc7Gh8g56sh2o0
!
username sleach password 7 1218160317195D1C
no ip domain-lookup
!
interface Ethernet0
ip address 192.168.150.1 255.255.255.0
!
interface Serial0
ip address 192.168.160.1 255.255.255.0
no fair-queue
!
interface Serial1
no ip address
shutdown
!
interface BRI0
no ip address
shutdown
!
router rip
network 192.168.0.0
!
!
banner login ^C
This system is solely for the use of authorized users.
You have no expectations of privacy in it's use.^C
!
line con 0
password 7 1511021F0725202D2C
login local
line aux 0
password 7 1511021F0725202D2C
login local
transport input all
line vty 0 4
password 7 1511021F0725202D2C
login local
!
end
=============================================
2500b
====
Current configuration:
!
version 11.2
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname 2500b
!
enable secret 5 $1$RkIx$nHH25TQd.D4SWPkj/vgUL0
!
username sleach password 7 0005001201495A1E
no ip domain-lookup
!
interface Ethernet0
ip address 192.168.170.1 255.255.255.0
!
interface Serial0
description 2501b to 2501a
ip address 192.168.160.2 255.255.255.0
no fair-queue
clockrate 64000
!
interface Serial1
description 2500b to 2500c
ip address 192.168.180.2 255.255.255.0
no fair-queue
clockrate 64000
!
interface BRI0
no ip address
shutdown
!
router rip
network 192.168.0.0
!
no ip classless
banner login ^C
This system is solely for the use of authorized users.
You have no expectation of privacy in it's use.^C
!
line con 0
password 7 00071A150754000F0B
login local
line aux 0
password 7 1511021F0725202D2C
login local
line vty 0 4
password 7 070C285F4D06120C13
login local
!
end
=============================================
2500c
====
Current configuration:
!
version 11.0
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname 2500c
!
enable secret 5 $1$SIhB$TRAprI.v591nHS1M6Algv/
!
username sleach password 7 11080A1112005A14
no ip domain-lookup
!
interface Ethernet0
ip address 192.168.190.1 255.255.255.0
!
interface Serial0
description 2500c to 2500b
ip address 192.168.180.1 255.255.255.0
no fair-queue
!
interface Serial1
no ip address
shutdown
!
router rip
network 192.168.0.0
!
banner login ^C
This system is solely for the use of authorized users.
You have no expectation of privacy in it's use.^C
!
line con 0
password 7 060506324F41021001
login local
line aux 0
password 7 13061E0108030F232F
login local
transport input all
line vty 0 4
password 7 1511021F0725202D2C
login local
!
end
=============================================
Again the book says that at this point the RIP routes should propagate - bu they do not.
I do a show ip route (as an example on the 2500c router) and get:
2500c#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
Gateway of last resort is not set
C 192.168.190.0 is directly connected, Ethernet0
C 192.168.180.0 is directly connected, Serial0
I try to see the protocol details as so:
2500c#show ip protocol
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 13 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Routing for Networks:
192.168.0.0
Routing Information Sources:
Gateway Distance Last Update
Distance: (default is 120)
I turn on debug for RIP on all routers but see nothing on the consoles. I have looked at the book over and over and tried searching google for examples that might help - nothing so far.
I *feel* that the lines:
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
May have something to do with it, but being new to this subject I am stymied somewhat at an early stage.
Can anyone help - just a push in the right direction - I would rather solve it if I know where to look.
Thank you in advance.
<*>terminaljunkie<*>
2 * Cisco 2503 Routers
1 * Cisco 2501 Router
1 * Cisco 1924 switch
1 * Intel Express 520T Switch
1 * 3Com OfficeConnect Switch
Routers are named 2500a, 2500b, 2500c (imaginative eh?).
It is here I am having the problem so I will descrivbe it thus:
The following setup is using a text from the Sybex CCNA study book 2nd Edition bt Todd Lammle:
- I have the Routers connected using back to back DTE <---> DCE Cables
- 2500a Serial port 0 192.168.160.1 (DTE) to 2500b serial port 0 192.168.160.2 (DCE)
- 2500b Serial port 1 192.168.180.2 (DCE) to 2500c serial port 0 192.168.180.1 (DTE)
With this setup I can create the static routes and ping the network through the switches end to end - no problem.
Then I tried default routes - again this works.....but I am flummoxed with the RIP implementation.
According to the text in the book, I simply remove the static routes and add:
router rip
network 192.168.0.0
So my configs look like this:
2500a
=====
Building configuration...
Current configuration:
!
version 11.0
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname 2500a
!
enable secret 5 $1$brOM$umU38gCPHc7Gh8g56sh2o0
!
username sleach password 7 1218160317195D1C
no ip domain-lookup
!
interface Ethernet0
ip address 192.168.150.1 255.255.255.0
!
interface Serial0
ip address 192.168.160.1 255.255.255.0
no fair-queue
!
interface Serial1
no ip address
shutdown
!
interface BRI0
no ip address
shutdown
!
router rip
network 192.168.0.0
!
!
banner login ^C
This system is solely for the use of authorized users.
You have no expectations of privacy in it's use.^C
!
line con 0
password 7 1511021F0725202D2C
login local
line aux 0
password 7 1511021F0725202D2C
login local
transport input all
line vty 0 4
password 7 1511021F0725202D2C
login local
!
end
=============================================
2500b
====
Current configuration:
!
version 11.2
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname 2500b
!
enable secret 5 $1$RkIx$nHH25TQd.D4SWPkj/vgUL0
!
username sleach password 7 0005001201495A1E
no ip domain-lookup
!
interface Ethernet0
ip address 192.168.170.1 255.255.255.0
!
interface Serial0
description 2501b to 2501a
ip address 192.168.160.2 255.255.255.0
no fair-queue
clockrate 64000
!
interface Serial1
description 2500b to 2500c
ip address 192.168.180.2 255.255.255.0
no fair-queue
clockrate 64000
!
interface BRI0
no ip address
shutdown
!
router rip
network 192.168.0.0
!
no ip classless
banner login ^C
This system is solely for the use of authorized users.
You have no expectation of privacy in it's use.^C
!
line con 0
password 7 00071A150754000F0B
login local
line aux 0
password 7 1511021F0725202D2C
login local
line vty 0 4
password 7 070C285F4D06120C13
login local
!
end
=============================================
2500c
====
Current configuration:
!
version 11.0
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname 2500c
!
enable secret 5 $1$SIhB$TRAprI.v591nHS1M6Algv/
!
username sleach password 7 11080A1112005A14
no ip domain-lookup
!
interface Ethernet0
ip address 192.168.190.1 255.255.255.0
!
interface Serial0
description 2500c to 2500b
ip address 192.168.180.1 255.255.255.0
no fair-queue
!
interface Serial1
no ip address
shutdown
!
router rip
network 192.168.0.0
!
banner login ^C
This system is solely for the use of authorized users.
You have no expectation of privacy in it's use.^C
!
line con 0
password 7 060506324F41021001
login local
line aux 0
password 7 13061E0108030F232F
login local
transport input all
line vty 0 4
password 7 1511021F0725202D2C
login local
!
end
=============================================
Again the book says that at this point the RIP routes should propagate - bu they do not.
I do a show ip route (as an example on the 2500c router) and get:
2500c#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
Gateway of last resort is not set
C 192.168.190.0 is directly connected, Ethernet0
C 192.168.180.0 is directly connected, Serial0
I try to see the protocol details as so:
2500c#show ip protocol
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 13 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Routing for Networks:
192.168.0.0
Routing Information Sources:
Gateway Distance Last Update
Distance: (default is 120)
I turn on debug for RIP on all routers but see nothing on the consoles. I have looked at the book over and over and tried searching google for examples that might help - nothing so far.
I *feel* that the lines:
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
May have something to do with it, but being new to this subject I am stymied somewhat at an early stage.
Can anyone help - just a push in the right direction - I would rather solve it if I know where to look.
Thank you in advance.
<*>terminaljunkie<*>