We have an Callmanager 4.1 server and a Cisco 2811 router with 2 BRI ports. This all is configured with H.323 and we are able to dial inwards an outwards.
If we dial inwards, the number of the dialer is displayed on our Ip phones (Cisco 7941-G). The problem is that the first digit is missing.
This setup is running in the Netherlands with a Netherlands Dial Plan. If I dial with my mobile phone (0636583910) to our office, the IP phone tells me that the following number is dialing: 636583910
This is really annoing for dial back, because we have to edit the number before we can dial it back.
Can anybody tell me how to get that 0 back?
I've posted my router configuration at the bottom here, maybe something is missing there?
hostname office-voicegw
!
boot-start-marker
boot system flash c2800nm-spservicesk9-mz.124-9.T.bin
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
network-clock-participate wic 0
network-clock-select 1 BRI0/0/0
!
!
ip cef
!
!
ip domain name office.quanza.net
ip name-server 192.168.1.3
ip name-server 192.168.1.254
!
isdn switch-type basic-net3
!
!
trunk group 100
!
voice-card 0
dspfarm
!
!
voice rtp send-recv
!
voice service voip
allow-connections h323 to h323
h323
!
!
voice class codec 1
codec preference 1 g711ulaw
!
!
!
voice class h323 1
h225 timeout tcp establish 3
call preserve
!
!
!
!
!
!
!
!
!
!
voice translation-rule 1
rule 1 /^00/ /0/
rule 2 /^01233/ /1233/
!
!
voice translation-profile TRANSOUT
translate called 1
translate redirect-called 1
!
!
interface FastEthernet0/0
ip address 192.168.1.4 255.255.255.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr 192.168.1.4
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface BRI0/0/0
no ip address
isdn switch-type basic-net3
isdn incoming-voice voice
isdn outgoing ie facility
isdn outgoing ie progress-indicator
isdn outgoing ie network-facility
isdn outgoing ie notify-indicator
isdn outgoing display-ie
isdn outgoing ie caller-number
isdn outgoing ie caller-subaddr
isdn outgoing ie called-number
isdn outgoing ie called-subaddr
isdn outgoing ie low-layer-compat
isdn outgoing ie high-layer-compat
isdn outgoing ie user-user
isdn static-tei 0
trunk-group 100
!
interface BRI0/0/1
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn incoming-voice voice
isdn static-tei 0
!
ip route 0.0.0.0 0.0.0.0 192.168.1.254
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0
compand-type a-law
cptone NL
!
voice-port 0/0/1
compand-type a-law
cptone NL
!
!
!
!
!
dial-peer voice 1000 pots
trunkgroup 100
description *** inkomende gesprekken ***
incoming called-number *number removed for privacy*
direct-inward-dial
forward-digits 0
!
dial-peer voice 1002 pots
trunkgroup 100
description *** Uitbellen nationaal ***
translation-profile outgoing TRANSOUT
destination-pattern 00[1-8]........
forward-digits all
!
dial-peer voice 1003 pots
trunkgroup 100
description *** Uitbellen internationaal ***
translation-profile outgoing TRANSOUT
destination-pattern 000[1-8]T
forward-digits all
!
dial-peer voice 1004 pots
trunkgroup 100
description *** uitbellen naar 0800 en 0900 ***
translation-profile outgoing TRANSOUT
destination-pattern 00[8-9]00T
forward-digits all
!
dial-peer voice 112 pots
trunkgroup 100
description *** naar 112 alarm centrale***
translation-profile outgoing TRANSOUT
destination-pattern 0112
forward-digits all
!
dial-peer voice 2 voip
destination-pattern *number removed for privacy*
session target ipv4:192.168.1.3
incoming called-number .T
tech-prefix 0
dtmf-relay h245-alphanumeric
codec g711ulaw
fax-relay ecm disable
fax rate disable
no vad
!
!
no dial-peer outbound status-check pots
gateway
timer receive-rtp 1200
!
!
!
line con 0
line aux 0
line vty 0 4
exec-timeout 30 0
privilege level 15
password flf123
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
!
end
If we dial inwards, the number of the dialer is displayed on our Ip phones (Cisco 7941-G). The problem is that the first digit is missing.
This setup is running in the Netherlands with a Netherlands Dial Plan. If I dial with my mobile phone (0636583910) to our office, the IP phone tells me that the following number is dialing: 636583910
This is really annoing for dial back, because we have to edit the number before we can dial it back.
Can anybody tell me how to get that 0 back?
I've posted my router configuration at the bottom here, maybe something is missing there?
hostname office-voicegw
!
boot-start-marker
boot system flash c2800nm-spservicesk9-mz.124-9.T.bin
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
network-clock-participate wic 0
network-clock-select 1 BRI0/0/0
!
!
ip cef
!
!
ip domain name office.quanza.net
ip name-server 192.168.1.3
ip name-server 192.168.1.254
!
isdn switch-type basic-net3
!
!
trunk group 100
!
voice-card 0
dspfarm
!
!
voice rtp send-recv
!
voice service voip
allow-connections h323 to h323
h323
!
!
voice class codec 1
codec preference 1 g711ulaw
!
!
!
voice class h323 1
h225 timeout tcp establish 3
call preserve
!
!
!
!
!
!
!
!
!
!
voice translation-rule 1
rule 1 /^00/ /0/
rule 2 /^01233/ /1233/
!
!
voice translation-profile TRANSOUT
translate called 1
translate redirect-called 1
!
!
interface FastEthernet0/0
ip address 192.168.1.4 255.255.255.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr 192.168.1.4
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface BRI0/0/0
no ip address
isdn switch-type basic-net3
isdn incoming-voice voice
isdn outgoing ie facility
isdn outgoing ie progress-indicator
isdn outgoing ie network-facility
isdn outgoing ie notify-indicator
isdn outgoing display-ie
isdn outgoing ie caller-number
isdn outgoing ie caller-subaddr
isdn outgoing ie called-number
isdn outgoing ie called-subaddr
isdn outgoing ie low-layer-compat
isdn outgoing ie high-layer-compat
isdn outgoing ie user-user
isdn static-tei 0
trunk-group 100
!
interface BRI0/0/1
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn incoming-voice voice
isdn static-tei 0
!
ip route 0.0.0.0 0.0.0.0 192.168.1.254
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0
compand-type a-law
cptone NL
!
voice-port 0/0/1
compand-type a-law
cptone NL
!
!
!
!
!
dial-peer voice 1000 pots
trunkgroup 100
description *** inkomende gesprekken ***
incoming called-number *number removed for privacy*
direct-inward-dial
forward-digits 0
!
dial-peer voice 1002 pots
trunkgroup 100
description *** Uitbellen nationaal ***
translation-profile outgoing TRANSOUT
destination-pattern 00[1-8]........
forward-digits all
!
dial-peer voice 1003 pots
trunkgroup 100
description *** Uitbellen internationaal ***
translation-profile outgoing TRANSOUT
destination-pattern 000[1-8]T
forward-digits all
!
dial-peer voice 1004 pots
trunkgroup 100
description *** uitbellen naar 0800 en 0900 ***
translation-profile outgoing TRANSOUT
destination-pattern 00[8-9]00T
forward-digits all
!
dial-peer voice 112 pots
trunkgroup 100
description *** naar 112 alarm centrale***
translation-profile outgoing TRANSOUT
destination-pattern 0112
forward-digits all
!
dial-peer voice 2 voip
destination-pattern *number removed for privacy*
session target ipv4:192.168.1.3
incoming called-number .T
tech-prefix 0
dtmf-relay h245-alphanumeric
codec g711ulaw
fax-relay ecm disable
fax rate disable
no vad
!
!
no dial-peer outbound status-check pots
gateway
timer receive-rtp 1200
!
!
!
line con 0
line aux 0
line vty 0 4
exec-timeout 30 0
privilege level 15
password flf123
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
!
end