b0y37
Technical User
- Nov 27, 2007
- 8
Hi there.
I have a multilink laboratory setup, composed of two Cisco routers back to back. One is an Cisco ISR 1841 and the other is a Cisco3745.I configured both of them for multilink and setup a cbwfq for qos. But it appears that (my monitoring tool is PRTG, btw) the routers does not dedicate my specified bandwidth between two hosts.
For reference, "sh ver" output from the 1841:
Cisco IOS Software, 1841 Software (C1841-IPBASE-M), Version 12.3(8)T11, RELEASE
SOFTWARE (fc1)
Technical Support: Copyright (c) 1986-2005 by Cisco Systems, Inc.
Compiled Wed 10-Aug-05 15:43 by dchih
ROM: System Bootstrap, Version 12.3(8r)T9, RELEASE SOFTWARE (fc1)
And here is my running config:Current configuration : 1617 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISR1841
!
boot-start-marker
boot-end-marker
!
no logging console
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
ip cef
!no ip domain lookup
no ftp-server write-enable
!
!
!
class-map match-any MIX
description prioritize critical traffic
match access-group 102
!
!
policy-map prioritize_mimix
class MIX
priority 5000
class class-default
fair-queue
!
!
!
interface Multilink1
ip address 10.1.0.154 255.255.255.252
service-policy output prioritize_mimix
ppp multilink
ppp multilink fragment delay 1
ppp multilink interleave
ppp multilink group 1
ppp multilink multiclass
!
interface FastEthernet0/0
ip address 10.89.0.254 255.255.0.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface Serial0/1/0
bandwidth 4000
ip address 192.168.1.2 255.255.255.0
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 1
!
interface Serial0/1/1
bandwidth 4000
ip address 192.168.2.2 255.255.255.0
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 1
!
interface Async0/0/0
no ip address
!
interface Async0/0/1
no ip address
!
ip classless
ip route 10.88.0.0 255.255.0.0 10.1.0.153
ip route 10.90.0.0 255.255.0.0 10.1.0.153
ip http server
!
!
access-list 102 permit ip any host 10.88.0.1
ip classless
ip route 10.88.0.0 255.255.0.0 10.1.0.153
ip route 10.90.0.0 255.255.0.0 10.1.0.153
ip http server
!
!
access-list 102 permit ip any host 10.88.0.1
!I even tried access-list 102 permit ip host 10.89.0.1 host 10.88.0.1
!
control-plane
!
!
line con 0
line aux 0
line 0/0/0 0/0/1
stopbits 1
speed 115200
flowcontrol hardware
line vty 0 4
login
!
end
"sh ver" for the C3745:
IOS (tm) 3700 Software (C3745-I-M), Version 12.2(13)T1, RELEASE SOFTWARE (fc1)
TAC Support: Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Fri 03-Jan-03 15:12 by ccai
Image text-base: 0x60008940, data-base: 0x60C28000
ROM: System Bootstrap, Version 12.2(8r)T2, RELEASE SOFTWARE (fc1)
Running config for the cisco3745:
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname C3745
!
no logging console
no logging monitor
!
ip subnet-zero
!
!
no ip domain lookup
!
class-map match-any MIX
description prioritize critical traffic
match access-group name mimix_priority
!policy-map mimix
class MIX
priority 5000
class class-default
bandwidth 1000
!
!
!
!
!
interface Multilink1
ip address 10.1.0.153 255.255.255.252
max-reserved-bandwidth 90
service-policy output mimix
ppp multilink
ppp multilink fragment-delay 1
ppp multilink interleave
multilink-group 1
!
interface FastEthernet0/0
ip address 10.88.0.254 255.255.0.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.90.0.254 255.255.0.0
duplex auto
speed auto
!
interface FastEthernet4/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial4/0
bandwidth 4000
no ip address
encapsulation ppp
clockrate 4000000
no fair-queue
ppp multilink
multilink-group 1
!
interface FastEthernet4/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial4/1
bandwidth 4000
no ip address
encapsulation ppp
clockrate 4000000
no fair-queue
ppp multilink
multilink-group 1
!
ip flow-export version 5
ip flow-export destination 10.89.0.1 17
ip classless
ip route 10.89.0.0 255.255.0.0 10.1.0.154
ip http server
!
!
ip access-list extended mimix_priority
permit ip host 10.88.0.1 host 10.89.0.1
!
snmp-server community ****** RO
snmp-server enable traps tty
snmp-server host 10.88.0.1 ******
!
line con 0
line aux 0
line vty 0 4
login
!
end
I tested my setup using various ftp sessions between
10.89.0.1 (server) to 10.88.0.1 and 10.90.0.1. But i noticed that the bandwidth are just divided equally among the ftp sessions(fair-queue?). My goal is to have a constant 5Mbps between 10.89.0.1 and 10.88.0.1.
I have been playing with commands like ppp multilink multiclass and the fair-queue command, but i cant seem to make it work.
Any more ideas?
TIA
I have a multilink laboratory setup, composed of two Cisco routers back to back. One is an Cisco ISR 1841 and the other is a Cisco3745.I configured both of them for multilink and setup a cbwfq for qos. But it appears that (my monitoring tool is PRTG, btw) the routers does not dedicate my specified bandwidth between two hosts.
For reference, "sh ver" output from the 1841:
Cisco IOS Software, 1841 Software (C1841-IPBASE-M), Version 12.3(8)T11, RELEASE
SOFTWARE (fc1)
Technical Support: Copyright (c) 1986-2005 by Cisco Systems, Inc.
Compiled Wed 10-Aug-05 15:43 by dchih
ROM: System Bootstrap, Version 12.3(8r)T9, RELEASE SOFTWARE (fc1)
And here is my running config:Current configuration : 1617 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISR1841
!
boot-start-marker
boot-end-marker
!
no logging console
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
ip cef
!no ip domain lookup
no ftp-server write-enable
!
!
!
class-map match-any MIX
description prioritize critical traffic
match access-group 102
!
!
policy-map prioritize_mimix
class MIX
priority 5000
class class-default
fair-queue
!
!
!
interface Multilink1
ip address 10.1.0.154 255.255.255.252
service-policy output prioritize_mimix
ppp multilink
ppp multilink fragment delay 1
ppp multilink interleave
ppp multilink group 1
ppp multilink multiclass
!
interface FastEthernet0/0
ip address 10.89.0.254 255.255.0.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface Serial0/1/0
bandwidth 4000
ip address 192.168.1.2 255.255.255.0
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 1
!
interface Serial0/1/1
bandwidth 4000
ip address 192.168.2.2 255.255.255.0
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 1
!
interface Async0/0/0
no ip address
!
interface Async0/0/1
no ip address
!
ip classless
ip route 10.88.0.0 255.255.0.0 10.1.0.153
ip route 10.90.0.0 255.255.0.0 10.1.0.153
ip http server
!
!
access-list 102 permit ip any host 10.88.0.1
ip classless
ip route 10.88.0.0 255.255.0.0 10.1.0.153
ip route 10.90.0.0 255.255.0.0 10.1.0.153
ip http server
!
!
access-list 102 permit ip any host 10.88.0.1
!I even tried access-list 102 permit ip host 10.89.0.1 host 10.88.0.1
!
control-plane
!
!
line con 0
line aux 0
line 0/0/0 0/0/1
stopbits 1
speed 115200
flowcontrol hardware
line vty 0 4
login
!
end
"sh ver" for the C3745:
IOS (tm) 3700 Software (C3745-I-M), Version 12.2(13)T1, RELEASE SOFTWARE (fc1)
TAC Support: Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Fri 03-Jan-03 15:12 by ccai
Image text-base: 0x60008940, data-base: 0x60C28000
ROM: System Bootstrap, Version 12.2(8r)T2, RELEASE SOFTWARE (fc1)
Running config for the cisco3745:
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname C3745
!
no logging console
no logging monitor
!
ip subnet-zero
!
!
no ip domain lookup
!
class-map match-any MIX
description prioritize critical traffic
match access-group name mimix_priority
!policy-map mimix
class MIX
priority 5000
class class-default
bandwidth 1000
!
!
!
!
!
interface Multilink1
ip address 10.1.0.153 255.255.255.252
max-reserved-bandwidth 90
service-policy output mimix
ppp multilink
ppp multilink fragment-delay 1
ppp multilink interleave
multilink-group 1
!
interface FastEthernet0/0
ip address 10.88.0.254 255.255.0.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.90.0.254 255.255.0.0
duplex auto
speed auto
!
interface FastEthernet4/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial4/0
bandwidth 4000
no ip address
encapsulation ppp
clockrate 4000000
no fair-queue
ppp multilink
multilink-group 1
!
interface FastEthernet4/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial4/1
bandwidth 4000
no ip address
encapsulation ppp
clockrate 4000000
no fair-queue
ppp multilink
multilink-group 1
!
ip flow-export version 5
ip flow-export destination 10.89.0.1 17
ip classless
ip route 10.89.0.0 255.255.0.0 10.1.0.154
ip http server
!
!
ip access-list extended mimix_priority
permit ip host 10.88.0.1 host 10.89.0.1
!
snmp-server community ****** RO
snmp-server enable traps tty
snmp-server host 10.88.0.1 ******
!
line con 0
line aux 0
line vty 0 4
login
!
end
I tested my setup using various ftp sessions between
10.89.0.1 (server) to 10.88.0.1 and 10.90.0.1. But i noticed that the bandwidth are just divided equally among the ftp sessions(fair-queue?). My goal is to have a constant 5Mbps between 10.89.0.1 and 10.88.0.1.
I have been playing with commands like ppp multilink multiclass and the fair-queue command, but i cant seem to make it work.
Any more ideas?
TIA