Hi, I have setup three Cisco 1720 routers in my Lab and everything is working fine within the routers. One thing I have not been able to do is to reach the Internet through my WAN router (Named WAN because its directly connected to my wireless sitting behind the ISP's router). It has one interface each connected to the other two routers that I am trying to ping from.
Following is the configuration of my WAN router:
WAN#sh ru
Building configuration...
Current configuration : 1584 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname WAN
!
boot-start-marker
boot-end-marker
!
enable password
!
memory-size iomem 25
no aaa new-model
ip subnet-zero
!
!
ip name-server 192.168.2.1
ip dhcp excluded-address 10.1.1.1 10.1.1.10
!
ip cef
!
!
!
!
!
interface Ethernet0
description LAN
ip address 10.1.1.1 255.255.255.0
ip nat inside
full-duplex
!
interface Ethernet1
ip address 192.168.1.2 255.255.255.0
half-duplex
!
interface FastEthernet0
description WAN
ip address 192.168.2.50 255.255.255.0
ip nat outside
ip nbar protocol-discovery
speed auto
!
router ospf 10
log-adjacency-changes
redistribute static subnets
passive-interface FastEthernet0
network 10.1.1.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
!
ip nat inside source list 2 interface FastEthernet0 overload
ip nat inside source static tcp 10.1.1.11 3389 192.168.2.50 3389 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1
no ip http server
!
access-list 2 permit 10.1.1.0 0.0.0.255 log
access-list 2 permit 192.168.1.0 0.0.0.255 log
access-list 2 permit 172.16.1.0 0.0.0.255 log
access-list 101 permit tcp any any eq 3389
access-list 101 permit tcp any any eq domain
access-list 101 permit tcp any any eq www
access-list 101 permit icmp any any
alias exec traffic sh ip nbar protocol-discovery stats bit-rate top-n 10
!
line con 0
exec-timeout 3660 0
line aux 0
password 7
line vty 0 4
password 7
login
!
end
-------------------------------------------------------
No here is the Config. on the other router that is connected to this WAN router but can not get to the WAN side of it (through the WAN router):
R-1#sh ru
Building configuration...
Current configuration : 960 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname R-1
!
enable password 7
!
!
!
!
!
memory-size iomem 15
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
ip address 172.17.2.1 255.255.255.252
!
interface Serial0
ip address 192.168.4.1 255.255.255.0
shutdown
!
interface Serial1
ip address 172.16.1.2 255.255.255.0
no fair-queue
clockrate 64000
!
interface FastEthernet0
ip address 192.168.1.1 255.255.255.0
speed auto
!
router ospf 10
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 172.16.1.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.4.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
!
line con 0
line aux 0
modem InOut
no exec
transport input all
stopbits 1
line vty 0 4
password 7
login
!
no scheduler allocate
end
Following is the configuration of my WAN router:
WAN#sh ru
Building configuration...
Current configuration : 1584 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname WAN
!
boot-start-marker
boot-end-marker
!
enable password
!
memory-size iomem 25
no aaa new-model
ip subnet-zero
!
!
ip name-server 192.168.2.1
ip dhcp excluded-address 10.1.1.1 10.1.1.10
!
ip cef
!
!
!
!
!
interface Ethernet0
description LAN
ip address 10.1.1.1 255.255.255.0
ip nat inside
full-duplex
!
interface Ethernet1
ip address 192.168.1.2 255.255.255.0
half-duplex
!
interface FastEthernet0
description WAN
ip address 192.168.2.50 255.255.255.0
ip nat outside
ip nbar protocol-discovery
speed auto
!
router ospf 10
log-adjacency-changes
redistribute static subnets
passive-interface FastEthernet0
network 10.1.1.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
!
ip nat inside source list 2 interface FastEthernet0 overload
ip nat inside source static tcp 10.1.1.11 3389 192.168.2.50 3389 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1
no ip http server
!
access-list 2 permit 10.1.1.0 0.0.0.255 log
access-list 2 permit 192.168.1.0 0.0.0.255 log
access-list 2 permit 172.16.1.0 0.0.0.255 log
access-list 101 permit tcp any any eq 3389
access-list 101 permit tcp any any eq domain
access-list 101 permit tcp any any eq www
access-list 101 permit icmp any any
alias exec traffic sh ip nbar protocol-discovery stats bit-rate top-n 10
!
line con 0
exec-timeout 3660 0
line aux 0
password 7
line vty 0 4
password 7
login
!
end
-------------------------------------------------------
No here is the Config. on the other router that is connected to this WAN router but can not get to the WAN side of it (through the WAN router):
R-1#sh ru
Building configuration...
Current configuration : 960 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname R-1
!
enable password 7
!
!
!
!
!
memory-size iomem 15
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
ip address 172.17.2.1 255.255.255.252
!
interface Serial0
ip address 192.168.4.1 255.255.255.0
shutdown
!
interface Serial1
ip address 172.16.1.2 255.255.255.0
no fair-queue
clockrate 64000
!
interface FastEthernet0
ip address 192.168.1.1 255.255.255.0
speed auto
!
router ospf 10
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 172.16.1.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.4.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
!
line con 0
line aux 0
modem InOut
no exec
transport input all
stopbits 1
line vty 0 4
password 7
login
!
no scheduler allocate
end