richdthomas
Programmer
Hi,
Our ISP is now providing over 1Mb download speed and the Cisco 1721 router I have between our cable modem and LAN switch is being a bottleneck, so we can't benefit from the increased speed.
When I connected my laptop directly to the cable modem, I got a 5Mb download and 0.5Mb upload.
When put the router between my laptop and the cable modem, I got a 0.7Mb download and 0.4Mb upload.
I've tried the "ip route-cache" "ip route-cache same-interface" "ip route-cache flow" "ip cef" commands, one at a time on both the inside and outside interfaces and can't get any more throughput.
Below is a censored copy of my router's config and various diagnostic commands that I ran during my speedtests.
Does anyone have any ideas as to why my throughput is so slow or what I can do to improve it please? Any advice would be much appreciated. Thanks in advance.
Our ISP is now providing over 1Mb download speed and the Cisco 1721 router I have between our cable modem and LAN switch is being a bottleneck, so we can't benefit from the increased speed.
When I connected my laptop directly to the cable modem, I got a 5Mb download and 0.5Mb upload.
When put the router between my laptop and the cable modem, I got a 0.7Mb download and 0.4Mb upload.
I've tried the "ip route-cache" "ip route-cache same-interface" "ip route-cache flow" "ip cef" commands, one at a time on both the inside and outside interfaces and can't get any more throughput.
Below is a censored copy of my router's config and various diagnostic commands that I ran during my speedtests.
Does anyone have any ideas as to why my throughput is so slow or what I can do to improve it please? Any advice would be much appreciated. Thanks in advance.
Code:
1721#show run
Building configuration...
Current configuration : 7965 bytes
!
version 12.4
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 1721
!
boot-start-marker
boot system flash flash:c1700-y-mz.124-8a.bin
boot-end-marker
!
logging buffered 51200 debugging
logging console critical
enable secret 5 ###########################
!
no aaa new-model
!
resource policy
!
!
!
no ip dhcp use vrf connected
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.1.0 192.168.1.1
!
ip dhcp pool rich_laptop_work_wired
host 192.168.1.30 255.255.255.0
client-identifier 0100.0e7b.b453.dd
client-name rich_laptop_work_wired
!
ip dhcp pool shuttle
host 192.168.1.10 255.255.255.0
client-identifier 0100.0dff.010b.63
client-name shuttle
!
ip dhcp pool rich-desktop
host 192.168.1.20 255.255.255.0
client-identifier 0100.1d92.aa07.b5
client-name rich-desktop
!
ip dhcp pool pundit
host 192.168.1.90 255.255.255.0
client-identifier 0100.1731.be1e.3d
client-name pundit
!
ip dhcp pool liz-laptop-wifi
host 192.168.1.141 255.255.255.0
client-identifier 0100.1e4c.7db3.43
client-name liz-laptop-wifi
!
ip dhcp pool wii-wifi
host 192.168.1.144 255.255.255.0
client-identifier 0100.2147.9ffd.45
client-name wii-wifi
!
ip dhcp pool rich-toshiba-wifi
host 192.168.1.143 255.255.255.0
client-identifier 0100.16b6.c3ea.48
client-name rich-toshiba-wifi
!
ip dhcp pool rich-old-hp-wifi
host 192.168.1.146 255.255.255.0
client-identifier 0100.1279.58f8.33
client-name rich-old-hp-wifi
!
ip dhcp pool pda-wifi
host 192.168.1.142 255.255.255.0
client-identifier 0100.1a6b.a585.00
client-name pda-wifi
!
ip dhcp pool liz-ipod-touch
host 192.168.1.148 255.255.255.0
client-identifier 0100.2436.d385.0a
client-name liz-ipod-touch
!
ip dhcp pool rich-dell-wifi
host 192.168.1.147 255.255.255.0
client-identifier 0100.22fb.08d7.6e
client-name rich-dell-wifi
!
ip dhcp pool rich-new-hp-wifi
host 192.168.1.149 255.255.255.0
client-identifier 0100.1302.36b6.a4
client-name rich-new-hp-wifi
!
ip dhcp pool liz-sony-walkman-wifi
host 192.168.1.150 255.255.255.0
client-identifier 0100.21e8.8079.24
client-name liz-sony-walkman-wifi
!
ip dhcp pool rich-nokia-wifi
host 192.168.1.145 255.255.255.0
client-identifier 0100.22fc.d154.44
client-name rich-nokia-wifi
!
ip dhcp pool home
network 192.168.1.0 255.255.255.0
domain-name home.loc
default-router 192.168.1.1
dns-server 194.168.8.100 194.168.4.100 158.43.192.1
!
!
ip cef
!
!
!
!
interface Ethernet0
description External interface to cable modem
bandwidth 2000
ip address dhcp
ip access-group 101 in
no ip proxy-arp
ip nat outside
no ip virtual-reassembly
no ip route-cache cef
no ip route-cache
full-duplex
no cdp enable
hold-queue 100 out
!
interface FastEthernet0
description Internal interface to hub for LAN
bandwidth 10000
ip address 192.168.1.1 255.255.255.0
ip access-group 111 out
no ip proxy-arp
ip nat inside
no ip virtual-reassembly
no ip route-cache cef
no ip route-cache
speed 100
full-duplex
hold-queue 100 out
!
no ip http server
!
ip nat inside source list 1 interface Ethernet0 overload
ip nat inside source static tcp 192.168.1.10 3389 interface Ethernet0 3389
ip nat inside source static tcp 192.168.1.10 6346 interface Ethernet0 6346
ip nat inside source static udp 192.168.1.10 6346 interface Ethernet0 6346
ip nat inside source static tcp 192.168.1.10 9024 interface Ethernet0 9024
ip nat inside source static tcp 192.168.1.10 20699 interface Ethernet0 20699
ip nat inside source static tcp 192.168.1.15 22 interface Ethernet0 1863
!
access-list 1 permit any
access-list 101 remark ==Incoming from Cable modem to Ethernet0==
access-list 101 remark Next line is to allow return TCP packets back in
access-list 101 permit tcp any any range 0 65535 established
access-list 101 remark Next line is to allow RDP in from PX02 at work
access-list 101 permit tcp host ##.##.##.## any eq 3389
access-list 101 remark Next line is to allow RDP in from Mum and Dad's IP
access-list 101 permit tcp host ##.##.##.## any eq 3389
access-list 101 remark Next line is to allow ssh access to CentOS appliance on p
access-list 101 permit tcp host ##.##.##.## any eq 1863 log
access-list 101 remark Next line is to allow P2P TCP port
access-list 101 permit tcp any any eq 6346
access-list 101 remark Next line is to allow Soulseek TCP port
access-list 101 permit tcp any any eq 20699
access-list 101 remark Next line is to allow streaming in
access-list 101 permit tcp any any eq 9024 log
access-list 101 remark Next line is to deny all other TCP traffic
access-list 101 deny tcp any any range 0 65535 log
access-list 101 remark Next 3 lines is to let DNS return packets back in
access-list 101 permit udp host 194.168.8.100 eq domain any
access-list 101 permit udp host 194.168.4.100 eq domain any
access-list 101 permit udp host 158.43.192.1 eq domain any
access-list 101 remark Next 6 lines is to let Nintendo UDP packets in
access-list 101 permit udp host 207.38.8.130 range 0 65535 any log
access-list 101 permit udp host 207.38.8.132 range 0 65535 any log
access-list 101 permit udp host 207.38.11.34 range 0 65535 any log
access-list 101 permit udp host 207.38.11.41 range 0 65535 any log
access-list 101 permit udp host 207.38.11.42 range 0 65535 any log
access-list 101 permit udp host 207.38.11.43 range 0 65535 any log
access-list 101 permit udp any any range 32768 61000 log
access-list 101 remark Next line is to let DHCP from ISP to router in
access-list 101 permit udp any eq bootps any
access-list 101 remark Next line is to allow P2P UDP port
access-list 101 permit udp any any eq 6346
access-list 101 remark Next line is to deny all other UDP traffic
access-list 101 deny udp any any range 0 65535 log
access-list 101 remark Next line is to allow IPSec VPN traffic
access-list 101 permit gre any any
access-list 101 remark Next line is to allow ping in from PX02 at work
access-list 101 permit icmp host 194.202.186.177 any echo
access-list 101 remark Next 3 lines is to allow and deny the relevant ICMP packets
access-list 101 permit icmp any any echo-reply
access-list 101 permit icmp any any ttl-exceeded
access-list 101 permit icmp any any unreachable
access-list 101 remark Next line is to let Nintendo ICMP packets in
access-list 101 permit icmp host 207.38.8.130 any log
access-list 101 permit icmp host 207.38.8.132 any log
access-list 101 deny icmp any any log
access-list 101 remark Next line denies everything else
access-list 101 deny ip any any log
access-list 111 remark Next 3 lines is to let DNS return packets back in
access-list 111 permit udp host 194.168.8.100 eq domain any
access-list 111 permit udp host 192.168.4.100 eq domain any
access-list 111 permit udp host 158.43.192.1 eq domain any
access-list 111 remark Next 5 lines is to let Nintendo UDP packets in
access-list 111 permit udp host 207.38.11.34 eq 27900 host 192.168.1.44 range 32768 61000 log
access-list 111 permit udp host 207.38.11.41 eq 27901 host 192.168.1.44 range 32768 61000 log
access-list 111 permit udp host 207.38.11.42 eq 27901 host 192.168.1.44 range 32768 61000 log
access-list 111 permit udp host 207.38.11.43 eq 27901 host 192.168.1.44 range 32768 61000 log
access-list 111 permit udp any host 192.168.1.44 range 32768 61000 log
access-list 111 remark Next line is to let DHCP from ISP to router in
access-list 111 permit udp any eq bootps any
access-list 111 remark Next line is to allow P2P UDP port
access-list 111 permit udp any any eq 6346
access-list 111 remark Next line is to deny all other UDP traffic
access-list 111 deny udp any any range 0 65535 log
access-list 111 permit ip any any
snmp-server community ############# RW
snmp-server community ####### RO
!
control-plane
!
banner motd ^C1721 Router^C
!
line con 0
password #########
logging synchronous
login
line aux 0
line vty 0 4
password #########
logging synchronous
login
!
end
1721#
1721#show proc cpu
CPU utilization for five seconds: 11%/2%; one minute: 8%; five minutes: 4%
PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process
1 24 10 2400 0.00% 0.00% 0.00% 0 Chunk Manager
2 4 199 20 0.00% 0.00% 0.00% 0 Load Meter
4 1124 117 9606 0.00% 0.10% 0.09% 0 Check heaps
5 0 1 0 0.00% 0.00% 0.00% 0 Pool Manager
6 0 2 0 0.00% 0.00% 0.00% 0 Timers
7 0 2 0 0.00% 0.00% 0.00% 0 Serial Backgroun
8 0 2 0 0.00% 0.00% 0.00% 0 AAA high-capacit
9 0 1 0 0.00% 0.00% 0.00% 0 AAA_SERVER_DEADT
10 0 1 0 0.00% 0.00% 0.00% 0 Policy Manager
11 0 1 0 0.00% 0.00% 0.00% 0 Crash writer
12 0 1 0 0.00% 0.00% 0.00% 0 RO Notify Timers
13 16 57 280 0.00% 0.00% 0.00% 0 ARP Input
14 0 2 0 0.00% 0.00% 0.00% 0 DDR Timers
15 0 101 0 0.00% 0.00% 0.00% 0 HC Counter Timer
16 12 2 6000 0.00% 0.00% 0.00% 0 Entity MIB API
17 40 31 1290 0.00% 0.00% 0.00% 0 EEM ED Syslog
18 0 2 0 0.00% 0.00% 0.00% 0 SMART
19 0 1 0 0.00% 0.00% 0.00% 0 SERIAL A'detect
20 0 990 0 0.00% 0.00% 0.00% 0 GraphIt
21 0 2 0 0.00% 0.00% 0.00% 0 Dialer event
22 0 2 0 0.00% 0.00% 0.00% 0 XML Proxy Client
23 0 1 0 0.00% 0.00% 0.00% 0 Critical Bkgnd
24 8 421 19 0.00% 0.00% 0.00% 0 Net Background
25 0 3 0 0.00% 0.00% 0.00% 0 IDB Work
26 4 49 81 0.00% 0.00% 0.00% 0 Logger
27 0 985 0 0.00% 0.00% 0.00% 0 TTY Background
28 0 1006 0 0.00% 0.00% 0.00% 0 Per-Second Jobs
29 0 9 0 0.00% 0.00% 0.00% 0 DHCPD Timer
30 0 1 0 0.00% 0.00% 0.00% 0 AggMgr Process
31 0 1 0 0.00% 0.00% 0.00% 0 dev_device_inser
32 4 1 4000 0.00% 0.00% 0.00% 0 dev_device_remov
33 0 2 0 0.00% 0.00% 0.00% 0 ESWPPM
34 0 1 0 0.00% 0.00% 0.00% 0 Net Input
35 0 200 0 0.00% 0.00% 0.00% 0 Compute load avg
36 476 17 28000 0.00% 0.02% 0.00% 0 Per-minute Jobs
37 8 2 4000 0.00% 0.00% 0.00% 0 AAA Server
38 0 1 0 0.00% 0.00% 0.00% 0 AAA ACCT Proc
39 0 1 0 0.00% 0.00% 0.00% 0 ACCT Periodic Pr
40 0 2 0 0.00% 0.00% 0.00% 0 AAA Dictionary R
41 15620 14980 1042 6.63% 4.28% 2.13% 0 IP Input
42 0 1 0 0.00% 0.00% 0.00% 0 ICMP event handl
43 0 106 0 0.00% 0.00% 0.00% 0 CDP Protocol
44 5148 5704 902 2.21% 2.25% 0.81% 6 Virtual Exec
45 0 1 0 0.00% 0.00% 0.00% 0 SSS Manager
46 0 135 0 0.00% 0.00% 0.00% 0 SSS Test Client
47 0 1 0 0.00% 0.00% 0.00% 0 SSS Feature Mana
48 8 3907 2 0.00% 0.00% 0.00% 0 SSS Feature Time
49 0 3 0 0.00% 0.00% 0.00% 0 PPP Hooks
50 0 1 0 0.00% 0.00% 0.00% 0 X.25 Encaps Mana
51 0 2 0 0.00% 0.00% 0.00% 0 DTP Protocol
52 4 2 2000 0.00% 0.00% 0.00% 0 PPP IP Route
53 0 2 0 0.00% 0.00% 0.00% 0 PPP IPCP
54 72 1983 36 0.00% 0.00% 0.00% 0 DHCPD Receive
55 20 49 408 0.00% 0.00% 0.00% 0 IP Background
56 16 27 592 0.00% 0.00% 0.00% 0 IP RIB Update
57 32 385 83 0.00% 0.01% 0.00% 0 TCP Timer
58 4 3 1333 0.00% 0.00% 0.00% 0 TCP Protocols
59 0 1 0 0.00% 0.00% 0.00% 0 IP Traceroute
60 0 1 0 0.00% 0.00% 0.00% 0 RARP Input
61 4 989 4 0.00% 0.00% 0.00% 0 Socket Timers
62 0 5 0 0.00% 0.00% 0.00% 0 HTTP CORE
63 0 17 0 0.00% 0.00% 0.00% 0 IP Cache Ager
64 0 1 0 0.00% 0.00% 0.00% 0 PAD InCall
65 0 2 0 0.00% 0.00% 0.00% 0 X.25 Background
66 0 2 0 0.00% 0.00% 0.00% 0 PPP SSS
67 0 18 0 0.00% 0.00% 0.00% 0 Adj Manager
68 40 1321 30 0.00% 0.00% 0.00% 0 CEF process
69 0 2 0 0.00% 0.00% 0.00% 0 PPP Bind
70 0 2 0 0.00% 0.00% 0.00% 0 LOCAL AAA
71 0 2 0 0.00% 0.00% 0.00% 0 ENABLE AAA
72 0 2 0 0.00% 0.00% 0.00% 0 LINE AAA
73 0 2 0 0.00% 0.00% 0.00% 0 TPLUS
74 0 1 0 0.00% 0.00% 0.00% 0 Key chain liveke
75 0 42 0 0.00% 0.00% 0.00% 0 CRM_CALL_UPDATE_
76 0 1 0 0.00% 0.00% 0.00% 0 EM Background Pr
77 0 2 0 0.00% 0.00% 0.00% 0 AAA SEND STOP EV
78 0 1 0 0.00% 0.00% 0.00% 0 Syslog Traps
79 0 1 0 0.00% 0.00% 0.00% 0 PM Callback
80 4 3 1333 0.00% 0.00% 0.00% 0 EEM ED CLI
81 4 2 2000 0.00% 0.00% 0.00% 0 EEM ED Counter
82 0 2 0 0.00% 0.00% 0.00% 0 EEM ED Interface
83 0 3 0 0.00% 0.00% 0.00% 0 EEM ED IOSWD
84 0 2 0 0.00% 0.00% 0.00% 0 EEM ED Memory-th
85 4 2 2000 0.00% 0.00% 0.00% 0 EEM ED None
86 0 2 0 0.00% 0.00% 0.00% 0 EM ED OIR
87 0 2 0 0.00% 0.00% 0.00% 0 EEM ED SNMP
88 0 18 0 0.00% 0.00% 0.00% 0 EEM ED Timer
89 8 216 37 0.00% 0.00% 0.00% 0 EEM Server
90 4 25 160 0.00% 0.00% 0.00% 0 Syslog
91 8 2 4000 0.00% 0.00% 0.00% 0 VLAN Manager
92 0 2 0 0.00% 0.00% 0.00% 0 EEM Policy Direc
94 28 1116 25 0.00% 0.00% 0.00% 0 DHCP Client
96 16 1930 8 0.00% 0.00% 0.00% 0 IP NAT Ager
97 0 1 0 0.00% 0.00% 0.00% 0 IP NAT WLAN
98 0 1 0 0.00% 0.00% 0.00% 0 IP VFR proc
99 8 35 228 0.00% 0.00% 0.00% 0 CEF Scanner
100 0 2 0 0.00% 0.00% 0.00% 0 SNMP Timers
101 8 14 571 0.00% 0.00% 0.00% 0 IP SNMP
102 4 7 571 0.00% 0.00% 0.00% 0 PDU DISPATCHER
103 40 7 5714 0.00% 0.00% 0.00% 0 SNMP ENGINE
104 0 1 0 0.00% 0.00% 0.00% 0 SNMP ConfCopyPro
105 0 1 0 0.00% 0.00% 0.00% 0 SNMP Traps
106 268 2383 112 0.00% 0.01% 0.00% 0 NAT MIB Helper
107 0 22 0 0.00% 0.00% 0.00% 0 DHCPD Database
1721#show memory summary
Head Total(b) Used(b) Free(b) Lowest(b) Largest(b)
Processor 81607F24 61462300 12031712 49430588 49254012 47197164
I/O 5060C00 16380928 1500840 14880088 14880088 14880060
1721#show interfaces stat
Ethernet0
Switching path Pkts In Chars In Pkts Out Chars Out
Processor 13305 12344283 8665 3697870
Route cache 13 1841 0 0
Total 13318 12346124 8665 3697870
FastEthernet0
Switching path Pkts In Chars In Pkts Out Chars Out
Processor 9237 3733409 13535 12464273
Route cache 0 0 0 0
Total 9237 3733409 13535 12464273
NVI0
Switching path Pkts In Chars In Pkts Out Chars Out
Processor 0 0 0 0
Route cache 0 0 0 0
Total 0 0 0 0
1721#
1721#show interfaces switching
Ethernet0 External interface to cable modem
Throttle count 0
Drops RP 0 SP 0
SPD Flushes Fast 0 SSE 0
SPD Aggress Fast 0
SPD Priority Inputs 2 Drops 0
Protocol IP
Switching path Pkts In Chars In Pkts Out Chars Out
Process 14934 13941989 9823 4594949
Cache misses 33 - - -
Fast 13 1841 0 0
Auton/SSE 0 0 0 0
Protocol ARP
Switching path Pkts In Chars In Pkts Out Chars Out
Process 2 120 3 180
Cache misses 0 - - -
Fast 0 0 0 0
Auton/SSE 0 0 0 0
Protocol Other
Switching path Pkts In Chars In Pkts Out Chars Out
Process 0 0 134 8040
Cache misses 0 - - -
Fast 0 0 0 0
Auton/SSE 0 0 0 0
NOTE: all counts are cumulative and reset only after a reload.
FastEthernet0 Internal interface to hub for LAN
Throttle count 0
Drops RP 0 SP 0
SPD Flushes Fast 0 SSE 0
SPD Aggress Fast 0
SPD Priority Inputs 25 Drops 0
Protocol IP
Switching path Pkts In Chars In Pkts Out Chars Out
Process 10566 4640908 14993 14139344
Cache misses 1 - - -
Fast 0 0 0 0
Auton/SSE 0 0 0 0
Protocol ARP
Switching path Pkts In Chars In Pkts Out Chars Out
Process 25 1500 108 6480
Cache misses 0 - - -
Fast 0 0 0 0
Auton/SSE 0 0 0 0
Protocol CDP
Switching path Pkts In Chars In Pkts Out Chars Out
Process 0 0 32 10425
Cache misses 0 - - -
Fast 0 0 0 0
Auton/SSE 0 0 0 0
Protocol Other
Switching path Pkts In Chars In Pkts Out Chars Out
Process 0 0 133 7980
Cache misses 0 - - -
Fast 0 0 0 0
Auton/SSE 0 0 0 0
NOTE: all counts are cumulative and reset only after a reload.
NVI0
All statistics for this interface are zero.
1721#