Hi all,
I am trying to do something very simple, I have a cisco router running ios 12.4 with two vlans attatched to two of the physical interfaces.
! ---- Local Interface Configuration
!
interface FastEthernet0
no shutdown
switchport mode access
switchport access vlan 1
!
interface FastEthernet1
shutdown
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
no shutdown
switchport mode access
switchport access vlan 2
!
! ---- VLAN Configuration
!
interface Vlan1
ip address 192.168.8.20 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1350
no ip mroute-cache
!
!
interface Vlan2
ip address 192.168.9.1 255.255.255.0
ip nat outside
ip access-group 101 in
!
!
access-list 101 permit ip 192.168.8.0 0.0.0.255 any
With this configuration the router can access all hosts on each network, however the situation I am trying to achieve is to have all the hosts on the 192.168.8.0/24 network to be able to contact the hosts on the 192.168.9.0/24 network.
Currently the hosts on 192.168.8.0/24 can contact 192.168.9.1 (the router) but not the hosts connected to that interface.
As a connected interface the route to 192.168.9.0/24 via Vlan2 appears in the routing table. I have also tried using nat in the following manner
ip nat inside source list 1 interface Vlan2 overload
I'm sure this is a trivial task in IOS and I apologise for the newibie question. Any guidance is much appreciated.
Thank you.
I am trying to do something very simple, I have a cisco router running ios 12.4 with two vlans attatched to two of the physical interfaces.
! ---- Local Interface Configuration
!
interface FastEthernet0
no shutdown
switchport mode access
switchport access vlan 1
!
interface FastEthernet1
shutdown
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
no shutdown
switchport mode access
switchport access vlan 2
!
! ---- VLAN Configuration
!
interface Vlan1
ip address 192.168.8.20 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1350
no ip mroute-cache
!
!
interface Vlan2
ip address 192.168.9.1 255.255.255.0
ip nat outside
ip access-group 101 in
!
!
access-list 101 permit ip 192.168.8.0 0.0.0.255 any
With this configuration the router can access all hosts on each network, however the situation I am trying to achieve is to have all the hosts on the 192.168.8.0/24 network to be able to contact the hosts on the 192.168.9.0/24 network.
Currently the hosts on 192.168.8.0/24 can contact 192.168.9.1 (the router) but not the hosts connected to that interface.
As a connected interface the route to 192.168.9.0/24 via Vlan2 appears in the routing table. I have also tried using nat in the following manner
ip nat inside source list 1 interface Vlan2 overload
I'm sure this is a trivial task in IOS and I apologise for the newibie question. Any guidance is much appreciated.
Thank you.