Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations IamaSherpa on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Basic BGP routing between 3 Cisco routers

Status
Not open for further replies.
Dec 27, 2002
13
US
Hello,

Can someone please help with basic BGP setup with 3 routers?
I have Router A, B, and C. B is in the middle of A and C. I would like to have Routers A and C be in one AS and Router B in another AS. What simple commands do you need to get this going? I have the BGP process started and I had each router a nieghbor statement on each that is is adjacently attached to but I am not able to ping across A to C and C to A. Of course B can hit both. Any help will do.


Router A
s0/0 12.12.12.13/30
e0/0 192.168.1.1/24
AS 65008
Router B
s0/0 12.12.12.14/30
s0/1 12.8.8.18/30
e0/0 192.168.2.1/24
AS 65000
Router C
s0/0 12.8.8.17/30
e0/0 192.168.3.1/24
AS 65008

Router A has
router bgp 65008
network 192.168.1.0
neighbor 12.12.12.14 remote-as 65000
no auto-summary
Router B has
router bgp 65000
network 192.168.2.0
neighbor 12.12.12.13 remote-as 65008
neighbor 12.8.8.17 remote-as 65008
no auto-summary
Router C has
router bgp 65008
network 192.168.3.0
neighbor 12.8.8.18 remote-as 65000
no auto-summary

I cannot ping 192.168.3.1 from Router A and vice versa from Router C. What am I missing? Thanks,


Johnny K
 
Actually neighbor ids have nothing to do with the adjacencies forming. They matter in ospf virtual links not bgp. BGP to OSPF redistribution needs the same router id on both processes.

make sure you have

router bgp xxxxxx
no synchronization

and

ip classless



Lui3
CCNP,CCDA,A+/Net+
Cisco Wireless Specialization
 
Disregard that last post; I don't know what I was thinking. Drunken dwarfs were using my computer.

I believe the problem you are experiencing is due to iBGP synchronization. Right about here I wrote a long explanation of why, but the univercd link also has a better example of why we use iBGP so you'd do well to read that instead.

If you disable synchronization on both routers it should work:

no synchronization
 
Dang! lui3 beat me to my own correction! I'll type faster next time.
 
Thanks for the tip guys, though I put no synchronization on all 3 routers and made sure ip classless was enabled as opposed to no ip classless and it is still not work. Router A cannot ping router C. In other words, Routers A and C are not advertising their networks across. Of course Router B can see both network and ping all interface because he is adjacent? Anything else? How about Router Reflectors? My goal is to run these routers with BGP and not use a IGP in conjunction with BGP.

Johnny
 
You're not advertising your serial link IP networks. If those pings are exiting the routers on a serial interface, the destination router will have no idea where to send a reply.
 
Thanks jneiberger, though I did advertise each serial int on each router, for some reason I can only ping from A to C and not C to B. I am trying to have both local e0/0 ping each other. I check the sh ip route and I do not see on C that it has learned the network 192.168.1.0 network from A.

Johnny
 
Can you show us a text diagram of your connections? Also, please post your configs.
 
Hi jneiberger,

My original post included just a basic set up of what I wanted to get me in the direction I want to go but I guess going that way is not going to help me without detailed facts.
Here is exactly what I am facing.

I have 4 routers and have included configs. I have routers setup in a hub and spoke topology. Now adjacent to H is a 3560 Switch which we will call SW3560. This Layer2/3 switch is running EIGRP and is connected to other routers running EIGRP and all networks behind that are the 192.168.0.0/24 networks. My ultimate goal is to get the hub and spoke network running BGP. If you noticed, the local ethernet interfaces of each BGP router is on the 192.168.0.0 network. I eventually want these networks redistrubuted into EIGRP so they can talk to the other side. Right now my problem is trying to get the local ethernet interfaces of each BGP router to talk to each other BGP spoke router. All the serial interfaces can talk and advertise but the 192.168.0.0 networks are not advertising even though I am specifically advertising them. What am I doing wrong and let me know if you need any other information. Thanks.

Router F is the hub and Routers D, C, and H are the spokes.

RouterF

!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
ip address 12.12.12.18 255.255.255.252
half-duplex
!
interface Serial0/0
ip address 12.7.7.6 255.255.255.252
no fair-queue
service-module t1 clock source internal
!
interface Serial0/1
ip address 12.20.20.42 255.255.255.252
clockrate 768000
!
router bgp 65000
no synchronization
no bgp log-neighbor-changes
network 12.7.7.4 mask 255.255.255.252
network 12.12.12.16 mask 255.255.255.252
network 12.20.20.40 mask 255.255.255.252
neighbor 12.7.7.5 remote-as 65008
neighbor 12.12.12.17 remote-as 65008
neighbor 12.20.20.41 remote-as 65008
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0
no ip http server
!
!
dial-peer cor custom
!
!
!
RouterF#



Router D

!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Ethernet0/0
ip address 192.168.3.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
no ip mroute-cache
half-duplex
!
!
interface Serial0/1
ip address 12.20.20.41 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
!
!
router bgp 65008
no synchronization
no bgp log-neighbor-changes
network 12.20.20.40 mask 255.255.255.252
network 192.168.3.0
neighbor 12.20.20.42 remote-as 65000
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 12.20.20.42
no ip http server
!
!
dial-peer cor custom


ROUTER C

!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.17 255.255.255.252
no keepalive
duplex auto
speed auto

interface FastEthernet1/0
ip address 192.168.101.1 255.255.255.0
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 172.16.101.1 255.255.255.0
duplex auto
speed auto
!
router bgp 65008
no synchronization
no bgp log-neighbor-changes
network 12.12.12.16 mask 255.255.255.252
network 172.16.101.0 mask 255.255.255.0
network 192.168.101.0
neighbor 12.12.12.18 remote-as 65000
no auto-summary
!
ip kerberos source-interface any
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
no ip http server
!
!
!
dial-peer cor custom
!
ROUTER H


!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Ethernet0/0
ip address 192.168.1.204 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 12.7.7.5 255.255.255.252
!
interface Serial0/1
ip address 12.8.8.9 255.255.255.252
shutdown
!
!
router eigrp 50
redistribute bgp 65008 metric 1500 2000 255 1 100
network 12.7.7.4 0.0.0.3
network 192.168.0.0
network 192.168.1.0
no auto-summary
!
router bgp 65008
no synchronization
no bgp log-neighbor-changes
network 12.7.7.4 mask 255.255.255.252
network 192.168.1.0
neighbor 12.7.7.6 remote-as 65000
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip http server
!
!
 
Wait a second... correct me if I have this wrong.

A is in 65008
B is in 65000
C is in 65008

B connects A and C?!

I see now. A/C gets updates from AS system 65008, thinks it is a little weird that it's receiving updates from it's self, figures it must be a loop or something, so it discards the update. What you WANT is A and B in the same AS, B and C in the same AS or put all three in different AS's.
 
since you want the same AS at both ends..
your router B's neighbor statements will need the as-overide command..
or else im pretty sure BGP will not put the routes into the routing table...

for simplicity you could also do a redistribute connected to make sure all your interfaces are being advertised..

as a test....

on router b
what is the output of
sh ip bgp sum

are the neighbor relationships forming ok? are you receiving routes from A and C ?
 
I would just change the AS number of A or C - no further commands would be needed. Not to imply that plshlpme's solution wouldn't work.
 
I would like to thank all who helped assist me getting this going. I made each router in its AS and each router is routing across the core BGP Router F. Thanks,

Jimmy
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top