Hi Everyone!
What Iam trying to do is to connect two routers via serial ports. I followed instructions from cisco..
I did everything the way they said but the connection does not stay up. Right when I finish configuring the the second router and I issue a no shutdown command to s0, the 2 routers will communicate for like 30 seconds and then the connection goes down. Here are the configs for both routers.
RouterA#sho run
Current configuration : 499 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
!
ip subnet-zero
!
!
!
!
interface Ethernet0
no ip address
shutdown
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
ip address 172.16.0.1 255.255.0.0
clock rate 64000
no cdp enable
!
interface Serial1
no ip address
shutdown
!
ip classless
ip http server
!
!
line con 0
line aux 0
line vty 0 4
!
end
RouterA#sho in s0
Serial0 is up, line protocol is down
Hardware is HD64570
Internet address is 172.16.0.1/16
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, loopback not set
Keepalive set (10 sec)
Last input never, output 00:00:07, output hang never
Last clearing of "show interface" counters 00:32:02
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
14 input errors, 14 CRC, 0 frame, 0 overrun, 0 ignored, 13 abort
113 packets output, 2486 bytes, 0 underruns
0 output errors, 0 collisions, 64 interface resets
0 output buffer failures, 0 output buffers swapped out
61 carrier transitions
RouterB#sho run
Current configuration : 420 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
!
!
!
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
ip address 172.16.0.3 255.255.0.0
no fair-queue
no ip address
shutdown
!
interface Serial0
ip address 172.16.0.3 255.255.0.0
no fair-queue
no cdp enable
!
interface Serial1
no ip address
shutdown
!
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
!
end
RouterB#sho in s0
Router#sho in s0
Serial0 is up, line protocol is down
Hardware is HD64570
Internet address is 172.16.0.3/16
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 179/255, txload 1/255, rxload 1/255
Encapsulation HDLC, loopback not set
Keepalive set (10 sec)
Last input never, output 00:00:01, output hang never
Last clearing of "show interface" counters 00:25:25
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue :0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
109 input errors, 109 CRC, 8 frame, 0 overrun, 0 ignored, 90 abort
161 packets output, 4395 bytes, 0 underruns
0 output errors, 0 collisions, 21 interface resets
0 output buffer failures, 0 output buffers swapped out
78 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up
This is what I get when I issue the last command on RouterB.
RouterB(config-if)#no shut
RouterB(config)#
*Mar 1 00:18:35.295: %LINK-3-UPDOWN: Interface Serial0, changed state to up
*Mar 1 00:18:36.299: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
Router(config)#
*Mar 1 00:19:02.723: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
**Notice the time
Thanks for any suggestions. And sorry for the long question but this was the only way to explain in detail.
What Iam trying to do is to connect two routers via serial ports. I followed instructions from cisco..
I did everything the way they said but the connection does not stay up. Right when I finish configuring the the second router and I issue a no shutdown command to s0, the 2 routers will communicate for like 30 seconds and then the connection goes down. Here are the configs for both routers.
RouterA#sho run
Current configuration : 499 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
!
ip subnet-zero
!
!
!
!
interface Ethernet0
no ip address
shutdown
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
ip address 172.16.0.1 255.255.0.0
clock rate 64000
no cdp enable
!
interface Serial1
no ip address
shutdown
!
ip classless
ip http server
!
!
line con 0
line aux 0
line vty 0 4
!
end
RouterA#sho in s0
Serial0 is up, line protocol is down
Hardware is HD64570
Internet address is 172.16.0.1/16
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, loopback not set
Keepalive set (10 sec)
Last input never, output 00:00:07, output hang never
Last clearing of "show interface" counters 00:32:02
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
14 input errors, 14 CRC, 0 frame, 0 overrun, 0 ignored, 13 abort
113 packets output, 2486 bytes, 0 underruns
0 output errors, 0 collisions, 64 interface resets
0 output buffer failures, 0 output buffers swapped out
61 carrier transitions
RouterB#sho run
Current configuration : 420 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
!
!
!
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
ip address 172.16.0.3 255.255.0.0
no fair-queue
no ip address
shutdown
!
interface Serial0
ip address 172.16.0.3 255.255.0.0
no fair-queue
no cdp enable
!
interface Serial1
no ip address
shutdown
!
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
!
end
RouterB#sho in s0
Router#sho in s0
Serial0 is up, line protocol is down
Hardware is HD64570
Internet address is 172.16.0.3/16
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 179/255, txload 1/255, rxload 1/255
Encapsulation HDLC, loopback not set
Keepalive set (10 sec)
Last input never, output 00:00:01, output hang never
Last clearing of "show interface" counters 00:25:25
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue :0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
109 input errors, 109 CRC, 8 frame, 0 overrun, 0 ignored, 90 abort
161 packets output, 4395 bytes, 0 underruns
0 output errors, 0 collisions, 21 interface resets
0 output buffer failures, 0 output buffers swapped out
78 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up
This is what I get when I issue the last command on RouterB.
RouterB(config-if)#no shut
RouterB(config)#
*Mar 1 00:18:35.295: %LINK-3-UPDOWN: Interface Serial0, changed state to up
*Mar 1 00:18:36.299: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
Router(config)#
*Mar 1 00:19:02.723: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
**Notice the time
Thanks for any suggestions. And sorry for the long question but this was the only way to explain in detail.