Hi,
I want to implement a LAN2LAN VPN between 2 sites (Main and Remote site), while being able to browse normally on the Web from the remote site (traffic directed to network 172.27.227.0 to be tunneled-out of the Remote ASA and the rest of the traffic to be routed to the Internet). Main site has an ASA5505 with public fixed IP address (Outside: PUBLIC_IP, Inside: 172.27.227.0), Remote site has another ASA5505 connected to an ADSL modem (ASA doing PPPoE, Outside: PPPOE_IP, Inside: 192.168.100.0).
* ASA in Remote site, without VPN tunnel, works perfectly well for providing Internet access. PPPOE authenticates correctly and all users connected to the internal network can connect to the Web.
* I configured the L2L Tunnel between the Remote and Main sites. Internet access was working fine, but I was not able to ping to the Main site internal IP addresses (172.27.227.0).
* Using "debug crypto isakmp 3" and "show crypto isakmp sa", I realized that the tunnel was not being established. After troubleshooting for some time I found a web page that mentioned that "Even if it is not necessary for the IP address to be translated, a translation must still occur." when an interface initiates a connection to a host on another interface ( so I tried adding the next line in the Remote site:
static (inside,outside) 192.168.100.82 192.168.100.82
where 192.168.100.82 is the computer connected to the Remote-Inside ASA that needs to connect to the 172.27.227.0 network in the Main-Inside. In the moment I added this line I saw the tunnel being established from the "debug crypto isakmp 3" output and I was able to ping a computer in the 172.27.227.0 network from the 192.168.100.82 computer. But, at the same time, I was not able to get to the Internet any more. I deleted the "static (inside,outside) 192.168.100.82 192.168.100.82" line, and I lost the ping to the 172.27.227.0 network, but I recovered my web browsing.
My question is: how can I configure my Remote ASA for being able to have connectivity to the Main-Inside 172.27.227.0 network while at the same time be able to connect to the Internet from computers in the Remote-Inside 192.168.100.0 network?
(I'm not an expert configuring ASA 5505 equipment, so detailed answers are appreciated).
Here is the Remote-ASA Configuration:
interface Vlan1
nameif inside
security-level 100
ip address 192.168.100.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
pppoe client vpdn group Prodigy
ip address pppoe setroute
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list Flores_splitTunnelAcl standard permit any
access-list Split-tunnel-list remark Tunnel only traffic going to Flores Network
access-list Split-tunnel-list standard permit 192.168.100.0 255.255.255.0
access-list INBOUND extended permit icmp any any
access-list INBOUND extended permit tcp any any eq echo
access-list INBOUND extended permit udp any any
access-list outside_1_cryptomap_1 extended permit ip 192.168.100.0 255.255.255.0 172.27.227.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool Pool1 192.168.100.70-192.168.100.79 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 192.168.100.82 192.168.100.82 netmask 255.255.255.255
access-group INBOUND in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map0 1 match address outside_1_cryptomap_1
crypto map outside_map0 1 set pfs
crypto map outside_map0 1 set peer PUBLIC_IP
crypto map outside_map0 1 set transform-set ESP-3DES-SHA
crypto map outside_map0 1 set reverse-route
crypto map outside_map0 interface outside
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp policy 5
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 10
authentication pre-share
encryption des
hash md5
group 2
lifetime 86400
crypto isakmp policy 20
authentication pre-share
encryption 3des
hash md5
group 1
lifetime 86400
crypto isakmp nat-traversal 20
crypto isakmp ipsec-over-tcp port 10000
console timeout 0
vpdn group x request dialout pppoe
vpdn group x localname USER
vpdn group x ppp authentication pap
vpdn username USER password * store-local
dhcpd auto_config outside
!
dhcpd address 192.168.100.80-192.168.100.99 inside
dhcpd enable inside
!
group-policy Flores internal
group-policy Flores attributes
dns-server value 4.2.2.1 4.2.2.2
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value Split-tunnel-list
username admin password PW encrypted
tunnel-group Flores type ipsec-ra
tunnel-group Flores general-attributes
address-pool Pool1
default-group-policy Flores
tunnel-group Flores ipsec-attributes
pre-shared-key *
tunnel-group PUBLIC_IP type ipsec-l2l
tunnel-group PUBLIC_IP ipsec-attributes
pre-shared-key *
tunnel-group-map default-group DefaultL2LGroup
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Thanks!
I want to implement a LAN2LAN VPN between 2 sites (Main and Remote site), while being able to browse normally on the Web from the remote site (traffic directed to network 172.27.227.0 to be tunneled-out of the Remote ASA and the rest of the traffic to be routed to the Internet). Main site has an ASA5505 with public fixed IP address (Outside: PUBLIC_IP, Inside: 172.27.227.0), Remote site has another ASA5505 connected to an ADSL modem (ASA doing PPPoE, Outside: PPPOE_IP, Inside: 192.168.100.0).
* ASA in Remote site, without VPN tunnel, works perfectly well for providing Internet access. PPPOE authenticates correctly and all users connected to the internal network can connect to the Web.
* I configured the L2L Tunnel between the Remote and Main sites. Internet access was working fine, but I was not able to ping to the Main site internal IP addresses (172.27.227.0).
* Using "debug crypto isakmp 3" and "show crypto isakmp sa", I realized that the tunnel was not being established. After troubleshooting for some time I found a web page that mentioned that "Even if it is not necessary for the IP address to be translated, a translation must still occur." when an interface initiates a connection to a host on another interface ( so I tried adding the next line in the Remote site:
static (inside,outside) 192.168.100.82 192.168.100.82
where 192.168.100.82 is the computer connected to the Remote-Inside ASA that needs to connect to the 172.27.227.0 network in the Main-Inside. In the moment I added this line I saw the tunnel being established from the "debug crypto isakmp 3" output and I was able to ping a computer in the 172.27.227.0 network from the 192.168.100.82 computer. But, at the same time, I was not able to get to the Internet any more. I deleted the "static (inside,outside) 192.168.100.82 192.168.100.82" line, and I lost the ping to the 172.27.227.0 network, but I recovered my web browsing.
My question is: how can I configure my Remote ASA for being able to have connectivity to the Main-Inside 172.27.227.0 network while at the same time be able to connect to the Internet from computers in the Remote-Inside 192.168.100.0 network?
(I'm not an expert configuring ASA 5505 equipment, so detailed answers are appreciated).
Here is the Remote-ASA Configuration:
interface Vlan1
nameif inside
security-level 100
ip address 192.168.100.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
pppoe client vpdn group Prodigy
ip address pppoe setroute
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list Flores_splitTunnelAcl standard permit any
access-list Split-tunnel-list remark Tunnel only traffic going to Flores Network
access-list Split-tunnel-list standard permit 192.168.100.0 255.255.255.0
access-list INBOUND extended permit icmp any any
access-list INBOUND extended permit tcp any any eq echo
access-list INBOUND extended permit udp any any
access-list outside_1_cryptomap_1 extended permit ip 192.168.100.0 255.255.255.0 172.27.227.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool Pool1 192.168.100.70-192.168.100.79 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 192.168.100.82 192.168.100.82 netmask 255.255.255.255
access-group INBOUND in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map0 1 match address outside_1_cryptomap_1
crypto map outside_map0 1 set pfs
crypto map outside_map0 1 set peer PUBLIC_IP
crypto map outside_map0 1 set transform-set ESP-3DES-SHA
crypto map outside_map0 1 set reverse-route
crypto map outside_map0 interface outside
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp policy 5
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 10
authentication pre-share
encryption des
hash md5
group 2
lifetime 86400
crypto isakmp policy 20
authentication pre-share
encryption 3des
hash md5
group 1
lifetime 86400
crypto isakmp nat-traversal 20
crypto isakmp ipsec-over-tcp port 10000
console timeout 0
vpdn group x request dialout pppoe
vpdn group x localname USER
vpdn group x ppp authentication pap
vpdn username USER password * store-local
dhcpd auto_config outside
!
dhcpd address 192.168.100.80-192.168.100.99 inside
dhcpd enable inside
!
group-policy Flores internal
group-policy Flores attributes
dns-server value 4.2.2.1 4.2.2.2
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value Split-tunnel-list
username admin password PW encrypted
tunnel-group Flores type ipsec-ra
tunnel-group Flores general-attributes
address-pool Pool1
default-group-policy Flores
tunnel-group Flores ipsec-attributes
pre-shared-key *
tunnel-group PUBLIC_IP type ipsec-l2l
tunnel-group PUBLIC_IP ipsec-attributes
pre-shared-key *
tunnel-group-map default-group DefaultL2LGroup
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Thanks!