Hello Forum Members,
This is my first attempt at configuring an ASA device.
I have limited experience with the Pix 515E. I'm looking
for some experienced folks to look over my config and point
out anything that is incorrect. Any help would be greatly
appreciated. In particular, my ACLs and NAT entries.
WHAT I NEED
On my INSIDE interface my Exchange 2007 server will sit.
We only allow HTTPS access to it.
On my DMZ interface I have an FTP and Web Server. I need
to be able to allow site visitors to submit an email from
a page on the site.
I need a site-to-site VPN connection between two offices.
WHAT I'M EXPERIENCING
I have Internet connectivity from the inside.
I cannot connect via my site-to-site
I cannot get to my FTP or Web servers
MY CONFIGURATION
ASA Version 8.0(2)
!
hostname asa5510
domain-name my.domainname.com
enable password riBdCf1fnvp8w.If encrypted
names
name 76.191.xxx.xx PERIM-RTR
!
interface Ethernet0/0
speed 100
duplex full
nameif outside
security-level 0
ip address 76.191.xxx.xx 255.255.255.224
!
interface Ethernet0/1
speed 100
duplex full
nameif inside
security-level 100
ip address 192.168.60.1 255.255.255.0
!
interface Ethernet0/2
speed 100
duplex full
nameif dmz
security-level 50
ip address 192.168.61.1 255.255.255.0
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
ip address 192.168.1.1 255.255.255.0
management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
boot system disk0:/asa802-k8.bin
ftp mode passive
clock timezone PST -8
dns server-group DefaultDNS
domain-name my.domainname.com
access-list outside_access_dmz extended permit tcp any host 76.191.xxx.xx eq ftp
access-list outside_access_dmz extended permit tcp any host 76.191.xxx.xx eq 3389
access-list outside_access_dmz extended permit tcp any host 76.191.xxx.xx eq www
access-list outside_access_dmz extended permit tcp any host 76.191.xxx.xx eq smtp
access-list outside_access_dmz extended permit icmp any host 76.191.xxx.xx echo
access-list outside_access_dmz extended permit icmp any host 76.191.xxx.xx echo
access-list inside_nat0_outbound extended permit ip 192.168.60.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list inside_access_inside extended permit ip 192.168.60.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list inside_access_inside extended permit ip 192.168.60.0 255.255.255.0 192.168.20.0 255.255.255.0
access-list inside_access_inside extended permit ip 192.168.60.0 255.255.255.0 192.168.30.0 255.255.255.0
access-list inside_access_inside extended permit ip 192.168.60.0 255.255.255.0 192.168.40.0 255.255.255.0
access-list inside_access_inside extended permit ip 192.168.60.0 255.255.255.0 192.168.50.0 255.255.255.0
access-list outside_cryptomap_10 extended permit ip 192.168.60.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list outside_access_inside extended permit tcp any host 76.191.xxx.xx eq https
access-list outside_access_inside extended permit tcp any host 76.191.xxx.xx eq smtp
access-list outside_access_inside extended permit tcp any host 76.191.xxx.xx eq www
access-list outside_access_inside extended permit icmp any host 76.191.xxx.xx echo
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz 1500
mtu management 1500
ip verify reverse-path interface outside
ip verify reverse-path interface inside
ip verify reverse-path interface dmz
no failover
icmp unreachable rate-limit 1 burst-size 1
icmp permit any outside
icmp permit 192.168.10.0 255.255.255.0 inside
icmp permit 192.168.20.0 255.255.255.0 inside
icmp permit 192.168.30.0 255.255.255.0 inside
icmp permit 192.168.40.0 255.255.255.0 inside
icmp permit 192.168.50.0 255.255.255.0 inside
icmp permit 192.168.60.0 255.255.255.0 inside
no asdm history enable
arp timeout 14400
nat-control
global (outside) 10 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 10 0.0.0.0 0.0.0.0
static (dmz,outside) 76.191.xxx.xx 192.168.61.75 netmask 255.255.255.255
static (inside,dmz) 192.168.10.0 192.168.10.0 netmask 255.255.255.0
static (inside,dmz) 192.168.20.0 192.168.20.0 netmask 255.255.255.0
static (inside,dmz) 192.168.30.0 192.168.30.0 netmask 255.255.255.0
static (inside,dmz) 192.168.40.0 192.168.40.0 netmask 255.255.255.0
static (inside,dmz) 192.168.50.0 192.168.50.0 netmask 255.255.255.0
static (inside,dmz) 192.168.60.0 192.168.60.0 netmask 255.255.255.0
static (inside,outside) 76.191.xxx.xx 192.168.60.94 netmask 255.255.255.255
access-group inside_access_inside in interface outside
access-group outside_access_dmz in interface dmz
route outside 0.0.0.0 0.0.0.0 PERIM-RTR 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 management
http 192.168.10.0 255.255.255.0 inside
http 192.168.60.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto map outside_map 10 match address outside_cryptomap_10
crypto map outside_map 10 set peer 67.40.xxx.xxx
crypto map outside_map 10 set transform-set ESP-AES-256-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption aes-256
hash sha
group 5
lifetime 86400
no crypto isakmp nat-traversal
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 192.168.0.0 255.255.255.0 inside
ssh timeout 60
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
username ggoasa password LfNpagedAlpUdogd encrypted
tunnel-group 67.40.xxx.xxx type ipsec-l2l
tunnel-group 67.40.xxx.xxx ipsec-attributes
pre-shared-key *
prompt hostname context
Cryptochecksum:4dd6ee8a34ae35600a3543496aaac949
: end
This is my first attempt at configuring an ASA device.
I have limited experience with the Pix 515E. I'm looking
for some experienced folks to look over my config and point
out anything that is incorrect. Any help would be greatly
appreciated. In particular, my ACLs and NAT entries.
WHAT I NEED
On my INSIDE interface my Exchange 2007 server will sit.
We only allow HTTPS access to it.
On my DMZ interface I have an FTP and Web Server. I need
to be able to allow site visitors to submit an email from
a page on the site.
I need a site-to-site VPN connection between two offices.
WHAT I'M EXPERIENCING
I have Internet connectivity from the inside.
I cannot connect via my site-to-site
I cannot get to my FTP or Web servers
MY CONFIGURATION
ASA Version 8.0(2)
!
hostname asa5510
domain-name my.domainname.com
enable password riBdCf1fnvp8w.If encrypted
names
name 76.191.xxx.xx PERIM-RTR
!
interface Ethernet0/0
speed 100
duplex full
nameif outside
security-level 0
ip address 76.191.xxx.xx 255.255.255.224
!
interface Ethernet0/1
speed 100
duplex full
nameif inside
security-level 100
ip address 192.168.60.1 255.255.255.0
!
interface Ethernet0/2
speed 100
duplex full
nameif dmz
security-level 50
ip address 192.168.61.1 255.255.255.0
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
ip address 192.168.1.1 255.255.255.0
management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
boot system disk0:/asa802-k8.bin
ftp mode passive
clock timezone PST -8
dns server-group DefaultDNS
domain-name my.domainname.com
access-list outside_access_dmz extended permit tcp any host 76.191.xxx.xx eq ftp
access-list outside_access_dmz extended permit tcp any host 76.191.xxx.xx eq 3389
access-list outside_access_dmz extended permit tcp any host 76.191.xxx.xx eq www
access-list outside_access_dmz extended permit tcp any host 76.191.xxx.xx eq smtp
access-list outside_access_dmz extended permit icmp any host 76.191.xxx.xx echo
access-list outside_access_dmz extended permit icmp any host 76.191.xxx.xx echo
access-list inside_nat0_outbound extended permit ip 192.168.60.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list inside_access_inside extended permit ip 192.168.60.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list inside_access_inside extended permit ip 192.168.60.0 255.255.255.0 192.168.20.0 255.255.255.0
access-list inside_access_inside extended permit ip 192.168.60.0 255.255.255.0 192.168.30.0 255.255.255.0
access-list inside_access_inside extended permit ip 192.168.60.0 255.255.255.0 192.168.40.0 255.255.255.0
access-list inside_access_inside extended permit ip 192.168.60.0 255.255.255.0 192.168.50.0 255.255.255.0
access-list outside_cryptomap_10 extended permit ip 192.168.60.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list outside_access_inside extended permit tcp any host 76.191.xxx.xx eq https
access-list outside_access_inside extended permit tcp any host 76.191.xxx.xx eq smtp
access-list outside_access_inside extended permit tcp any host 76.191.xxx.xx eq www
access-list outside_access_inside extended permit icmp any host 76.191.xxx.xx echo
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz 1500
mtu management 1500
ip verify reverse-path interface outside
ip verify reverse-path interface inside
ip verify reverse-path interface dmz
no failover
icmp unreachable rate-limit 1 burst-size 1
icmp permit any outside
icmp permit 192.168.10.0 255.255.255.0 inside
icmp permit 192.168.20.0 255.255.255.0 inside
icmp permit 192.168.30.0 255.255.255.0 inside
icmp permit 192.168.40.0 255.255.255.0 inside
icmp permit 192.168.50.0 255.255.255.0 inside
icmp permit 192.168.60.0 255.255.255.0 inside
no asdm history enable
arp timeout 14400
nat-control
global (outside) 10 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 10 0.0.0.0 0.0.0.0
static (dmz,outside) 76.191.xxx.xx 192.168.61.75 netmask 255.255.255.255
static (inside,dmz) 192.168.10.0 192.168.10.0 netmask 255.255.255.0
static (inside,dmz) 192.168.20.0 192.168.20.0 netmask 255.255.255.0
static (inside,dmz) 192.168.30.0 192.168.30.0 netmask 255.255.255.0
static (inside,dmz) 192.168.40.0 192.168.40.0 netmask 255.255.255.0
static (inside,dmz) 192.168.50.0 192.168.50.0 netmask 255.255.255.0
static (inside,dmz) 192.168.60.0 192.168.60.0 netmask 255.255.255.0
static (inside,outside) 76.191.xxx.xx 192.168.60.94 netmask 255.255.255.255
access-group inside_access_inside in interface outside
access-group outside_access_dmz in interface dmz
route outside 0.0.0.0 0.0.0.0 PERIM-RTR 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 management
http 192.168.10.0 255.255.255.0 inside
http 192.168.60.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto map outside_map 10 match address outside_cryptomap_10
crypto map outside_map 10 set peer 67.40.xxx.xxx
crypto map outside_map 10 set transform-set ESP-AES-256-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption aes-256
hash sha
group 5
lifetime 86400
no crypto isakmp nat-traversal
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 192.168.0.0 255.255.255.0 inside
ssh timeout 60
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
username ggoasa password LfNpagedAlpUdogd encrypted
tunnel-group 67.40.xxx.xxx type ipsec-l2l
tunnel-group 67.40.xxx.xxx ipsec-attributes
pre-shared-key *
prompt hostname context
Cryptochecksum:4dd6ee8a34ae35600a3543496aaac949
: end