impromptu79
Technical User
Please help anyone. This is a configuration for my ASA 5510, and this is just for a lab exercise. I can't see why dmz10 cannot go to outside. Here I will paste configuration for ASA and for a SWITCH that I used. I used our local network in the company to be an outside, we use 172.16.xx.xx addresses. I am just a beginner so I am sorry if there are some trivial mistakes
ASA Version 7.2(2)
!
hostname asa
domain-name default.domain.invalid
enable password 8Ry2YjIyt7RRXU24 encrypted
no names
dns-guard
!
interface Ethernet0/0
nameif outside
security-level 0
ip address dhcp setroute
!
interface Ethernet0/1
nameif inside
security-level 100
ip address 192.168.100.1 255.255.255.0
!
interface Ethernet0/2
no nameif
no security-level
no ip address
!
interface Ethernet0/2.1
vlan 1
nameif dmz1
security-level 50
ip address 10.10.1.1 255.255.255.0
!
interface Ethernet0/2.10
vlan 10
nameif dmz10
security-level 50
ip address 10.10.10.1 255.255.255.0
!
interface Ethernet0/2.20
vlan 20
nameif dmz20
security-level 50
ip address 10.10.20.1 255.255.255.0
!
interface Ethernet0/2.99
vlan 99
nameif dmz99
security-level 50
ip address 10.10.99.1 255.0.0.0
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
ip address 192.168.1.1 255.255.255.0
management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group icmp-type echo
description object group to allow ICMP echo and echo-reply
icmp-object echo
icmp-object echo-reply
access-list dmz10toinside extended permit udp host 10.10.10.10 host 10.10.10.11 eq domain
access-list dmz10toinside extended permit tcp host 10.10.10.10 host 10.10.10.11 eq www
access-list outsidetodmz10 extended permit tcp any host 172.16.88.88 eq www
access-list outsidetodmz10 extended permit tcp any host 172.16.88.88 eq ftp
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz1 1500
mtu dmz10 1500
mtu dmz20 1500
mtu dmz99 1500
mtu management 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any outside
icmp permit any inside
icmp permit any dmz10
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 1 192.168.100.0 255.255.255.0
nat (dmz10) 1 10.10.10.0 255.255.255.0
static (inside,dmz10) 10.10.10.11 192.168.100.2 netmask 255.255.255.255
static (dmz10,outside) 172.16.88.88 10.10.10.10 netmask 255.255.255.255
access-group outsidetodmz10 in interface outside
access-group dmz10toinside in interface dmz10
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
username cisco password ffIRPGpDSOJh9YLq encrypted
http server enable
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect icmp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:b5c4439a7d72986b63e096a8e0a5c25a
: end
SWITCH:
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
ip subnet-zero
!
no ip domain-lookup
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/1
shutdown
!
interface GigabitEthernet0/2
shutdown
!
interface GigabitEthernet0/3
shutdown
!
interface GigabitEthernet0/4
shutdown
!
interface GigabitEthernet0/5
shutdown
!
interface GigabitEthernet0/6
shutdown
!
interface GigabitEthernet0/7
shutdown
!
interface GigabitEthernet0/8
shutdown
!
interface GigabitEthernet0/9
shutdown
!
interface GigabitEthernet0/10
shutdown
!
interface GigabitEthernet0/11
shutdown
!
interface GigabitEthernet0/12
shutdown
!
interface GigabitEthernet0/13
shutdown
!
interface GigabitEthernet0/14
shutdown
!
interface GigabitEthernet0/15
shutdown
!
interface GigabitEthernet0/16
shutdown
!
interface GigabitEthernet0/17
shutdown
!
interface GigabitEthernet0/18
shutdown
!
interface GigabitEthernet0/19
shutdown
!
interface GigabitEthernet0/20
shutdown
!
interface GigabitEthernet0/21
shutdown
!
interface GigabitEthernet0/22
switchport trunk native vlan 99
switchport mode trunk
!
interface GigabitEthernet0/23
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet0/24
switchport access vlan 20
switchport mode access
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan99
ip address 10.10.99.11 255.255.255.0
no ip route-cache
!
ip default-gateway 10.10.99.1
ip http server
!
control-plane
!
!
line con 0
line vty 0 4
no login
line vty 5 15
no login
!
end
ASA Version 7.2(2)
!
hostname asa
domain-name default.domain.invalid
enable password 8Ry2YjIyt7RRXU24 encrypted
no names
dns-guard
!
interface Ethernet0/0
nameif outside
security-level 0
ip address dhcp setroute
!
interface Ethernet0/1
nameif inside
security-level 100
ip address 192.168.100.1 255.255.255.0
!
interface Ethernet0/2
no nameif
no security-level
no ip address
!
interface Ethernet0/2.1
vlan 1
nameif dmz1
security-level 50
ip address 10.10.1.1 255.255.255.0
!
interface Ethernet0/2.10
vlan 10
nameif dmz10
security-level 50
ip address 10.10.10.1 255.255.255.0
!
interface Ethernet0/2.20
vlan 20
nameif dmz20
security-level 50
ip address 10.10.20.1 255.255.255.0
!
interface Ethernet0/2.99
vlan 99
nameif dmz99
security-level 50
ip address 10.10.99.1 255.0.0.0
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
ip address 192.168.1.1 255.255.255.0
management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group icmp-type echo
description object group to allow ICMP echo and echo-reply
icmp-object echo
icmp-object echo-reply
access-list dmz10toinside extended permit udp host 10.10.10.10 host 10.10.10.11 eq domain
access-list dmz10toinside extended permit tcp host 10.10.10.10 host 10.10.10.11 eq www
access-list outsidetodmz10 extended permit tcp any host 172.16.88.88 eq www
access-list outsidetodmz10 extended permit tcp any host 172.16.88.88 eq ftp
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz1 1500
mtu dmz10 1500
mtu dmz20 1500
mtu dmz99 1500
mtu management 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any outside
icmp permit any inside
icmp permit any dmz10
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 1 192.168.100.0 255.255.255.0
nat (dmz10) 1 10.10.10.0 255.255.255.0
static (inside,dmz10) 10.10.10.11 192.168.100.2 netmask 255.255.255.255
static (dmz10,outside) 172.16.88.88 10.10.10.10 netmask 255.255.255.255
access-group outsidetodmz10 in interface outside
access-group dmz10toinside in interface dmz10
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
username cisco password ffIRPGpDSOJh9YLq encrypted
http server enable
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect icmp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:b5c4439a7d72986b63e096a8e0a5c25a
: end
SWITCH:
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
ip subnet-zero
!
no ip domain-lookup
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/1
shutdown
!
interface GigabitEthernet0/2
shutdown
!
interface GigabitEthernet0/3
shutdown
!
interface GigabitEthernet0/4
shutdown
!
interface GigabitEthernet0/5
shutdown
!
interface GigabitEthernet0/6
shutdown
!
interface GigabitEthernet0/7
shutdown
!
interface GigabitEthernet0/8
shutdown
!
interface GigabitEthernet0/9
shutdown
!
interface GigabitEthernet0/10
shutdown
!
interface GigabitEthernet0/11
shutdown
!
interface GigabitEthernet0/12
shutdown
!
interface GigabitEthernet0/13
shutdown
!
interface GigabitEthernet0/14
shutdown
!
interface GigabitEthernet0/15
shutdown
!
interface GigabitEthernet0/16
shutdown
!
interface GigabitEthernet0/17
shutdown
!
interface GigabitEthernet0/18
shutdown
!
interface GigabitEthernet0/19
shutdown
!
interface GigabitEthernet0/20
shutdown
!
interface GigabitEthernet0/21
shutdown
!
interface GigabitEthernet0/22
switchport trunk native vlan 99
switchport mode trunk
!
interface GigabitEthernet0/23
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet0/24
switchport access vlan 20
switchport mode access
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan99
ip address 10.10.99.11 255.255.255.0
no ip route-cache
!
ip default-gateway 10.10.99.1
ip http server
!
control-plane
!
!
line con 0
line vty 0 4
no login
line vty 5 15
no login
!
end