Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations SkipVought on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Alternate ways of load balancing?

Status
Not open for further replies.

Dakiraun

IS-IT--Management
Sep 28, 2000
21
0
0
CA
We have 2 routers set up at the CBOE in Chicago. Each router is a Cisco 2621, and has a T1 line running into it. Currently, only one is in use. The original intent was to set up HSRP, but now the request has changed to load balancing. Normally, I would use EIGRP, but that is only to be used on our core routers, of which, the 2 at the CBOE are not. Does anyone know any alternate ways of implementing load balancing?
 
I just finished a real world load balancing test for my company.
We have 2 Internet connections {using the same ISP -mistake}, anyway, Both connections are located in physically different locations ~ 10 miles apart but utilize the ATM backbone. I used RIP routing for the test.

Background:
Pc are assigned IP addresses via DHCP.
Pc's default gateway is x.x.x.5 -OR- x.x.x.6 again assigned via DHCP
Even numbered IP addresses use x.x.x.6 and Odd numbered Ip addresses use x.x.x.5. So, half of the PC's will use router "A" .5 to reach the Internet and the other half will use router "B" .6.

--Back to the router
Both "A" .5 & "B" .6 know about each other via RIP
By changing the Default Administrative Distance {I.E. Rip is 120}, on router "A" to 119 for the "Gateway of last resort" and leaving the route to router "B" as 120. Then do the reverse on Router "B". This will give you load balancing {NOT TRUE, but close}. This also provides redundancy!!

Option B
Look at a Load Balancer
We researched RADWARE's Fireproof - Might be a better solution than messing with the router Admin distance if you are not familure with IOS. However, the load balancer IOS presents a Virtual interface different than Cisco's implementation.
One interface supports layer 3 routing, the other supports layer 2 mac addresses.
Good Luck!
 
If you have point-to-point T1's then ppp multilink would work out great for you. The only thing I would be careful here is your ver of software. Make sure you have he latest ver because there are known bugs using ppp multilink.
(Use 12.1) here are some sample configs. Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Fiesta-1
!
memory-size iomem 10
clock timezone pst -8
clock summer-time pdt recurring
ip subnet-zero


!
interface Multilink1
ip address 192.168.1.26 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
compress stac caim 0
no cdp enable
ppp multilink
no ppp multilink fragmentation
multilink-group 1
!
interface FastEthernet0/0
ip address 10.30.1.2 255.255.0.0
ip helper-address 172.16.3.1
no ip directed-broadcast
speed 100
full-duplex
!
interface Serial0/0
bandwidth 1544
no ip address
no ip directed-broadcast
encapsulation ppp
no ip mroute-cache
no fair-queue
compress stac caim 0
ppp multilink
multilink-group 1
!
interface Serial0/1
bandwidth 1544
no ip address
no ip directed-broadcast
encapsulation ppp
no ip mroute-cache
no fair-queue
compress stac caim 0
ppp multilink
multilink-group 1
!
ip default-gateway 192.168.1.25
ip classless
ip route 10.30.0.0 255.255.0.0 Multilink1
ip route 172.16.0.0 255.255.0.0 192.168.1.25
ip route 192.168.133.0 255.255.255.0 192.168.1.25
ip route 192.168.172.0 255.255.255.0 192.168.1.25
ip route 192.168.172.236 255.255.255.255 192.168.1.25
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end


Barleys-2#sh run
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Fiesta-2
!
enable secret
enable password
!
memory-size iomem 20
clock timezone pst -8
clock summer-time pdt recurring
ip subnet-zero
!
interface Multilink1
ip address 192.168.1.25 255.255.255.252
compress stac caim 0
no cdp enable
ppp multilink
no ppp multilink fragmentation
multilink-group 1
!
interface FastEthernet0/0
ip address 172.16.11.43 255.255.0.0
speed 100
full-duplex
!
interface Serial0/0
no ip address
encapsulation ppp
no ip mroute-cache
no fair-queue
compress stac caim 0
service-module t1 clock source internal
ppp multilink
multilink-group 1
!
interface Serial0/1
bandwidth 1544
no ip address
encapsulation ppp
no ip mroute-cache
no fair-queue
compress stac caim 0
service-module t1 clock source internal
ppp multilink
multilink-group 1
!
ip default-gateway 172.16.1.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.1.1
ip route 192.168.133.0 255.255.255.0 172.16.1.1
ip route 192.168.172.0 255.255.255.0 172.16.1.1
no ip http server
!
!
line con 0
exec-timeout 30 0
password 7
login
transport input none
line aux 0
exec-timeout 30 0
password 7
login
modem InOut
modem autoconfigure discovery
speed 115200
line vty 0 4
exec-timeout 30 0
password 7
login
!
end

I hope this helps !!! #-)






Jeter@LasVegas.com The best answer I could ever give is the one to maintain my Sanity
 
Does PPP Multilink provide LOAD BALANCING? Or does it provide additional bandwidth once the original link has reached it's bandwidth threshold?

Frank
 
All very good suggestions, but not quite related to what I needed (I'll keep that Multilink one in mind for something else though!). What we have is 2 2621's at the CBOE location, 2 T1's (1 each) at that end, and they all connect to one 3660 at the Chicago office. The most workable solution so far might be to use EIGRP and limit it in such a way that it only talks to the Chicago router, and not the whole family. Still, I would rather use something else if possible.
 
I found this nice explantion of load balancing. I also think multiple static routes will give you what you want but I need to draw it out since normally all the static routes are on the same router, not two different ones. Multi static routes act as a "round robin" on the outbound traffic.

Load Balancing

AppleTalk and IPX routers can remember only one route to a remote network. By default, they do not support load balancing. You can change this for IPX by using the ipx maximum-paths command on a Cisco router.

Most IP routing protocols can load balance across six parallel links that have equal cost. To support load balancing, keep bandwidth consistent within a layer of the hierarchical model so that all paths have the same cost. (Cisco's IGRP and Enhanced IGRP are exceptions because they can load balance traffic across multiple routes that have different metrics, using a feature called "variance.")

A hop-based routing protocol does load balancing over unequal bandwidth paths as long as the hop count is equal. Once the slower link becomes saturated, the higher-capacity link cannot be filled which is called pinhole congestion. Pinhole congestion can be avoided by designing equal bandwidth links within one layer of the hierarchy or by using a routing protocol that takes bandwidth into account.

IP load balancing depends on which switching mode is used on a router. Process switching load balances packet by packet. Fast, autonomous, silicon, optimum, distributed, and NetFlow switching load balance destination by destination, because the processor caches the encapsulation to a specific destination for these types of switching modes. Switching modes are discussed in more detail in "Provision Hardware and Media for the WAN."

from:
Mike S


"Diplomacy; the art of saying 'nice doggie' till you can find a rock" Wynn Catlin
 
ppp multilink does provide load balancing . Its works great, pull 1 span off and the other span will take the full load. When it comes back on line then it will resume normal operations. There are several ways of load balancing
choose one and run with it. Good luck !!! Jeter@LasVegas.com The best answer I could ever give is the one to maintain my Sanity
 
If you are using equal links and do not want to use EIGRP then why not use OSPF with packet switching?

good luck
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top