Hi,
I am trying to allow outside access to a server that is on the inside protected net. I am adding the static and access-list commands to a working config. Each time I add the static command the pix stops working in either direction. No traffics comes in or goes out. The goal is to add access to an inside web server for users comming in via the outside(intrenet). I have attahce the commands I am adding below and a copy of the working config prior to adding the additional static command. Any help is much appreciated.
Thanks in advance.
Additional commands:
static(inside,outside) 'outside ip addr' 192.169.1.90
access-list web-acl permit tcp any host 'outside ip addr' eq www
access-group web-acl in interface outside
'outside ip addr' is assigned to the outside interface via my pppoe connection. Yes, I adjust the command everytime I get a new address.
Working config prior to adding the above commands:
PIX Version 6.2(2)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password encrypted
passwd encrypted
hostname pixfirewall
domain-name mdlmail.com
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
names
access-list acl_out permit ip any any
access-list inside_access_in permit ip any any
access-list inside_outbound_nat0_acl permit ip any 192.169.2.0 255.255.255.224
pager lines 24
logging on
logging console debugging
logging history debugging
interface ethernet0 auto
interface ethernet1 auto
icmp permit any echo-reply inside
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 192.169.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpniprange 192.169.2.10-192.169.2.20
pdm location 12.146.0.0 255.255.255.0 outside
pdm logging debugging 512
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group inside_access_in in interface inside
rip outside default version 1
rip inside default version 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 0.0.0.0 0.0.0.0 outside
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
no sysopt route dnat
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-DES-MD5
crypto map outside_map 20 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client configuration address initiate
crypto map outside_map client configuration address respond
crypto map outside_map interface outside
isakmp enable outside
isakmp identity address
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup mdladmin address-pool vpniprange
vpngroup mdladmin dns-server 151.203.0.84 151.203.0.85
vpngroup mdladmin idle-time 1800
vpngroup mdladmin password ****
telnet timeout 5
ssh x.x.x.x 255.255.255.0 outside
ssh timeout 15
vpdn group pppoe-verizon request dialout pppoe
vpdn group pppoe-verizon localname vze3s3nr
vpdn group pppoe-verizon ppp authentication pap
vpdn username vze3s3nr password ****
dhcpd address 192.169.1.10-192.169.1.50 inside
dhcpd dns 151.203.0.84 151.203.0.85
dhcpd lease 2073600
dhcpd ping_timeout 750
dhcpd enable inside
terminal width 80
Cryptochecksum:93669a96806dbc00992c4ffb37313ead
I am trying to allow outside access to a server that is on the inside protected net. I am adding the static and access-list commands to a working config. Each time I add the static command the pix stops working in either direction. No traffics comes in or goes out. The goal is to add access to an inside web server for users comming in via the outside(intrenet). I have attahce the commands I am adding below and a copy of the working config prior to adding the additional static command. Any help is much appreciated.
Thanks in advance.
Additional commands:
static(inside,outside) 'outside ip addr' 192.169.1.90
access-list web-acl permit tcp any host 'outside ip addr' eq www
access-group web-acl in interface outside
'outside ip addr' is assigned to the outside interface via my pppoe connection. Yes, I adjust the command everytime I get a new address.
Working config prior to adding the above commands:
PIX Version 6.2(2)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password encrypted
passwd encrypted
hostname pixfirewall
domain-name mdlmail.com
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
names
access-list acl_out permit ip any any
access-list inside_access_in permit ip any any
access-list inside_outbound_nat0_acl permit ip any 192.169.2.0 255.255.255.224
pager lines 24
logging on
logging console debugging
logging history debugging
interface ethernet0 auto
interface ethernet1 auto
icmp permit any echo-reply inside
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 192.169.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpniprange 192.169.2.10-192.169.2.20
pdm location 12.146.0.0 255.255.255.0 outside
pdm logging debugging 512
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group inside_access_in in interface inside
rip outside default version 1
rip inside default version 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 0.0.0.0 0.0.0.0 outside
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
no sysopt route dnat
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-DES-MD5
crypto map outside_map 20 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client configuration address initiate
crypto map outside_map client configuration address respond
crypto map outside_map interface outside
isakmp enable outside
isakmp identity address
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup mdladmin address-pool vpniprange
vpngroup mdladmin dns-server 151.203.0.84 151.203.0.85
vpngroup mdladmin idle-time 1800
vpngroup mdladmin password ****
telnet timeout 5
ssh x.x.x.x 255.255.255.0 outside
ssh timeout 15
vpdn group pppoe-verizon request dialout pppoe
vpdn group pppoe-verizon localname vze3s3nr
vpdn group pppoe-verizon ppp authentication pap
vpdn username vze3s3nr password ****
dhcpd address 192.169.1.10-192.169.1.50 inside
dhcpd dns 151.203.0.84 151.203.0.85
dhcpd lease 2073600
dhcpd ping_timeout 750
dhcpd enable inside
terminal width 80
Cryptochecksum:93669a96806dbc00992c4ffb37313ead