ACorpolongo
IS-IT--Management
Hi everyone,
I'm building a new internal network for my company and they bought me a new ASA 5500. I learned networking on IOS Routers and think this little box with its GUI is awesome I've been able to get everything configured except port redirection. By using the packet tracer built into the ASDM I've figured that even though I have an allow any any ACL on the outside port for incoming (out of desperation only) everytime I send a packet address to an individual port it gets blocked by the implicit deny any any. This is driving me crazy! When I create specific ACL rules for the IP that is getting port 3389 directed to it, the implicit deny any any catches the packet which seemingly gets ignored by my ACLs meant to allow it. Here I've posted my configuration, I could really use some help with getting my ACL and NAT settings figured out. Like I said, it's doing everything I want to except I can't figure out the ACL and port redirection. Thanks much!
Result of the command: "sh run"
: Saved
:
ASA Version 7.2(2)
!
hostname TSCUSAGateway
domain-name tscusa.com
enable password TPHIn.D8lbIFB50E encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 10.1.10.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address <Outside IP> <Outside S/N>
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup inside
dns server-group DefaultDNS
name-server 10.1.10.10
domain-name tscusa.com
same-security-traffic permit intra-interface
access-list inside_access_in extended permit ip any any
access-list outside_access_in extended permit udp any host 10.1.10.10 eq 3389
access-list outside_access_in extended permit tcp any host 10.1.10.10 eq 3389
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 1 10.1.10.0 255.255.255.0
static (inside,outside) udp <Outside IP> 3389 10.1.10.10 3389 netmask 255.255.255.255
static (inside,outside) tcp <Outside IP> 3389 10.1.10.10 3389 netmask 255.255.255.255
static (outside,inside) udp 10.1.10.10 3389 <Outside IP> 3389 netmask 255.255.255.255
static (outside,inside) tcp 10.1.10.10 3389 <Outside IP> 3389 netmask 255.255.255.255
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 68.250.1.49 255
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 10.1.10.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 68.250.1.54 255.255.255.255 outside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd dns 10.1.10.10 10.1.10.11
dhcpd wins 10.1.10.10 10.1.10.11
dhcpd lease 86900
dhcpd ping_timeout 100
dhcpd domain TSCUSA.COM
!
dhcpd address 10.1.10.100-10.1.10.200 inside
dhcpd dns 10.1.10.10 10.1.10.11 interface inside
dhcpd wins 10.1.10.10 10.1.10.11 interface inside
dhcpd lease 86400 interface inside
dhcpd ping_timeout 100 interface inside
dhcpd domain TSCUSA.COM interface inside
dhcpd enable inside
!
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:f6c331c56690f792cf86354b605a34f6
: end
I'm building a new internal network for my company and they bought me a new ASA 5500. I learned networking on IOS Routers and think this little box with its GUI is awesome I've been able to get everything configured except port redirection. By using the packet tracer built into the ASDM I've figured that even though I have an allow any any ACL on the outside port for incoming (out of desperation only) everytime I send a packet address to an individual port it gets blocked by the implicit deny any any. This is driving me crazy! When I create specific ACL rules for the IP that is getting port 3389 directed to it, the implicit deny any any catches the packet which seemingly gets ignored by my ACLs meant to allow it. Here I've posted my configuration, I could really use some help with getting my ACL and NAT settings figured out. Like I said, it's doing everything I want to except I can't figure out the ACL and port redirection. Thanks much!
Result of the command: "sh run"
: Saved
:
ASA Version 7.2(2)
!
hostname TSCUSAGateway
domain-name tscusa.com
enable password TPHIn.D8lbIFB50E encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 10.1.10.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address <Outside IP> <Outside S/N>
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup inside
dns server-group DefaultDNS
name-server 10.1.10.10
domain-name tscusa.com
same-security-traffic permit intra-interface
access-list inside_access_in extended permit ip any any
access-list outside_access_in extended permit udp any host 10.1.10.10 eq 3389
access-list outside_access_in extended permit tcp any host 10.1.10.10 eq 3389
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 1 10.1.10.0 255.255.255.0
static (inside,outside) udp <Outside IP> 3389 10.1.10.10 3389 netmask 255.255.255.255
static (inside,outside) tcp <Outside IP> 3389 10.1.10.10 3389 netmask 255.255.255.255
static (outside,inside) udp 10.1.10.10 3389 <Outside IP> 3389 netmask 255.255.255.255
static (outside,inside) tcp 10.1.10.10 3389 <Outside IP> 3389 netmask 255.255.255.255
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 68.250.1.49 255
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 10.1.10.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 68.250.1.54 255.255.255.255 outside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd dns 10.1.10.10 10.1.10.11
dhcpd wins 10.1.10.10 10.1.10.11
dhcpd lease 86900
dhcpd ping_timeout 100
dhcpd domain TSCUSA.COM
!
dhcpd address 10.1.10.100-10.1.10.200 inside
dhcpd dns 10.1.10.10 10.1.10.11 interface inside
dhcpd wins 10.1.10.10 10.1.10.11 interface inside
dhcpd lease 86400 interface inside
dhcpd ping_timeout 100 interface inside
dhcpd domain TSCUSA.COM interface inside
dhcpd enable inside
!
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:f6c331c56690f792cf86354b605a34f6
: end