Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations SkipVought on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

827 ADSL Router WAN Interface Configuration 1

Status
Not open for further replies.

IllegalOperation

Technical User
Jan 27, 2003
206
0
0
US
Hello once again everyone. I have a real simple question that Cisco notoriously makes you rip your hair out trying to find on their web site.

All I want to do, with my 827, is set up the WAN interface (ADSL) so it can successfully communicate with my provider. Unfortunately, Cisco forces you to overthink this simple solution on their support site.

I have the VPI/VCI information.
I have the IP Address information (we have been assigned a /29 block).
I have the authentication information (username/password, and I think CHAP is involved?).

This 827 is going to act stricly as a router (no bridging), as office equipment will be directly behind it. Very simple stuff. Now why does Cisco make it so difficult?

No I dont want to "configure the Cisco 827 for RFC1483 Bridging with Integrated Routing and Bridging (IRB)". No I dont want to "configure the Cisco 827, acting as a DHCP server, for Easy IP (Phase 2)". I just want to find out what ATM0 interface parameters are needed to get a successful connection. Hardly rocket science.

Well, here is the config I came up with - but I know it is not completely right...

interface ATM0
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
bundle-enable

interface ATM0.1 point-to-point
ip address x.x.x.x 255.255.255.248
pvc 1/34
encapsulation aal5snap

ip route 0.0.0.0 0.0.0.0 x.x.x.x

Note: x.x.x.x is the assigned IP address for the router.


Does anyone have either their own config or a default config that I can take a look at to see what else is needed? Im sure theres a few 827 users that are happily using their DSL circuit right about now....
 
interface ATM0
no ip address
no ip mroute-cache
no atm ilmi-keepalive
pvc 1/50
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
no fair-queue
hold-queue 244 in
!
interface FastEthernet0
ip address 10.0.0.1 255.0.0.0
ip nat inside
speed auto
full-duplex
!
interface Dialer0
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp chap hostname router
ppp chap password xxxxxxxxxxxx
!
ip nat inside source list 7 interface Dialer0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0



**********************
Chris Andrew, CCNA, CCSA
chris@iproute.co.uk
**********************
 
Appreciated iproute. Actually, I came up with this. The connection is successfull, however, I can not get past this 827 router from a computer behind it on the 192.168.0.x subnet. It looks like some kind of routing problem, as I can get to the WAN interface of the router - but not past it. Any suggestions?

(I disabled the access to see if that was the problem, but it isnt)


Current configuration : 1335 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Odyssey1
!
logging rate-limit console 10 except errors
enable secret 5 $1$qdqL$elBX5ke384..mCDN9smwj/
enable password *******
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
!
no ip dhcp-client network-discovery
vpdn enable
!
vpdn-group pppoe
request-dialin
protocol pppoe
!
!
!
!
interface Ethernet0
ip address 192.168.0.251 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
no ip mroute-cache
!
interface ATM0
no ip address
no ip mroute-cache
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
!
interface ATM0.1 point-to-point
no ip mroute-cache
pvc 0/35
pppoe-client dial-pool-number 1
!
!
interface Dialer1
mtu 1492
ip address x.x.x.x 255.255.255.248
ip nat outside
encapsulation ppp
dialer pool 1
ppp pap sent-username ******** password 7 00001A010D4F0A0A
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
!
ip nat inside source list 1 interface Dialer1 overload
access-list 1 permit 192.168.0.0 0.0.0.255
!
line con 0
stopbits 1
line vty 0 4
password *****
login
!
scheduler max-task-time 5000
end
 
Any interesting traffic defined?

....
dailer-group 3
...
dialer-list 3 protocol ip permit


Simon Yu
CCNP
 
Hi illegalop, call it a hunch , but it sounds like you have a default gateway problem here. So, from the inside, you can ping the ip address of Dialer1 (x.x.x.x /29), but can not get past it? If this is the case, try changing your default route from "ip route 0.0.0.0 0.0.0.0 Dialer1" to "ip route 0.0.0.0 0.0.0.0 x.x.x.x"

NOTE: x.x.x.x in this case being the IP on the /29 block on your provider's side.

*** FOR EXAMPLE, if let's just say your dialer1 interface was set up with this IP :

interface Dialer1
mtu 1492
ip address 10.10.125.2 255.255.255.248
ip nat outside
encapsulation ppp
dialer pool 1
ppp pap sent-username ******** password 7 00001A010D4F0A0A


** You would want to change your default gateway to the following:

ip route 0.0.0.0 0.0.0.0 10.10.125.1

***Just a little trick I know, as I have worked at mutliple ISP's and they usually assign the first usable IP in any given subnet to their side***



I'm the Fanciest of the Fancy...INDEED
 
Thanks guys. You were right FancyPete, Ive noticed that I have had to do that every time with the ISP I have. I went ahead and changed the default route (my IP was a .134 - and my ISP's was .1), and I also forgot to enable IRB on the router...which is needed.

Works like a charm now. Thanks...
 
Hi!
I have probably the same problem as yours.
Can you send me a sample config.
I set everything without enabling IRB and the router works for 2 hours , then stops.
How did you enable IRB on Dialer interface?

Didocus
 
Sure Didocus. This is what my current config looks like, with the exception of access lists and other personalized features...

(I simply used the "bridge irb" command)

Current configuration : 2655 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ******
!
logging rate-limit console 10 except errors
enable secret 5 *******
enable password *******
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip name-server *.*.*.*
ip name-server *.*.*.*
!
no ip dhcp-client network-discovery
vpdn enable
!
vpdn-group pppoe
request-dialin
protocol pppoe
!
bridge irb
!
interface Ethernet0
ip address *.*.*.* 255.255.255.0
no ip redirects
ip nat inside
ip tcp adjust-mss 1452
no ip mroute-cache
no cdp enable
!
interface ATM0
no ip address
no ip redirects
no ip mroute-cache
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
bridge-group 1
bridge-group 1 spanning-disabled
!
interface ATM0.1 point-to-point
no ip mroute-cache
pvc 0/35
pppoe-client dial-pool-number 1
!
!
interface Dialer1
mtu 1492
ip address *.*.*.* 255.255.255.248
ip access-group odyssey in
ip nat outside
encapsulation ppp
dialer pool 1
no cdp enable
ppp pap sent-username *******
password 7 *******
!
ip classless
ip route 0.0.0.0 0.0.0.0 *.*.*.*
ip http server
!
ip nat inside source list 1 interface Dialer1 overload
access-list 1 permit 192.168.*.* 0.0.0.255
no cdp run
!
line con 0
stopbits 1
line vty 0 4
password *******
login
!
scheduler max-task-time 5000
end
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top