I've got a Cisco 804 connecting via ISDN and it seems that after about 2.5hrs, the idle-timeout period, it disconnects and it will not reconnect unless you issue a manual isdn call.
Anyone have any ideas on what I should check? Below is my config, any advice would be greatly appreciated!
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname SD-804-01
!
enable secret 5 xyz
enable password 7 xyz
!
!
pots country US
ip subnet-zero
!
no ip domain-lookup
isdn switch-type basic-ni
!
!
!
interface Ethernet0
description connected to EthernetLAN
ip address x.x.x.x 255.255.255.240
no ip directed-broadcast
!
interface BRI0
description connected to Internet
no ip address
no ip directed-broadcast
encapsulation ppp
dialer rotary-group 1
isdn switch-type basic-ni
isdn spid1 11122233330101
isdn spid2 11122233340101
no cdp enable
!
interface Dialer1
description connected to Internet
ip unnumbered Ethernet0
no ip directed-broadcast
encapsulation ppp
no ip split-horizon
dialer in-band
dialer idle-timeout 10000
dialer string 5407258319
dialer hold-queue 5
dialer load-threshold 1 either
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname username
ppp chap password 7 xyz
ppp pap sent-username username password 7 xyz
ppp multilink
!
router rip
version 2
passive-interface Dialer1
network 10.0.0.0
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
line con 0
exec-timeout 0 0
password 7 xyz
login
transport input none
stopbits 1
line vty 0 4
password 7 xyz
login
!
end
Anyone have any ideas on what I should check? Below is my config, any advice would be greatly appreciated!
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname SD-804-01
!
enable secret 5 xyz
enable password 7 xyz
!
!
pots country US
ip subnet-zero
!
no ip domain-lookup
isdn switch-type basic-ni
!
!
!
interface Ethernet0
description connected to EthernetLAN
ip address x.x.x.x 255.255.255.240
no ip directed-broadcast
!
interface BRI0
description connected to Internet
no ip address
no ip directed-broadcast
encapsulation ppp
dialer rotary-group 1
isdn switch-type basic-ni
isdn spid1 11122233330101
isdn spid2 11122233340101
no cdp enable
!
interface Dialer1
description connected to Internet
ip unnumbered Ethernet0
no ip directed-broadcast
encapsulation ppp
no ip split-horizon
dialer in-band
dialer idle-timeout 10000
dialer string 5407258319
dialer hold-queue 5
dialer load-threshold 1 either
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname username
ppp chap password 7 xyz
ppp pap sent-username username password 7 xyz
ppp multilink
!
router rip
version 2
passive-interface Dialer1
network 10.0.0.0
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
line con 0
exec-timeout 0 0
password 7 xyz
login
transport input none
stopbits 1
line vty 0 4
password 7 xyz
login
!
end