Hi,
We have an external software vendor who wants to support their software, without coming onsite each time there's a problem with it. I've been asked to grant them access into our network. It's a 506e PIX. I'm trying to do this with the following commands at the PIX....
(note, I've substituted IP addresses for fake ones! )
access-list acl-out permit gre host 209.165.201.25 host 209.165.201.5
access-list acl-out permit tcp host 209.165.201.25 host 209.165.201.5 eq 1723
static (inside,outside) 209.165.201.5 10.48.66.106 netmask 255.255.255.255 0 0
access-group acl-out in interface outside
the external PPTP client is at 209.165.201.25 <Their Public IP Address
the public address of our Windows Server is 209.165.201.5
the internal address of our Windows Server is 10.48.66.106
============================================================
My problem is this. When I enter this line at the PIX...
access-group acl-out in interface outside
The following line gets removed from the PIX, hence knocking out all of our incoming e-mail ( SMTP traffic )...
access-group mail in interface outside
============================================================
My PIX configuration is as follows....
Result of firewall command: "sho runn"
: Saved
:
PIX Version 6.3(4)
interface ethernet0 10full
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxx encrypted
passwd xxxx encrypted
hostname PIXFIREWALL
domain-name domain.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list mail permit tcp any host xx.yy.zzz.10 eq https
access-list mail permit tcp mmm.nnn.ppp.0 255.255.255.0 host xx.yy.zzz.10 eq smtp
access-list mail permit tcp qqq.rr.sss.0 255.255.255.0 host xx.yy.zzz.10 eq smtp
access-list 101 permit ip aaa.bbb.cc.0 255.255.255.0 ggg.h.i.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside jj.kk.lll.9 255.255.255.255 pppoe setroute
ip address inside aaa.bbb.cc.97 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location aaa.bbb.cc.8 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) xx.yy.zzz.10 aaa.bbb.cc.91 netmask 255.255.255.255 0 0
static (inside,outside) xx.yy.zzz.11 aaa.bbb.cc.92 netmask 255.255.255.255 0 0
access-group mail in interface outside
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http aaa.bbb.cc.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set viper esp-des esp-md5-hmac
crypto map corvette 1 ipsec-isakmp
crypto map corvette 1 match address 101
crypto map corvette 1 set peer dd.ee.ff.124
crypto map corvette 1 set transform-set viper
crypto map corvette interface outside
isakmp enable outside
isakmp key ******** address dd.ee.ff.124 netmask 255.255.255.255
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash md5
isakmp policy 1 group 1
isakmp policy 1 lifetime 1000
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname eircom
vpdn group pppoe_group ppp authentication chap
vpdn username eircom password *********
terminal width 80
Cryptochecksum:e25aa77285b2cd72c55d04748bf3325a
: end
============================================================
How do I work around this? Thanks a million in advance for anyone who may be kind enough to help!
Dublin73
We have an external software vendor who wants to support their software, without coming onsite each time there's a problem with it. I've been asked to grant them access into our network. It's a 506e PIX. I'm trying to do this with the following commands at the PIX....
(note, I've substituted IP addresses for fake ones! )
access-list acl-out permit gre host 209.165.201.25 host 209.165.201.5
access-list acl-out permit tcp host 209.165.201.25 host 209.165.201.5 eq 1723
static (inside,outside) 209.165.201.5 10.48.66.106 netmask 255.255.255.255 0 0
access-group acl-out in interface outside
the external PPTP client is at 209.165.201.25 <Their Public IP Address
the public address of our Windows Server is 209.165.201.5
the internal address of our Windows Server is 10.48.66.106
============================================================
My problem is this. When I enter this line at the PIX...
access-group acl-out in interface outside
The following line gets removed from the PIX, hence knocking out all of our incoming e-mail ( SMTP traffic )...
access-group mail in interface outside
============================================================
My PIX configuration is as follows....
Result of firewall command: "sho runn"
: Saved
:
PIX Version 6.3(4)
interface ethernet0 10full
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxx encrypted
passwd xxxx encrypted
hostname PIXFIREWALL
domain-name domain.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list mail permit tcp any host xx.yy.zzz.10 eq https
access-list mail permit tcp mmm.nnn.ppp.0 255.255.255.0 host xx.yy.zzz.10 eq smtp
access-list mail permit tcp qqq.rr.sss.0 255.255.255.0 host xx.yy.zzz.10 eq smtp
access-list 101 permit ip aaa.bbb.cc.0 255.255.255.0 ggg.h.i.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside jj.kk.lll.9 255.255.255.255 pppoe setroute
ip address inside aaa.bbb.cc.97 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location aaa.bbb.cc.8 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) xx.yy.zzz.10 aaa.bbb.cc.91 netmask 255.255.255.255 0 0
static (inside,outside) xx.yy.zzz.11 aaa.bbb.cc.92 netmask 255.255.255.255 0 0
access-group mail in interface outside
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http aaa.bbb.cc.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set viper esp-des esp-md5-hmac
crypto map corvette 1 ipsec-isakmp
crypto map corvette 1 match address 101
crypto map corvette 1 set peer dd.ee.ff.124
crypto map corvette 1 set transform-set viper
crypto map corvette interface outside
isakmp enable outside
isakmp key ******** address dd.ee.ff.124 netmask 255.255.255.255
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash md5
isakmp policy 1 group 1
isakmp policy 1 lifetime 1000
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname eircom
vpdn group pppoe_group ppp authentication chap
vpdn username eircom password *********
terminal width 80
Cryptochecksum:e25aa77285b2cd72c55d04748bf3325a
: end
============================================================
How do I work around this? Thanks a million in advance for anyone who may be kind enough to help!
Dublin73