Has anyone connected to swbell dsl w/ a 2xxx or 36xx router? I have internal Net on e0/0 and external to dsl modem on e2/0. Below is my sanitized config.
-- Snip --
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname K2
!
boot system flash
logging buffered 4096 debugging
enable secret 5 ******************
!
username ****** password 0 ******
ip subnet-zero
!
!
no ip domain-lookup
ip domain-name none.net
!
ip audit notify log
ip audit po max-events 100
ip ssh source-interface Ethernet2/0
vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!
!
!
!
!
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
partition slot1: 2 8 8
!
!
!
!
!
interface Ethernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
half-duplex
!
interface Serial0/0
no ip address
shutdown
!
interface BRI0/0
no ip address
shutdown
!
interface TokenRing0/0
no ip address
shutdown
ring-speed 16
!
interface Serial1/0
no ip address
shutdown
!
interface Serial1/1
no ip address
shutdown
!
interface Serial1/2
no ip address
shutdown
!
interface Serial1/3
no ip address
shutdown
!
interface BRI2/0
no ip address
shutdown
!
interface Ethernet2/0
no ip address
half-duplex
pppoe enable
pppoe-client dial-pool-number 2
pppoe-client dial-pool-number 1
!
interface Serial2/0
no ip address
shutdown
!
interface Ethernet2/1
no ip address
half-duplex
pppoe enable
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap
ppp chap hostname *****************
ppp chap password 0 **************
!
router ospf 1
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0
!
ip nat inside source list 101 interface Dialer1 overload
no ip classless
mp ip http server
ip pim bidir-enable
!
!
!
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps casa
snmp-server enable traps isdn call-information
snmp-server enable traps isdn layer2
snmp-server enable traps isdn isdnu-interface
snmp-server enable traps hsrp
snmp-server enable traps config
snmp-server enable traps entity
snmp-server enable traps envmon
snmp-server enable traps bgp
snmp-server enable traps rsvp
snmp-server enable traps frame-relay
snmp-server enable traps rtr
snmp-server enable traps syslog
snmp-server enable traps dlsw
snmp-server enable traps dial
snmp-server enable traps voice poor-qov
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
password ******
login local
rotary 1
length 49
width 132
transport input ssh
!
!
end
-- Snip --
The error I'm getting from debug is:
00:38:20: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
00:38:20: Vi1 PPP: Treating connection as a callout
00:38:20: Vi1 PPP: Authorization NOT required
00:38:20: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1
00:38:20: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
Any Ideas on what I'm missing. The DSL connection works fine plugged into my laptop.
(I also realize I missing a ton of security in this config but my aim is to get it working first.)
Thanks,
James Pedersen
pedersen@pobox.com
-- Snip --
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname K2
!
boot system flash
logging buffered 4096 debugging
enable secret 5 ******************
!
username ****** password 0 ******
ip subnet-zero
!
!
no ip domain-lookup
ip domain-name none.net
!
ip audit notify log
ip audit po max-events 100
ip ssh source-interface Ethernet2/0
vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!
!
!
!
!
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
partition slot1: 2 8 8
!
!
!
!
!
interface Ethernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
half-duplex
!
interface Serial0/0
no ip address
shutdown
!
interface BRI0/0
no ip address
shutdown
!
interface TokenRing0/0
no ip address
shutdown
ring-speed 16
!
interface Serial1/0
no ip address
shutdown
!
interface Serial1/1
no ip address
shutdown
!
interface Serial1/2
no ip address
shutdown
!
interface Serial1/3
no ip address
shutdown
!
interface BRI2/0
no ip address
shutdown
!
interface Ethernet2/0
no ip address
half-duplex
pppoe enable
pppoe-client dial-pool-number 2
pppoe-client dial-pool-number 1
!
interface Serial2/0
no ip address
shutdown
!
interface Ethernet2/1
no ip address
half-duplex
pppoe enable
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap
ppp chap hostname *****************
ppp chap password 0 **************
!
router ospf 1
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0
!
ip nat inside source list 101 interface Dialer1 overload
no ip classless
mp ip http server
ip pim bidir-enable
!
!
!
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps casa
snmp-server enable traps isdn call-information
snmp-server enable traps isdn layer2
snmp-server enable traps isdn isdnu-interface
snmp-server enable traps hsrp
snmp-server enable traps config
snmp-server enable traps entity
snmp-server enable traps envmon
snmp-server enable traps bgp
snmp-server enable traps rsvp
snmp-server enable traps frame-relay
snmp-server enable traps rtr
snmp-server enable traps syslog
snmp-server enable traps dlsw
snmp-server enable traps dial
snmp-server enable traps voice poor-qov
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
password ******
login local
rotary 1
length 49
width 132
transport input ssh
!
!
end
-- Snip --
The error I'm getting from debug is:
00:38:20: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
00:38:20: Vi1 PPP: Treating connection as a callout
00:38:20: Vi1 PPP: Authorization NOT required
00:38:20: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1
00:38:20: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
Any Ideas on what I'm missing. The DSL connection works fine plugged into my laptop.
(I also realize I missing a ton of security in this config but my aim is to get it working first.)
Thanks,
James Pedersen
pedersen@pobox.com