Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations strongm on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

2600 and dialup over ISDN having trouble with understanding dialers 1

Status
Not open for further replies.
Feb 20, 2002
265
GB
Hi, sorry I have asked a question like this before, but failed to ever get a working answer, I have got further with this now, but am still running into trouble.
I think the problem is my lack of understanding on the dialer-groups (I have looked at the cisco online help, but it doesnt explain any better). The configuration below works fine for dialer 1, but dialer 2 always gives me an error saying...

2d08h: Di2 DDR: No free dialer - starting fast idle timer
2d08h: Di2 DDR: No free dialer - starting fast idle timer
(Using "debug dialer events")

Can anybody explain where I am going wrong, both of these are rare connections and I would like them to share a single ISDN.

Thanks
Simon

------------------------------------------------------------

Building configuration...

Current configuration : 2070 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2610dr
!
enable secret 5 xxxxxxxxxxxxx
!
ip subnet-zero
!
!
!
isdn switch-type basic-net3
!
!
!
interface FastEthernet0/0
ip address 192.168.101.97 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface BRI1/0
no ip address
ip nat outside
encapsulation ppp
dialer rotary-group 1
isdn switch-type basic-net3
no cdp enable
!
interface BRI1/1
no ip address
shutdown
isdn switch-type basic-net3
!
interface BRI1/2
no ip address
isdn switch-type basic-net3
!
interface BRI1/3
no ip address
isdn switch-type basic-net3
!
interface BRI1/4
no ip address
shutdown
isdn switch-type basic-net3
!
interface BRI1/5
no ip address
shutdown
isdn switch-type basic-net3
!
interface BRI1/6
no ip address
shutdown
isdn switch-type basic-net3
!
interface BRI1/7
no ip address
isdn switch-type basic-net3
!
interface Async1
no ip address
!
interface Async2
no ip address
!
interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer in-band
dialer string 909090909090
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp pap sent-username XXXXX password 0 XXXXX
!
interface Dialer2
ip address negotiated
ip nat outside
encapsulation ppp
dialer in-band
dialer string 101010101
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp pap sent-username XXXXX password 0 XXXXXX
!
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source list 2 interface Dialer2 overload
ip classless
ip route 10.10.10.10 255.255.255.255 Dialer1
ip route 20.20.20.20 255.255.255.255 Dialer2
no ip http server
ip pim bidir-enable
!
!
access-list 1 permit 192.168.101.0 0.0.0.255
access-list 2 permit 192.168.101.0 0.0.0.255
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
!
line con 0
line 1 2
line aux 0
line vty 0 4
password XXXXXX
login
!
!
end

2610dr#
 
Ok, you're nearly there...

The "dialer-group 1" command in each of your Dialer Interface configs relates to the dialer-list you setup to forward intersting traffic to a dialer.

so if both dialers are interested in all IP traffic you only need "dialer-group 1" in each Dialer Interface config. And only 1 corresponding dialer list, eg.
dialer-list 1 protocol ip permit

dialer-list number = dialer-group number

The IP routes you configure, indicate which Dialer Interface should be used for each route.

Finally add the physical and logical dialers into a pool.
remove the legacy DDR config command "dialer rotary-group"
and add the BRI to pool 1.
"dialer pool-member 1"

then configure each dialer interface with the same pool
interface dialer 1
dialer pool 1

interface dialer 2
dialer pool 1

Good Luck,
Phil.

If everything is coming your way then you're in the wrong lane.
 
Thanks for the answer, its a real help.. These duplicated commands that are there for legacy alway catch me out...

1 more thing though if I may, this line...

"ip nat inside source list 1 interface Dialer1 overload"

how do I get this NAT to also effect Dialer2????

if I type the same this but with Dialer2 it over rights the Dialer 1 entry, but if both dialers are in pool 1 then howelse do I do it???

This??

ip nat inside source route-map pool pool 1 overload

??

Ta
 
Your access lists in this case define what addresses are eligible for NAT.

So you can have two identical ACLs one for each dialer.
access-list 1 permit 192.168.101.0 0.0.0.255
access-list 2 permit 192.168.101.0 0.0.0.255

and define NAT for each Dialer
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source list 2 interface Dialer2 overload

You could tie your access lists down further to only NAT for the specific destination hosts e.g.

access-list 101 permit ip 192.168.101.0 0.0.0.255 host 10.10.10.10
ip nat inside source list 101 interface Dialer1 overload

will only NAT your internal hosts desined for 10.10.10.10

good luck.


If everything is coming your way then you're in the wrong lane.
 
OK splendid, I think I have it working, so a big thanks for you help, 1 more minor thing if I may.

We are using a FTP conenction over this, but currently the FTP times out the first time (while all the connection dialup is done) and then when you retry it connect's. It sound like this command should have maybe sorted it..

dialer hold-queue 50

but it does not seem to do what I though :)

Any clues??

Ta
Simon
 
BRI Dial up is usually pretty quick, and wouldn't normally cause FTP timeouts. But if it does then the command you have there "dialer hold-queue 50" (conf'd on the BRI interface) will buffer 50 packets (maximum is 100). You can also specify a timeout (how long it will hold those packets for) e.g. dialer hold-queue 50 timeout 60.

To check whether it is the dialup that is causing the timeout (which it does sound like) debug the ISDN call.

# terminal monitor
(will throw debug / logg messages to your console)
# debug isdn q931

then start your first FTP, and watch the dialer call the far end. If the connection is made before the timeout, then your problem may not be the dialup time. Let me know the outcome,

Cheers.

If everything is coming your way then you're in the wrong lane.
 
OK, had to work on some other stuff hence the slooow responce..

You know when things start really getting on you tits?? well this is becoming 1 of those :)

All the dialups work, but I am still having problems with the NAT's, I make a FTP connection to Dialer1 and that works, I make a connection to Dialer2 and "DEBUG IP NAT EVENTS" shows me that the address is being translated to the NAT given to Dialer1, this should be a new NAT.
Also Dialer3 has a Static NAT, how do I put that in to make sure that only connections to Dialer3 are translated to this static IP. I have attached the lower end of the config, so I hope somebody can see where I am going wrong..

Thanks
Simon



interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer string 11111111111
dialer hold-queue 50
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp pap sent-username SECRET password SECRET
!
interface Dialer2
mtu 1400
ip address negotiated
ip nat outside
encapsulation ppp
no ip split-horizon
dialer pool 1
dialer string 222222222222
dialer-group 2
no cdp enable
ppp authentication chap pap callin
ppp pap sent-username SECRET password SECRET
!
interface Dialer3
ip address 192.168.105.6 255.255.255.252
ip nat outside
encapsulation ppp
dialer pool 1
dialer string 333333333333
dialer-group 3
ppp authentication chap
ppp chap hostname SECRET
ppp chap password 0 SECRET
multilink load-threshold 100 outbound
!
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source list 2 interface Dialer2 overload
ip classless
ip route 10.10.10.0 255.255.255.0 Dialer1
ip route 20.20.20.20 255.255.255.255 Dialer3
ip route 30.30.30.0 255.255.255.0 Dialer2
no ip http server
ip pim bidir-enable
!
!
access-list 1 permit 192.168.101.0 0.0.0.255
access-list 2 permit 192.168.101.0 0.0.0.255
access-list 3 permit 192.168.101.0 0.0.0.255
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
dialer-list 3 protocol ip permit
!
line con 0
line 1 2
stopbits 1
speed 115200
line aux 0
line vty 0 4
password cisco
login
!
!
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top