Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations TouchToneTommy on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

1610 Router 1

Status
Not open for further replies.

Bigpants

IS-IT--Management
May 12, 2005
9
US
I am new to these routers and I need a little help.

I have a cable modem which is 6Mbps Up and 1.5 Down. What I want to do is to route traffic from Internet through Cisco 1610 and then into internal network and vice-versa.

How do I setup NAT and external DNS Servers for the router? and the external gateway?

Current configuration : 1085 bytes
!
! Last configuration change at 15:14:56 UTC Thu May 12 2005
! NVRAM config last updated at 13:57:45 UTC Thu May 12 2005
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname **********
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$27rQ$hL7jMnGqN0ifuqQs71myL.
!
no aaa new-model
ip subnet-zero
!
!
ip host Barry 192.168.2.254
ip audit notify log
ip audit po max-events 100
!
!
interface Ethernet0/0
description Tightline Internal LAN, Barry
ip address 192.168.2.253 255.255.255.0

full-duplex
!
interface Serial0/0
no ip address
shutdown
!
interface Serial0/1
no ip address
shutdown
!
interface Ethernet1/0
ip address 24.75.158.210 255.255.255.240
full-duplex
!
!
ip http server
no ip http secure-server
ip classless
ip route profile
!
!
ip classless
ip route profile
!
!
banner motd ^C This is a secure system, Authorized Access Only ^C
!
!
end

Any help will be greatly appreciated

Cheers
Colin
 
Assumption:

1) ISP provides only 1 public IP address which is 24.75.158.210
2) The IP address on the cable modem is 24.75.158.209
3) You want to translate 192.168.2.x to 24.75.158.210 by PAT
4) The external DNS server IP address is 1.1.1.1

NAT/PAT Configuration:

!
int e0/0
ip nat inside
!
int e1/0
ip nat outside
!
access-list 101 permit ip 192.168.2.0 255.255.255.0 any
!
ip nat inside source list 101 interface e1/0 overload
!

Default gateway configuration:

!
ip route 0.0.0.0 0.0.0.0 24.75.158.209
!

DNS configuration:

!
ip name-server 1.1.1.1
!

 
Lambert thanks for the response and that will help butlet me go into more detail.

We have 1 cable modem. The connection comes into a switch and then into 5 1610 routers. These routers have been setup with 2 ethernet ports. They basically will be acting as gateways.

Each router has an external IP address and then an internal IP Address. The external addresses and gateway/DNS Servers are as follows:

Static – 24.75.158.210
Static – 24.75.158.211
Static – 24.75.158.212
Static – 24.75.158.213
Static – 24.75.158.214
Static – 24.75.158.215

Default Gateway – 24.75.158.209
Subnet mask – 255.255.255.240

Primary DNS Server – 67.21.13.2
Secondary DNS Server – 67.21.13.4

What I need to know is show to set the external information into the Ethernet 1/0 Port.

Also how do I setup NAT?

Thanks for the help in this matter I am new to this and Cisco routers can be very confusing

Cheers
 
So 5 routers sharing the same cable connection? How many internal LAN subnets you have?

Btw, do you want your client PCs to use those external DNS servers to resolve hostnames/URLs, or do you want those routers to use these DNS servers to resolve hostnames/URLs?
 
Lambent,
Firstly thanks for all the help so far it is very appreciated. I am new to this and the Ciscos are not very friendly

Yes the 5 routers will be sharing the same cable connection.

They will each be using the same internal subnet, but I want to assign specific machines to use a router as the gateway to the internet. I need to do this as I have a problem with a site that allows only a certian amount of connections per IP address.

So to overcome this I want to use the 5 External IP addresses. I have 10 machines sitting in the same local internal subnet and I wanted to point 2 internal machines to each router to use as a gateway. Thus overcoming my problem.

I would like the routers to resolve all the DNS names to ease the load on the machines.

Also just one other thing there is a 4 Port Ethernet Module which can be plugged into these routers. Can this module be used so that each of the ethernet ports can have an external IP address?


 
Actually you can just use 1 router to do this but I'll stick to your own design with 5 routers, 1 common public subnet and 1 common internal subnet:

Assumption:

1) Router A is using 24.75.158.210 and 192.168.2.253
2) Router B is using 24.75.158.211 and 192.168.2.252
3) Router C is using 24.75.158.212 and 192.168.2.251
4) Router D is using 24.75.158.213 and 192.168.2.250
5) Router E is using 24.75.158.214 and 192.168.2.249

Then for Router A:

!
int e0/0
description Tightline Internal LAN, Barry
ip address 192.168.2.253 255.255.255.0
ip nat inside
!
int e1/0
description To Internet
ip address 24.75.158.210 255.255.255.240
full-duplex
ip nat outside
!
access-list 101 permit ip 192.168.2.0 255.255.255.0 any
!
ip nat inside source list 101 interface e1/0 overload
!
ip route 0.0.0.0 0.0.0.0 24.75.158.209
!

That's it. Change the IP addresses on interface e0/0 and e1/0 for Router B and so on.

I still don't get your DNS issue but I think you can just set those external DNS servers in each of the machines.

About that 4-port ethernet module I guess it should be only a layer-2 switch module so you can't have IP addresses on them. Really not sure...
 
How would you do this with one router? I didn't realize you could do this with one router and still use the 5 external IP addresses?

Wouldn't there be a bottleneck?

 
The config will be like this:

Router A:

!
int e0/0
description Tightline Internal LAN, Barry
ip address 192.168.2.253 255.255.255.0
ip nat inside
!
int e1/0
description To Internet
ip address 24.75.158.210 255.255.255.240
full-duplex
ip nat outside
!
access-list 1 permit host 192.168.2.1
access-list 1 permit host 192.168.2.2
access-list 2 permit host 192.168.2.3
access-list 2 permit host 192.168.2.4
access-list 3 permit host 192.168.2.5
access-list 3 permit host 192.168.2.6
access-list 4 permit host 192.168.2.7
access-list 4 permit host 192.168.2.8
access-list 5 permit host 192.168.2.9
access-list 5 permit host 192.168.2.10
!
ip nat pool pool1 24.75.158.211 24.75.158.211 netmask 255.255.255.240
ip nat pool pool2 24.75.158.212 24.75.158.212 netmask 255.255.255.240
ip nat pool pool3 24.75.158.213 24.75.158.213 netmask 255.255.255.240
ip nat pool pool4 24.75.158.214 24.75.158.214 netmask 255.255.255.240
ip nat pool pool5 24.75.158.215 24.75.158.215 netmask 255.255.255.240
!
ip nat inside source list 1 pool pool1 overload
ip nat inside source list 2 pool pool2 overload
ip nat inside source list 3 pool pool3 overload
ip nat inside source list 4 pool pool4 overload
ip nat inside source list 5 pool pool5 overload
!
ip route 0.0.0.0 0.0.0.0 24.75.158.209
!

 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top