Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations strongm on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Wild card on eigrp

Status
Not open for further replies.

localbuilt

Technical User
Dec 20, 2007
6
US
Im a bit confused with the wild card when setting up the eigpr routing policy. Can someone help me understand what these means. I know Im suppose to ignore the first 3 octets..

network 192.168.51.100 0.0.0.3
network 192.168.63.0 0.0.0.127
network 192.168.63.0 0.0.0.255
 
As with ACL's the wildcard mask is inverse.

Consider the following configuration:
Code:
interface FastEthernet0/1
 ip address 192.168.63.126 255.255.255.128
!
interface FastEthernet0/1
 ip address 192.168.63.254 255.255.255.128
!

By default if you wanted both these interfaces to run EIGRP and be included in the same EIGRP AS then you would configure:
Code:
router eigrp 10
 network 192.168.63.0

and this would work fine. However if you wanted one interface in one EIGRP AS and the other in a different AS then you would need to use the wildcard masks:
Code:
router eigrp 10
 network 192.168.63.0 0.0.0.127
!
router eigrp 20
 network 192.168.63.128 0.0.0.127
!

You could also go the other way and use a network statement with a supernet mask to cover multiple interfaces that share the same 1st part of the network address:
Code:
interface FastEthernet0/0
 ip address 192.168.1.254 255.255.255.0
!
interface FastEthernet0/1
 ip address 192.168.2.254 255.255.255.0
!
interface FastEthernet1/0
 ip address 192.168.3.254 255.255.255.0
!
router eigrp 10
 network 192.168.0.0 0.0.255.255
!

HTH

Andy
 
The matching is saying all addresses/interfaces in the below subnet can participate in the Eigrp routing process.

192.168.51.100 255.255.255.252
192.168.63.0 255.255.255.128
192.168.63.0 255.255.255.0


Regards
 
Take the mask and subtract it from 255.255.255.255...

255.255.255.255 minus 255.255.255.128 = 0.0.0.127

Burt
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top