These 2 routers are connected with WIC cards and its possible to ping from one LAN to the other. The problem i see is that the connected serial interfaces are in different network:
Router 1: 192.168.10.1 255.255.255.0
Router 2: 192.168.20.1 255.255.255.0
------------------------------------------------
Router 1:
interface Loopback1
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 154.151.200.10 255.255.0.0
duplex auto
speed auto
no mop enabled
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:0
ip address 192.168.10.1 255.255.255.0
encapsulation ppp
!
ip classless
ip route 154.151.0.0 255.255.0.0 FastEthernet0/0
ip route 192.100.0.0 255.255.0.0 Serial0/0/0:0
ip route 192.168.2.0 255.255.255.0 Serial0/0/0:0
ip route 192.168.20.0 255.255.255.0 Serial0/0/0:0
ip http server
---------------------------------------
Router 2:
interface Loopback1
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.100.200.10 255.255.0.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:0
ip address 192.168.20.1 255.255.255.0
encapsulation ppp
!
ip classless
ip route 154.151.0.0 255.255.0.0 Serial0/0/0:0
ip route 192.168.10.0 255.255.255.0 Serial0/0/0:0
ip route 192.168.1.0 255.255.255.0 Serial0/0/0:0
ip route 192.100.0.0 255.255.0.0 FastEthernet0/0
ip http server
--------------------------------------
I have only one explanation. Its working because the IP routes are set up in a way where they are not concerned about what IP the other routers have, only on what interface to exit. lets say a guy on 154.151.0.0 is pinging a PC on 192.100.0.0 this route is used:
ip route 192.100.0.0 255.255.0.0 Serial0/0/0:0
which is not concerned about the other router serial 0 IP, but only on what interface to exit to reach 192.100.0.0
is this correct or does there have to be a router in between these routers, routing from one serial 0 to there other serial 0?
Router 1: 192.168.10.1 255.255.255.0
Router 2: 192.168.20.1 255.255.255.0
------------------------------------------------
Router 1:
interface Loopback1
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 154.151.200.10 255.255.0.0
duplex auto
speed auto
no mop enabled
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:0
ip address 192.168.10.1 255.255.255.0
encapsulation ppp
!
ip classless
ip route 154.151.0.0 255.255.0.0 FastEthernet0/0
ip route 192.100.0.0 255.255.0.0 Serial0/0/0:0
ip route 192.168.2.0 255.255.255.0 Serial0/0/0:0
ip route 192.168.20.0 255.255.255.0 Serial0/0/0:0
ip http server
---------------------------------------
Router 2:
interface Loopback1
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.100.200.10 255.255.0.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:0
ip address 192.168.20.1 255.255.255.0
encapsulation ppp
!
ip classless
ip route 154.151.0.0 255.255.0.0 Serial0/0/0:0
ip route 192.168.10.0 255.255.255.0 Serial0/0/0:0
ip route 192.168.1.0 255.255.255.0 Serial0/0/0:0
ip route 192.100.0.0 255.255.0.0 FastEthernet0/0
ip http server
--------------------------------------
I have only one explanation. Its working because the IP routes are set up in a way where they are not concerned about what IP the other routers have, only on what interface to exit. lets say a guy on 154.151.0.0 is pinging a PC on 192.100.0.0 this route is used:
ip route 192.100.0.0 255.255.0.0 Serial0/0/0:0
which is not concerned about the other router serial 0 IP, but only on what interface to exit to reach 192.100.0.0
is this correct or does there have to be a router in between these routers, routing from one serial 0 to there other serial 0?