Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations IamaSherpa on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

WAN QOS for Avaya IP Office SCN network

Status
Not open for further replies.

jlyoung

IS-IT--Management
Feb 14, 2013
3
US
Good Evening Everybody..
I have some Cisco Router code that I would like comments on. I have recently installed an IP Office SCN voice network that uses T1’s between the different SCN nodes and I having QOS problems when data traffic is heavy.

Here is an overview of my network:
The primary IP Office server is hanging on a 3560 that is connected to a 2821 located at Main Node. Node 2 is at Branch1 using a 2901 connected via a pair of multilink’d T1’s. Node 3 is at Branch2 using a 2620 using a single T1.

I read up on AutoQOS, but couldn’t verify that it’s available on all of my routers.. The commands were never available when configuring an interface. Maybe I didn’t have it correctly implemented. There are also some here who do not think AutoQOS is very good anyway.

After browsing and searching and gleaning, I’ve come to the decision to use class-map and policy-map to implement QOS and following is what I’ve come up with for programming on each of the routers.

My questions are… will this work? Am I on the right track? Is the best way to implement? What would you suggest/recommend?

Thanks for any suggestions and/or comments…

Jeffrey

========== Main Node 2821 ==================
!
class-map match-any signal
match ip dscp cs3
match ip dscp af31
class-map match-any voice
match ip dscp ef
!
policy-map branch1
class voice
priority percent 33
class signal
bandwidth percent 5
!
policy-map branch2
class voice
priority percent 33
class signal
bandwidth percent 5
!
policy-map mqc-branch2
class class-default
shape average 1460000 14600 0
service-policy branch2
!
policy-map mqc-branch1
class class-default
shape average 2920000 29200 0
service-policy branch1
!
!
interface Multilink1
description Branch1
bandwidth 3162
ip address 10.10.1.2 255.255.255.0
ip route-cache flow
ppp multilink
ppp multilink group 1
class frame-b1
!
interface Serial0/0/0:0
description Branch1 circuit1
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
!
interface Serial0/0/1:0
description Branch2
bandwidth 1581
ip address 10.10.2.2 255.255.255.0
ip route-cache flow
encapsulation ppp
class frame-b2
!
interface Serial0/3/1:0
description Branch1 circuit2
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1

!
map-class frame-relay frame-b1
service-policy output mqc-branch1
!
map-class frame-relay frame-b2
service-policy output mqc-branch2

====== Branch2 2620 ==============
!
class-map match-any signal
match ip dscp cs3
match ip dscp af31
class-map match-any voice
match ip dscp ef
!
policy-map branch2
class voice
priority percent 33
class signal
bandwidth percent 5
!
policy-map mqc-branch2
class class-default
shape average 1460000 14600 0
service-policy branch2
!
interface Serial0/0
description Main Node
bandwidth 1581
ip address 10.10.2.1 255.255.255.0
ip route-cache flow
encapsulation ppp
service-module t1 timeslots 1-24
class frame-b2
!
map-class frame-relay frame-b2
service-policy output mqc-branch2

=========== Branch1 2901 =========
class-map match-any signal
match ip dscp cs3
match ip dscp af31
class-map match-any voice
match ip dscp ef
!
policy-map branch1
class voice
priority percent 33
class signal
bandwidth percent 5
!
policy-map mqc-branch1
class class-default
shape average 2920000 29200 0
service-policy branch1
!
interface Multilink1
description Main Node
bandwidth 3162
ip address 10.10.1.1 255.255.255.0
ip route-cache flow
ppp multilink
ppp multilink group 1
no cdp enable
class frame-b1
!
interface Serial0/2/0:0
description Main Node
no ip address
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 1
!
interface Serial0/3/0:0
description Main Node
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
!
map-class frame-relay frame-b1
service-policy output mqc-branch1

============ END =======================
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top