hello, i'm sorry if there is so much reading, but i think that many people may find some interesting thoughts in these lines 
we already have VPNs configured on our PIX, but we only use VPN between several remote sites linked through PIXes as well.
What I would like to do is being able to connect to our VPN through our cisco PIX 515 with a windows 2000 client using my DSL connection (changes of ip address every 24h).
I've been doing some readings on the subject but i'm not sure if what i'm going for is right.
First of all, i would like to use pre-shared key authentification, as it is already what we use in our current VPNs. From what i've read i have to use L2TP to build the tunnel with the PIX. Here are some articles i found very interesting on the subject:
So, what i'm going for is using a custom ipsec policy using pre-shared key authentification, MD5 and ESP.
Then i have to create a new connection with the win2k wizard, and i indicate it is for VPN. I pay good attention to choosing the L2TP protocol as well as CHAP and MS-CHAP for the authentification.
Now here is a sample of a PIX configuration for VPN:
Building configuration...
: Saved
:
PIX Version 6.0(0)216
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname PIX-506-2
domain-name sjvpn.com
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 1720
fixup protocol rsh 514
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
names
!--- Do not NAT the l2tp IP pool.
access-list nonat permit ip 20.1.1.0 255.255.255.0 50.1.1.0 255.255.255.0
!--- Permit l2tp traffic.
access-list l2tp permit udp host 171.68.9.57 any eq 1701
no pager
logging on
logging console debugging
logging buffered debugging
interface ethernet0 10baset
interface ethernet1 10baset
mtu outside 1500
mtu inside 1500
ip address outside 171.68.9.57 255.255.255.0
ip address inside 20.1.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
!--- Pool for l2tp address assignment.
ip local pool l2tp 50.1.1.1-50.1.1.5
pdm history enable
arp timeout 14400
!--- Do not NAT the l2tp IP pool.
nat (inside) 0 access-list nonat
route outside 0.0.0.0 0.0.0.0 171.68.9.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323
0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
!--- Authenticate with RADIUS.
aaa-server RADIUS (inside) host 20.1.1.2 cisco timeout 5
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
!--- Permit l2tp connections.
sysopt connection permit-l2tp
no sysopt route dnat
!--- IPSec configuration.
crypto ipsec transform-set l2tp esp-des esp-md5-hmac
!--- Only transport mode is supported.
crypto ipsec transform-set l2tp mode transport
crypto ipsec security-association lifetime seconds 3600
crypto dynamic-map dyna 20 match address l2tp
crypto dynamic-map dyna 20 set transform-set l2tp
crypto map mymap 10 ipsec-isakmp dynamic dyna
crypto map mymap client authentication RADIUS
crypto map mymap interface outside
!--- IKE configuration.
isakmp enable outside
isakmp policy 20 authentication rsa-sig
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 1
isakmp policy 20 lifetime 86400
ca identity sjvpn 171.68.9.149:/certsrv/mscep/mscep.dll
ca configure sjvpn ra 1 20 crloptional
telnet 171.68.9.0 255.255.255.0 inside
telnet 20.1.1.2 255.255.255.255 inside
telnet timeout 60
ssh timeout 5
!--- l2tp configuration.
vpdn group l2tpipsec accept dialin l2tp
vpdn group l2tpipsec ppp authentication chap
vpdn group l2tpipsec ppp authentication mschap
vpdn group l2tpipsec client configuration address local l2tp
vpdn group l2tpipsec client configuration dns 20.1.1.250 20.1.1.251
vpdn group l2tpipsec client configuration wins 20.1.1.250
vpdn group l2tpipsec client authentication aaa RADIUS
vpdn group l2tpipsec client accounting RADIUS
vpdn group l2tpipsec l2tp tunnel hello 60
vpdn enable outside
terminal width 80
Cryptochecksum:06a53009d1e9f04740256d9f0fb82837
: end
[OK]
so as you can see, it uses RADIUS for authentification, not pre-shared key, so here are my modifications:
ip local pool test1 10.250.64.210-10.250.64.212
access-list nonat permit ip 10.250.64.11 255.255.255.0
access-list l2tp permit udp host xx.xx.xx.xx any eq 1701
nat (inside) 0 access-list nonat
sysopt connection permit-l2tp
crypto ipsec transform-set l2tp esp-des esp-md5-hmac
crypto ipsec transform-set l2tp mode transport
crypto ipsec security-association lifetime seconds 3600
crypto dynamic-map dyna 22 match address l2tp
crypto dynamic-map dyna 22 set transform-set l2tp
crypto map mymap 10 ipsec-isakmp dynamic dyna
crypto map mymap interface outside
isakmp enable outside
isakmp key xxxxxxxxxxx address 0.0.0.0 netmask 0.0.0.0
isakmp client configuration address-pool local test1 outside
isakmp policy 22 authentication pre-share
isakmp policy 22 encryption des
isakmp policy 22 hash md5
isakmp policy 22 group 1
isakmp policy 22 lifetime 86400
vpdn group l2tpipsec accept dialin l2tp
vpdn group l2tpipsec ppp authentication chap
vpdn group l2tpipsec ppp authentication mschap
vpdn group l2tpipsec client configuration address local test1
vpdn group l2tpipsec client authentification local
vpdn username XXXX password xxxx
vpdn group l2tpipsec l2tp tunnel hello 60
vpdn enable outside
so, in the VPN connection in Win2k i'll put XXXX as username, and xxxx as password
Has anybody tried this before and could tell me if i'm doing anything wrong ?
we already have VPNs configured on our PIX, but we only use VPN between several remote sites linked through PIXes as well.
What I would like to do is being able to connect to our VPN through our cisco PIX 515 with a windows 2000 client using my DSL connection (changes of ip address every 24h).
I've been doing some readings on the subject but i'm not sure if what i'm going for is right.
First of all, i would like to use pre-shared key authentification, as it is already what we use in our current VPNs. From what i've read i have to use L2TP to build the tunnel with the PIX. Here are some articles i found very interesting on the subject:
So, what i'm going for is using a custom ipsec policy using pre-shared key authentification, MD5 and ESP.
Then i have to create a new connection with the win2k wizard, and i indicate it is for VPN. I pay good attention to choosing the L2TP protocol as well as CHAP and MS-CHAP for the authentification.
Now here is a sample of a PIX configuration for VPN:
Building configuration...
: Saved
:
PIX Version 6.0(0)216
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname PIX-506-2
domain-name sjvpn.com
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 1720
fixup protocol rsh 514
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
names
!--- Do not NAT the l2tp IP pool.
access-list nonat permit ip 20.1.1.0 255.255.255.0 50.1.1.0 255.255.255.0
!--- Permit l2tp traffic.
access-list l2tp permit udp host 171.68.9.57 any eq 1701
no pager
logging on
logging console debugging
logging buffered debugging
interface ethernet0 10baset
interface ethernet1 10baset
mtu outside 1500
mtu inside 1500
ip address outside 171.68.9.57 255.255.255.0
ip address inside 20.1.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
!--- Pool for l2tp address assignment.
ip local pool l2tp 50.1.1.1-50.1.1.5
pdm history enable
arp timeout 14400
!--- Do not NAT the l2tp IP pool.
nat (inside) 0 access-list nonat
route outside 0.0.0.0 0.0.0.0 171.68.9.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323
0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
!--- Authenticate with RADIUS.
aaa-server RADIUS (inside) host 20.1.1.2 cisco timeout 5
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
!--- Permit l2tp connections.
sysopt connection permit-l2tp
no sysopt route dnat
!--- IPSec configuration.
crypto ipsec transform-set l2tp esp-des esp-md5-hmac
!--- Only transport mode is supported.
crypto ipsec transform-set l2tp mode transport
crypto ipsec security-association lifetime seconds 3600
crypto dynamic-map dyna 20 match address l2tp
crypto dynamic-map dyna 20 set transform-set l2tp
crypto map mymap 10 ipsec-isakmp dynamic dyna
crypto map mymap client authentication RADIUS
crypto map mymap interface outside
!--- IKE configuration.
isakmp enable outside
isakmp policy 20 authentication rsa-sig
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 1
isakmp policy 20 lifetime 86400
ca identity sjvpn 171.68.9.149:/certsrv/mscep/mscep.dll
ca configure sjvpn ra 1 20 crloptional
telnet 171.68.9.0 255.255.255.0 inside
telnet 20.1.1.2 255.255.255.255 inside
telnet timeout 60
ssh timeout 5
!--- l2tp configuration.
vpdn group l2tpipsec accept dialin l2tp
vpdn group l2tpipsec ppp authentication chap
vpdn group l2tpipsec ppp authentication mschap
vpdn group l2tpipsec client configuration address local l2tp
vpdn group l2tpipsec client configuration dns 20.1.1.250 20.1.1.251
vpdn group l2tpipsec client configuration wins 20.1.1.250
vpdn group l2tpipsec client authentication aaa RADIUS
vpdn group l2tpipsec client accounting RADIUS
vpdn group l2tpipsec l2tp tunnel hello 60
vpdn enable outside
terminal width 80
Cryptochecksum:06a53009d1e9f04740256d9f0fb82837
: end
[OK]
so as you can see, it uses RADIUS for authentification, not pre-shared key, so here are my modifications:
ip local pool test1 10.250.64.210-10.250.64.212
access-list nonat permit ip 10.250.64.11 255.255.255.0
access-list l2tp permit udp host xx.xx.xx.xx any eq 1701
nat (inside) 0 access-list nonat
sysopt connection permit-l2tp
crypto ipsec transform-set l2tp esp-des esp-md5-hmac
crypto ipsec transform-set l2tp mode transport
crypto ipsec security-association lifetime seconds 3600
crypto dynamic-map dyna 22 match address l2tp
crypto dynamic-map dyna 22 set transform-set l2tp
crypto map mymap 10 ipsec-isakmp dynamic dyna
crypto map mymap interface outside
isakmp enable outside
isakmp key xxxxxxxxxxx address 0.0.0.0 netmask 0.0.0.0
isakmp client configuration address-pool local test1 outside
isakmp policy 22 authentication pre-share
isakmp policy 22 encryption des
isakmp policy 22 hash md5
isakmp policy 22 group 1
isakmp policy 22 lifetime 86400
vpdn group l2tpipsec accept dialin l2tp
vpdn group l2tpipsec ppp authentication chap
vpdn group l2tpipsec ppp authentication mschap
vpdn group l2tpipsec client configuration address local test1
vpdn group l2tpipsec client authentification local
vpdn username XXXX password xxxx
vpdn group l2tpipsec l2tp tunnel hello 60
vpdn enable outside
so, in the VPN connection in Win2k i'll put XXXX as username, and xxxx as password
Has anybody tried this before and could tell me if i'm doing anything wrong ?