Hi all,
I'm trying to set up a vpn connection from an XP client with microsofts L2tp connection using a pre shared key.
I can connect ok and seem to have an ike SA, IPsec tunnel and L2tp seesion but i am unable to see my local network.
Hers is my config.
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxxxxxxxxxxx encrypted
passwd xxxxxxxxxx encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 87.xxxxxx cisco_outside
access-list acl_out permit icmp any any echo-reply
access-list acl_out permit icmp any any unreachable
access-list acl_out permit icmp any any time-exceeded
access-list inside_outbound_nat0_acl permit ip any 192.xxx.xxx.xxx 255.255.255.240
access-list outside_cryptomap_dyn_60 permit ip any 192.xxx.xxx.xxx 255.255.255.240
pager lines 24
logging timestamp
logging buffered errors
logging trap errors
mtu outside 1500
mtu inside 1500
ip address outside 81.xxx.xxx.xxx 255.255.255.248
ip address inside 192.xxx.xxx.xxx 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool new 192.xxx.xxx.xxx-192.xxx.xxx.xxx
pdm location 192.xxx.xxx.xxx 255.255.255.255 inside
pdm location 192.xxx.xxx.xxx 255.255.255.0 inside
pdm location 192.xxx.xxx.xxx 255.255.255.0 inside
pdm location 192.xxx.xxx.xxx 255.255.255.192 outside
pdm location 192.xxx.xxx.xxx 255.255.255.0 outside
pdm location 192.xxx.xxx.xxx 255.255.255.240 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 81.xxx.xxx.xxx-81.xxx.xxx.xxx
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 192.xxx.xxx.xxx 255.255.255.0 0 0
nat (inside) 1 192.xxx.xxx.xxx 255.255.255.0 0 0
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group acl_out in interface outside
route outside 0.0.0.0 0.0.0.0 81.137.57.14 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
tftp-server inside 192.xxx.xxx.xxx /pixconfig.txt
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-l2tp
crypto ipsec transform-set TRANS_ESP_DES_MD5 esp-des esp-md5-hmac
crypto ipsec transform-set TRANS_ESP_DES_MD5 mode transport
crypto ipsec transform-set TRANS_ESP_3DES_MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 40 set transform-set TRANS_ESP_DES_MD5
TRANS_ESP_3DES_MD5
crypto dynamic-map outside_dyn_map 60 match address outside_cryptomap_dyn_60
crypto dynamic-map outside_dyn_map 60 set transform-set TRANS_ESP_DES_MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp nat-traversal 10
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash sha
isakmp policy 20 group 1
isakmp policy 20 lifetime 86400
telnet 192.xxx.xxx.xxx 255.255.255.255 inside
telnet 192.xxx.xxx.xxx 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group L2TP-VPDN-GROUP accept dialin l2tp
vpdn group L2TP-VPDN-GROUP ppp authentication pap
vpdn group L2TP-VPDN-GROUP ppp authentication chap
vpdn group L2TP-VPDN-GROUP ppp authentication mschap
vpdn group L2TP-VPDN-GROUP client configuration address local new
vpdn group L2TP-VPDN-GROUP client configuration dns 192.xxx.xxx.xxx
vpdn group L2TP-VPDN-GROUP client configuration wins 192.xxx.xxx.xxx
vpdn group L2TP-VPDN-GROUP client authentication local
vpdn group L2TP-VPDN-GROUP l2tp tunnel hello 60
vpdn username lblinco password *********
vpdn enable outside
terminal width 80
any tips much appreciated
I'm trying to set up a vpn connection from an XP client with microsofts L2tp connection using a pre shared key.
I can connect ok and seem to have an ike SA, IPsec tunnel and L2tp seesion but i am unable to see my local network.
Hers is my config.
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxxxxxxxxxxx encrypted
passwd xxxxxxxxxx encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 87.xxxxxx cisco_outside
access-list acl_out permit icmp any any echo-reply
access-list acl_out permit icmp any any unreachable
access-list acl_out permit icmp any any time-exceeded
access-list inside_outbound_nat0_acl permit ip any 192.xxx.xxx.xxx 255.255.255.240
access-list outside_cryptomap_dyn_60 permit ip any 192.xxx.xxx.xxx 255.255.255.240
pager lines 24
logging timestamp
logging buffered errors
logging trap errors
mtu outside 1500
mtu inside 1500
ip address outside 81.xxx.xxx.xxx 255.255.255.248
ip address inside 192.xxx.xxx.xxx 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool new 192.xxx.xxx.xxx-192.xxx.xxx.xxx
pdm location 192.xxx.xxx.xxx 255.255.255.255 inside
pdm location 192.xxx.xxx.xxx 255.255.255.0 inside
pdm location 192.xxx.xxx.xxx 255.255.255.0 inside
pdm location 192.xxx.xxx.xxx 255.255.255.192 outside
pdm location 192.xxx.xxx.xxx 255.255.255.0 outside
pdm location 192.xxx.xxx.xxx 255.255.255.240 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 81.xxx.xxx.xxx-81.xxx.xxx.xxx
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 192.xxx.xxx.xxx 255.255.255.0 0 0
nat (inside) 1 192.xxx.xxx.xxx 255.255.255.0 0 0
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group acl_out in interface outside
route outside 0.0.0.0 0.0.0.0 81.137.57.14 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
tftp-server inside 192.xxx.xxx.xxx /pixconfig.txt
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-l2tp
crypto ipsec transform-set TRANS_ESP_DES_MD5 esp-des esp-md5-hmac
crypto ipsec transform-set TRANS_ESP_DES_MD5 mode transport
crypto ipsec transform-set TRANS_ESP_3DES_MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 40 set transform-set TRANS_ESP_DES_MD5
TRANS_ESP_3DES_MD5
crypto dynamic-map outside_dyn_map 60 match address outside_cryptomap_dyn_60
crypto dynamic-map outside_dyn_map 60 set transform-set TRANS_ESP_DES_MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp nat-traversal 10
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash sha
isakmp policy 20 group 1
isakmp policy 20 lifetime 86400
telnet 192.xxx.xxx.xxx 255.255.255.255 inside
telnet 192.xxx.xxx.xxx 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group L2TP-VPDN-GROUP accept dialin l2tp
vpdn group L2TP-VPDN-GROUP ppp authentication pap
vpdn group L2TP-VPDN-GROUP ppp authentication chap
vpdn group L2TP-VPDN-GROUP ppp authentication mschap
vpdn group L2TP-VPDN-GROUP client configuration address local new
vpdn group L2TP-VPDN-GROUP client configuration dns 192.xxx.xxx.xxx
vpdn group L2TP-VPDN-GROUP client configuration wins 192.xxx.xxx.xxx
vpdn group L2TP-VPDN-GROUP client authentication local
vpdn group L2TP-VPDN-GROUP l2tp tunnel hello 60
vpdn username lblinco password *********
vpdn enable outside
terminal width 80
any tips much appreciated