Hi, I am running a Cisco asa 5505 , ver 8.2(1). I have security plus license which DMZ is unrestricted. After reading alot of documentations on Cisco support site and other forums, I just can't figure out why I can't access the DMZ network while connected to my network via VPN client. I can talk to the DMZ network from LAN, but not from VPN client. below is my config. if someone can tell me what I am doing wrong or what I need to do to get it work, I'd be grateful. Thanks in advance.
hostname ciscoasa
names
name 192.168.10.50 GSD
dns-guard
!
interface Vlan1
nameif inside
security-level 100
ip address 10.1.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address XX.XX.XX.51 255.255.255.240
!
interface Vlan3
nameif dmz
security-level 50
ip address 192.168.10.1 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
switchport access vlan 3
!
interface Ethernet0/7
!
boot system disk0:/asa821-k8.bin
ftp mode passive
object-group network gsdwww
description Oracle GSD in DMZ
network-object host GSD
object-group service WEB-PORTS tcp
description Ports to the REHL port-object eq www
port-object eq https
access-list no-nat extended permit ip 10.1.1.0 255.255.255.0 10.6.6.0 255.255.255.0
access-list vpnclient extended permit ip 10.1.1.0 255.255.255.0 10.6.6.0 255.255.255.0
access-list outbound extended permit udp 10.1.1.0 255.255.255.0 10.6.6.0 255.255.255.0 eq netbios-ns
access-list outbound extended permit udp 10.1.1.0 255.255.255.0 10.6.6.0 255.255.255.0 eq netbios-dgm
access-list outbound extended permit tcp 10.1.1.0 255.255.255.0 10.6.6.0 255.255.255.0 eq 137
access-list outbound extended permit tcp 10.1.1.0 255.255.255.0 10.6.6.0 255.255.255.0 eq netbios-ssn
access-list outbound extended permit ip 10.1.1.0 255.255.255.0 any
access-list allow-in extended permit tcp any host XX.XX.XX.51 eq www
access-list nonat_dmz extended permit ip 192.168.10.0 255.255.255.0 10.6.6.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool vpnpool 10.6.6.1-10.6.6.100
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-647.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
global (dmz) 1 interface
nat (inside) 0 access-list no-nat
nat (inside) 1 0.0.0.0 0.0.0.0
nat (dmz) 0 access-list nonat_dmz
nat (dmz) 1 192.168.10.0 255.255.255.0
static (dmz,outside) tcp interface 255.255.255.255
static (inside,dmz) 10.1.1.0 10.1.1.0 netmask 255.255.255.0
access-group outbound in interface inside
access-group allow-in in interface outside
access-group nonat_dmz in interface dmz
route outside 0.0.0.0 0.0.0.0 98.190.149.49 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.1.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map dm10 10 set transform-set ESP-AES-256-SHA
crypto dynamic-map dm10 10 set security-association lifetime seconds 28800
crypto dynamic-map dm10 10 set security-association lifetime kilobytes 4608000
crypto map map1 100 ipsec-isakmp dynamic dm10
crypto map map1 interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption aes-256
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh 10.1.1.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
enable outside
svc image disk0:/anyconnect-win-2.5.2019-k9.pkg 1
svc enable
tunnel-group-list enable
group-policy mynetvpn internal
group-policy mynetvpn attributes
banner value Welcome to my network!
dns-server value 10.1.1.22
vpn-tunnel-protocol IPSec svc
split-tunnel-policy tunnelspecified
split-tunnel-network-list value vpnclient
webvpn
svc dtls enable
svc keep-installer installed
svc ask none default svc
tunnel-group mynetvpn type remote-access
tunnel-group mynetvpn general-attributes
address-pool vpnpool
default-group-policy mynetvpn
tunnel-group mynetvpn webvpn-attributes
group-alias mynetvpn enable
group-url enable
tunnel-group mynetvpn ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect sip
inspect xdmcp
inspect netbios
inspect tftp
inspect pptp
inspect icmp
!
service-policy global_policy global
hostname ciscoasa
names
name 192.168.10.50 GSD
dns-guard
!
interface Vlan1
nameif inside
security-level 100
ip address 10.1.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address XX.XX.XX.51 255.255.255.240
!
interface Vlan3
nameif dmz
security-level 50
ip address 192.168.10.1 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
switchport access vlan 3
!
interface Ethernet0/7
!
boot system disk0:/asa821-k8.bin
ftp mode passive
object-group network gsdwww
description Oracle GSD in DMZ
network-object host GSD
object-group service WEB-PORTS tcp
description Ports to the REHL port-object eq www
port-object eq https
access-list no-nat extended permit ip 10.1.1.0 255.255.255.0 10.6.6.0 255.255.255.0
access-list vpnclient extended permit ip 10.1.1.0 255.255.255.0 10.6.6.0 255.255.255.0
access-list outbound extended permit udp 10.1.1.0 255.255.255.0 10.6.6.0 255.255.255.0 eq netbios-ns
access-list outbound extended permit udp 10.1.1.0 255.255.255.0 10.6.6.0 255.255.255.0 eq netbios-dgm
access-list outbound extended permit tcp 10.1.1.0 255.255.255.0 10.6.6.0 255.255.255.0 eq 137
access-list outbound extended permit tcp 10.1.1.0 255.255.255.0 10.6.6.0 255.255.255.0 eq netbios-ssn
access-list outbound extended permit ip 10.1.1.0 255.255.255.0 any
access-list allow-in extended permit tcp any host XX.XX.XX.51 eq www
access-list nonat_dmz extended permit ip 192.168.10.0 255.255.255.0 10.6.6.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool vpnpool 10.6.6.1-10.6.6.100
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-647.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
global (dmz) 1 interface
nat (inside) 0 access-list no-nat
nat (inside) 1 0.0.0.0 0.0.0.0
nat (dmz) 0 access-list nonat_dmz
nat (dmz) 1 192.168.10.0 255.255.255.0
static (dmz,outside) tcp interface 255.255.255.255
static (inside,dmz) 10.1.1.0 10.1.1.0 netmask 255.255.255.0
access-group outbound in interface inside
access-group allow-in in interface outside
access-group nonat_dmz in interface dmz
route outside 0.0.0.0 0.0.0.0 98.190.149.49 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.1.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map dm10 10 set transform-set ESP-AES-256-SHA
crypto dynamic-map dm10 10 set security-association lifetime seconds 28800
crypto dynamic-map dm10 10 set security-association lifetime kilobytes 4608000
crypto map map1 100 ipsec-isakmp dynamic dm10
crypto map map1 interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption aes-256
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh 10.1.1.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
enable outside
svc image disk0:/anyconnect-win-2.5.2019-k9.pkg 1
svc enable
tunnel-group-list enable
group-policy mynetvpn internal
group-policy mynetvpn attributes
banner value Welcome to my network!
dns-server value 10.1.1.22
vpn-tunnel-protocol IPSec svc
split-tunnel-policy tunnelspecified
split-tunnel-network-list value vpnclient
webvpn
svc dtls enable
svc keep-installer installed
svc ask none default svc
tunnel-group mynetvpn type remote-access
tunnel-group mynetvpn general-attributes
address-pool vpnpool
default-group-policy mynetvpn
tunnel-group mynetvpn webvpn-attributes
group-alias mynetvpn enable
group-url enable
tunnel-group mynetvpn ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect sip
inspect xdmcp
inspect netbios
inspect tftp
inspect pptp
inspect icmp
!
service-policy global_policy global