This is my first ASA and have figured most of it out. Had it working perfectly with the Cisco VPN client, but due to needing x64 clients, had to resort to AnyConnect client. Using split tunneling and connecting fine.
Cannot ping/access any internal servers and I'm sure its probably a routing / acl problem.
When pinging from the client (10.10.10.1), to the inside interface (10.0.10.4) I get a icmp denied response. It sees it.
When I try to ping a server(10.0.10.3) - nothing hits the log.
I can ping from the server to the inside interface, but NOT to the client. Its like there is no route from the client through the ASA to the servers.
Below is my running config. I also have route prints from the client/server if needed.
Thanks, Kevin
ASA Version 8.2(2)
!
hostname mycisco
domain-name evtgroup.local
enable password s.z/tIiXdQaRP4c9 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
dns-guard
!
interface Ethernet0/0
nameif outside
security-level 0
ip address 1.2.3.4 255.255.255.128
!
interface Ethernet0/1
nameif EVTfeed
security-level 100
ip address 10.0.10.4 255.255.255.0
!
interface Ethernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
ip address 10.0.0.236 255.255.255.0
management-only
!
boot system disk0:/asa822-k8.bin
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring 1 Sun Apr 2:00 last Sun Oct 2:00
dns domain-lookup EVTfeed
dns server-group DNS2
name-server 209.51.197.221
name-server 208.67.222.222
dns server-group DefaultDNS
name-server 10.0.10.3
domain-name evtgroup.local
object-group service RDP tcp-udp
port-object range 3389 3389
access-list EVTfeed_nat0_outbound extended permit ip any 10.0.10.176 255.255.255.240
access-list EVTfeed_nat0_outbound extended permit ip interface EVTfeed 10.10.10.0 255.255.255.192
access-list EVTsplitACL standard permit 10.0.10.0 255.255.255.0
access-list no_nat extended permit ip 10.0.10.0 255.255.255.0 10.10.10.0 255.255.255.0
access-list no_nat extended permit ip 10.10.10.0 255.255.255.0 10.0.10.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu EVTfeed 1500
mtu management 1500
ip local pool evtpool 10.10.10.1-10.10.10.50 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-625.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (EVTfeed) 0 access-list no_nat
nat (EVTfeed) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 1.2.3.5 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
dynamic-access-policy-record EVTaccess
description "For EVT vpn users"
network-acl EVTfeed_nat0_outbound
aaa-server EVTusers protocol nt
aaa-server EVTusers (EVTfeed) host 10.0.10.3
timeout 5
nt-auth-domain-controller EVT-SBS
http server enable
http 10.0.0.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp identity hostname
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
no crypto isakmp nat-traversal
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd ping_timeout 750
!
dhcprelay server 10.0.0.1 management
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
tftp-server EVTfeed 10.0.10.25 asa5510
webvpn
enable outside
svc image disk0:/anyconnect-dart-win-2.4.1012-k9.pkg 1
svc enable
group-policy DfltGrpPolicy attributes
vpn-tunnel-protocol IPSec l2tp-ipsec
group-policy EVTgroup internal
group-policy EVTgroup attributes
wins-server value 10.0.10.3
dns-server value 10.0.10.3
vpn-tunnel-protocol svc webvpn
split-tunnel-policy tunnelspecified
split-tunnel-network-list value EVTsplitACL
address-pools value evtpool
webvpn
url-list value EVT
svc ask enable
username ldavsko password AkXP.31BFd15LaZX encrypted
username ldavsko attributes
vpn-group-policy EVTgroup
service-type remote-access
webvpn
url-list value EVT
username kprice password B9gX9eeeHZcuQy/E encrypted privilege 15
username kprice attributes
vpn-group-policy EVTgroup
tunnel-group EVTusers type remote-access
tunnel-group EVTusers general-attributes
address-pool evtpool
authorization-server-group LOCAL
default-group-policy EVTgroup
tunnel-group EVTusers webvpn-attributes
nbns-server 10.0.10.3 master timeout 2 retry 2
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns migrated_dns_map_1
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns migrated_dns_map_1
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
!
Cannot ping/access any internal servers and I'm sure its probably a routing / acl problem.
When pinging from the client (10.10.10.1), to the inside interface (10.0.10.4) I get a icmp denied response. It sees it.
When I try to ping a server(10.0.10.3) - nothing hits the log.
I can ping from the server to the inside interface, but NOT to the client. Its like there is no route from the client through the ASA to the servers.
Below is my running config. I also have route prints from the client/server if needed.
Thanks, Kevin
ASA Version 8.2(2)
!
hostname mycisco
domain-name evtgroup.local
enable password s.z/tIiXdQaRP4c9 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
dns-guard
!
interface Ethernet0/0
nameif outside
security-level 0
ip address 1.2.3.4 255.255.255.128
!
interface Ethernet0/1
nameif EVTfeed
security-level 100
ip address 10.0.10.4 255.255.255.0
!
interface Ethernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
ip address 10.0.0.236 255.255.255.0
management-only
!
boot system disk0:/asa822-k8.bin
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring 1 Sun Apr 2:00 last Sun Oct 2:00
dns domain-lookup EVTfeed
dns server-group DNS2
name-server 209.51.197.221
name-server 208.67.222.222
dns server-group DefaultDNS
name-server 10.0.10.3
domain-name evtgroup.local
object-group service RDP tcp-udp
port-object range 3389 3389
access-list EVTfeed_nat0_outbound extended permit ip any 10.0.10.176 255.255.255.240
access-list EVTfeed_nat0_outbound extended permit ip interface EVTfeed 10.10.10.0 255.255.255.192
access-list EVTsplitACL standard permit 10.0.10.0 255.255.255.0
access-list no_nat extended permit ip 10.0.10.0 255.255.255.0 10.10.10.0 255.255.255.0
access-list no_nat extended permit ip 10.10.10.0 255.255.255.0 10.0.10.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu EVTfeed 1500
mtu management 1500
ip local pool evtpool 10.10.10.1-10.10.10.50 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-625.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (EVTfeed) 0 access-list no_nat
nat (EVTfeed) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 1.2.3.5 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
dynamic-access-policy-record EVTaccess
description "For EVT vpn users"
network-acl EVTfeed_nat0_outbound
aaa-server EVTusers protocol nt
aaa-server EVTusers (EVTfeed) host 10.0.10.3
timeout 5
nt-auth-domain-controller EVT-SBS
http server enable
http 10.0.0.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp identity hostname
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
no crypto isakmp nat-traversal
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd ping_timeout 750
!
dhcprelay server 10.0.0.1 management
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
tftp-server EVTfeed 10.0.10.25 asa5510
webvpn
enable outside
svc image disk0:/anyconnect-dart-win-2.4.1012-k9.pkg 1
svc enable
group-policy DfltGrpPolicy attributes
vpn-tunnel-protocol IPSec l2tp-ipsec
group-policy EVTgroup internal
group-policy EVTgroup attributes
wins-server value 10.0.10.3
dns-server value 10.0.10.3
vpn-tunnel-protocol svc webvpn
split-tunnel-policy tunnelspecified
split-tunnel-network-list value EVTsplitACL
address-pools value evtpool
webvpn
url-list value EVT
svc ask enable
username ldavsko password AkXP.31BFd15LaZX encrypted
username ldavsko attributes
vpn-group-policy EVTgroup
service-type remote-access
webvpn
url-list value EVT
username kprice password B9gX9eeeHZcuQy/E encrypted privilege 15
username kprice attributes
vpn-group-policy EVTgroup
tunnel-group EVTusers type remote-access
tunnel-group EVTusers general-attributes
address-pool evtpool
authorization-server-group LOCAL
default-group-policy EVTgroup
tunnel-group EVTusers webvpn-attributes
nbns-server 10.0.10.3 master timeout 2 retry 2
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns migrated_dns_map_1
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns migrated_dns_map_1
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
!