Not able to see my client join the VLC players streams based on the configs/toplogy below.
I'm running an IGMPv3 SSM environment in a 232.255.x.x range. However, the VLC keeps defaulting to 239.255.255.250 on the Vlan 999 that it's playing into.
Topology:
c6506 --- 4503 <--- VLC --- 4948 <--- Client
cisco6506#sh ip igmp g
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter
232.255.99.1 Vlan209 17:31:59 stopped 0.0.0.0
224.0.1.40 Loopback0 6w5d 00:02:27 10.115.5.5
cisco6506#sh ip pim rp
Group: 232.255.99.1
Group: 224.0.1.40, RP: 10.115.5.5, next RP-reachable in 00:00:15
cisco6506#sh run int vlan 999
interface Vlan999 (VLC Player vlan)
ip address 10.115.99.5 255.255.255.240
ip pim sparse-mode
ip igmp version 3
shutdown
end
!
interface Vlan209 (Client Vlan)
ip address 10.115.209.5 255.255.255.0
ip pim sparse-mode
ip igmp version 3
end
---
cisco4503#sh run int g1/3
interface GigabitEthernet1/3
switchport access vlan 999
switchport mode access
switchport nonegotiate
cisco4503#sh ip igmp sn g
Vlan Group Version Port List
---------------------------------------
999 239.255.255.250v3 Gi1/3
cisco4948#sh run int g1/9
interface GigabitEthernet1/9
description IGMP Client
switchport access vlan 209
switchport mode access
switchport nonegotiate
cisco4948#sh ip igmp sn g
Vlan Group Version Port List
-----------------------------------------
209 232.255.99.1 v3 Gi1/9
I'm running an IGMPv3 SSM environment in a 232.255.x.x range. However, the VLC keeps defaulting to 239.255.255.250 on the Vlan 999 that it's playing into.
Topology:
c6506 --- 4503 <--- VLC --- 4948 <--- Client
cisco6506#sh ip igmp g
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter
232.255.99.1 Vlan209 17:31:59 stopped 0.0.0.0
224.0.1.40 Loopback0 6w5d 00:02:27 10.115.5.5
cisco6506#sh ip pim rp
Group: 232.255.99.1
Group: 224.0.1.40, RP: 10.115.5.5, next RP-reachable in 00:00:15
cisco6506#sh run int vlan 999
interface Vlan999 (VLC Player vlan)
ip address 10.115.99.5 255.255.255.240
ip pim sparse-mode
ip igmp version 3
shutdown
end
!
interface Vlan209 (Client Vlan)
ip address 10.115.209.5 255.255.255.0
ip pim sparse-mode
ip igmp version 3
end
---
cisco4503#sh run int g1/3
interface GigabitEthernet1/3
switchport access vlan 999
switchport mode access
switchport nonegotiate
cisco4503#sh ip igmp sn g
Vlan Group Version Port List
---------------------------------------
999 239.255.255.250v3 Gi1/3
cisco4948#sh run int g1/9
interface GigabitEthernet1/9
description IGMP Client
switchport access vlan 209
switchport mode access
switchport nonegotiate
cisco4948#sh ip igmp sn g
Vlan Group Version Port List
-----------------------------------------
209 232.255.99.1 v3 Gi1/9